Contribute
Register
Joined
Jan 24, 2013
Messages
18
Motherboard
ASRock X299 OC Formula
CPU
i9-9900X OC @4.7 GHz
Graphics
3x GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello!

I use a MSI Z77A-G45 Thunderbolt motherboard and have a i5-3570K @ 4.2 Ghz processor. The two graphics cards I'm using are the GTX 1080 Ti and GTX 1070 Ti. I use octane render with Cinema 4D for a lot fo my work and need the extra GPU power. Whenever I have both cards plugged in at the same time, I get graphical errors on certain GPU accelerated programs, like Spotify and even clover configurator. The graphic cards both work fine plugged in solo and work without issues on the windows boot. Anyone have an idea on what's going on? I've disabled integrated graphics and selected PEG as my BIOS option. I also read somewhere that you may have to select in the BIOS one card as your primary to avoid any issues but unfortunately my BIOS do not offer that option. When both cards are plugged in, it has no issues with GPU acceleration and works within octane. However, within Cinema 4D the viewport is no longer utilizing Open GL. I fear that MacOS is having a hard to choosing which card to use. Is there any way to force a primary card with an SSDT or something?

Is my setup just getting too old to hang with the fresh updated graphics cards?

Also I've attached my config.plist


Thank you!
 

Attachments

  • config.plist
    7.7 KB · Views: 121
Joined
Aug 3, 2018
Messages
5
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
AMD RADEON 5700XT, AMD RADEON VII
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Hello!

I use a MSI Z77A-G45 Thunderbolt motherboard and have a i5-3570K @ 4.2 Ghz processor. The two graphics cards I'm using are the GTX 1080 Ti and GTX 1070 Ti. I use octane render with Cinema 4D for a lot fo my work and need the extra GPU power. Whenever I have both cards plugged in at the same time, I get graphical errors on certain GPU accelerated programs, like Spotify and even clover configurator. The graphic cards both work fine plugged in solo and work without issues on the windows boot. Anyone have an idea on what's going on? I've disabled integrated graphics and selected PEG as my BIOS option. I also read somewhere that you may have to select in the BIOS one card as your primary to avoid any issues but unfortunately my BIOS do not offer that option. When both cards are plugged in, it has no issues with GPU acceleration and works within octane. However, within Cinema 4D the viewport is no longer utilizing Open GL. I fear that MacOS is having a hard to choosing which card to use. Is there any way to force a primary card with an SSDT or something?

Is my setup just getting too old to hang with the fresh updated graphics cards?

Also I've attached my config.plist


Thank you!

Hello cbutters.
As of today the only NVIDIA driver that works under HS 10.13.6 (17G3025) for multiple GPU is 378.10.10.10.25.106.
Just use the benjamin.dobell's script to force the install and you'll get Open GL back and CUDA working as well. https://www.tonymacx86.com/threads/nvidia-update-simple-way-to-install-nvidia-web-drivers.244987/

Simply paste the following line in a terminal:
Code:
bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh) 378.10.10.10.25.106
 
Joined
Jan 24, 2013
Messages
18
Motherboard
ASRock X299 OC Formula
CPU
i9-9900X OC @4.7 GHz
Graphics
3x GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Worked like a dream! Thank you! Is there any websites you stay up to date on that tell you which Drivers support multiple GPUs? I see you you have 2 1080 Ti's. I'm just wondering for the future when new security updates or os versions come out.
 
Joined
Aug 3, 2018
Messages
5
Motherboard
ASUS WS X299 SAGE/10G
CPU
i9-9980XE
Graphics
AMD RADEON 5700XT, AMD RADEON VII
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Mobile Phone
  1. iOS
Worked like a dream! Thank you! Is there any websites you stay up to date on that tell you which Drivers support multiple GPUs? I see you you have 2 1080 Ti's. I'm just wondering for the future when new security updates or os versions come out.

I'm glad it worked! I struggled quite a while until I found the info in a comment at MacVidCards blog. For now stay away from Mojave and you'll be fine.
 
Joined
Dec 27, 2016
Messages
44
Motherboard
ASUS Z170 ROG MAXIMUS VIII HERO
CPU
i7-6700K
Graphics
Vega 64
Mac
  1. iMac
Mobile Phone
  1. iOS
Hey, great advice, but after working for about an hour in MS Word - Word became sluggish and stuttering. Any advice how to solve this?

Also changing virtual Desktos is also a little bit juddering.
 
Joined
May 14, 2011
Messages
11
Motherboard
Gigabyte G1.Sniper Z97
CPU
i7 - Intel 4790K
Graphics
Zotac 1080 ti Amp Extreme
Mobile Phone
  1. Android
Hello cbutters.
As of today the only NVIDIA driver that works under HS 10.13.6 (17G3025) for multiple GPU is 378.10.10.10.25.106.
Just use the benjamin.dobell's script to force the install and you'll get Open GL back and CUDA working as well. https://www.tonymacx86.com/threads/nvidia-update-simple-way-to-install-nvidia-web-drivers.244987/

Simply paste the following line in a terminal:
Code:
bash <(curl -s https://raw.githubusercontent.com/Benjamin-Dobell/nvidia-update/master/nvidia-update.sh) 378.10.10.10.25.106

Thank you so much for this. I was have so many problem in Chrome because of my dual Nvidia card set up.
 
Joined
Sep 7, 2012
Messages
1
Motherboard
Windows
CPU
Q9550
Graphics
EVGA
Mac
Classic Mac
Mobile Phone
Hi All,

First of all thanks. these drivers helped me get around my issues with my software not functioning.

The following programs kept crashing or lagging before I installed the drivers 378.10.10.10.25.106.
Adobe Premiere Pro 13.1.4 crash using OpenCL,
Adobe After Effects 16.1.2 crash using OpenCL,
Adobe Dimension 2.3 would not display my canvas,
Cinema 4D R20.059 would lag and wouldn't show Nvidia as my renderer but instead Apple.
Google Chrome - The browser would lag, stutter/strobe, text would disappear if I didn't disable hardware acceleration.

Methods Tried that Failed
CUDA Driver Version: 418.163
I tried installing the latest Nvidia drivers 387.10.10.10.40.130, but ran into all the issues mentioned up top. It did display all of the correct graphics card information in my system report but kept crashing everything.

Question
My only concern is looking at the Overview and its displaying Unknown 256MB... furthermore looking at the video cards VRAM shows the same 256MB then 4095MB for the second one. My physical video cards are (2) 1080 Ti 8GB. I have yet to test the rendering and performance of the cards. Will they run at what is shown or will they perform at the correct memory size/speeds?
Are these the latest drivers that function for multiple video cards?

My specs are
macOS High Sierra 10.13.6 (17G8030)
3.41Ghz i7
32Gb 2133Mhz DDR4
(2) EVGA 1080 Tis 8GB
 

Attachments

  • hackintosh.jpg
    hackintosh.jpg
    371 KB · Views: 139
Joined
Jul 1, 2019
Messages
1
Hi, is there a new driver with multi-GPU support? This driver (378.10.10.10.25.106) when "Displays have separate Spaces" / Mission Controlis enabled when logging in - after a few seconds throws me back to the logins. But otherwise it works and there are no glitches. Thanks in advance!
 
Joined
Mar 5, 2011
Messages
33
Motherboard
Gigabyte X299 UD4 Pro
CPU
i9-9960X
Graphics
2x GTX 1080 Ti
Worked like a dream! Thank you! Is there any websites you stay up to date on that tell you which Drivers support multiple GPUs? I see you you have 2 1080 Ti's. I'm just wondering for the future when new security updates or os versions come out.
Hey! I see you now have 3x 1080ti. Are they all working on macOS?
I'm currently installing High Sierra on my new 9960x with 2x 1080 ti that I was unable to set up both with my previous x99 setup.
And by the way, how is octane/redshift rendering experience with that on your machine? stable? fast?
 
Joined
Jan 24, 2013
Messages
18
Motherboard
ASRock X299 OC Formula
CPU
i9-9900X OC @4.7 GHz
Graphics
3x GTX 1080 Ti
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hey! I see you now have 3x 1080ti. Are they all working on macOS?
I'm currently installing High Sierra on my new 9960x with 2x 1080 ti that I was unable to set up both with my previous x99 setup.
And by the way, how is octane/redshift rendering experience with that on your machine? stable? fast?

They are all working! I however am trying to get on OpenCore. Still trying to figure out DSDT and SSDT editing. Also, considering switching to an ASUS x299 SAGE. My OC Formula has a weird way of handling multi GPU and I think its the source of my issues.

I am running the most current web drivers and CUDA. However, CUDA causes random reboots so I have to disable it unless I'm using it for Octane/Redshift. Octane and Redshift run great but for Octane you have to set your display card as low priority or it will crash. Here is the script I use for enabling\disabling CUDA.


I would say its stable enough for small projects but I have Windows as a backup. It is fast for sure. Hoping OpenCore will solve some issues.
 
Top