Contribute
Register

[SOLVED] NVIDIA GeForce GTX 260 + Sierra

Joined
Sep 12, 2010
Messages
53
Motherboard
MSI Z170A Krait Gaming
CPU
i5-6500
Graphics
GTX 710
Well ... i just enrolled in HS beta and installed the public beta. Seems were back to the same issue with the GTX 260. You get a black screen after install with a cursor. Using nv_disable=1 works but of course the screen flickers etc.
I did also see the Audio greyed out but didn't pursue that. But Microsoft Outlook isn't currently working with the beta at this point.
I never tried using the Sierra nvidastartup.kext to see if that would work either.
 
Joined
Jul 10, 2013
Messages
13
Motherboard
Intel DP55WB
CPU
Intel i7 860 2.8GHz
Graphics
nVidia GTX 260
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello guys. I have successfully installed Mac OS Sierra 10.12.3 on my machine which is kinda old. My specs are Intel DP55WB motherboard, i7 860 CPU and a GTX260 GPU. So I followed your guide and installed NVDAStartup.kext from an older version of Mac but it behaves with some glitches on my computer. Essentially I get strange colors in my status bar or the dock starts to glitch. Sometimes when I open any kind of app (even Finder) I get black borders around my window. What should I do?
Thank you
Anyone?
 
Joined
Sep 7, 2016
Messages
4
Motherboard
Gigabyte GA-Z77X-UD5H-WB WIFI
CPU
Intel Core i5-3570K 3.4GHz
Graphics
MSI GeForce GTX 275
GA-Z77X-UD5H + GTX 275 now works with El Capitan kext (thanks yhiraki !)

It is important to remove web drivers too to make system work (otherwise I got kernel panic, nv_disable=1 was deleted and webdriver option was disabled).
 
Joined
Feb 21, 2011
Messages
101
Motherboard
Asus Rampage V Extreme X99
CPU
i7-5960
Graphics
GTX 1080 Ti
I was trying to upgrade my 10.10.5 hackintosh (Gigabyte GA-X58A-UD7 rev1, Nvidia GeForce GTX 275, latest Clover, MacPro 5.1 smbios) to 10.12.6 (with WebDriver-378.05.05.25f01.pkg Nvidia drivers). I tried using yhiraki's NVDAStartup.kext but I
am stuck at boot with a KP at NVDAStartupWeb.kext. Does this need to be replaced with an older El Capitan version as well ? Which flags and options are needed in Clover ? Anybody willing to share a working config.plist or EFI folder ?
 
Joined
Sep 7, 2016
Messages
4
Motherboard
Gigabyte GA-Z77X-UD5H-WB WIFI
CPU
Intel Core i5-3570K 3.4GHz
Graphics
MSI GeForce GTX 275
I was trying to upgrade my 10.10.5 hackintosh (Gigabyte GA-X58A-UD7 rev1, Nvidia GeForce GTX 275, latest Clover, MacPro 5.1 smbios) to 10.12.6 (with WebDriver-378.05.05.25f01.pkg Nvidia drivers). I tried using yhiraki's NVDAStartup.kext but I
am stuck at boot with a KP at NVDAStartupWeb.kext. Does this need to be replaced with an older El Capitan version as well ? Which flags and options are needed in Clover ? Anybody willing to share a working config.plist or EFI folder ?

1) Uninstall web drivers completely.
2) Install kext from El Capitan (yhiraki post)
3) Boot with active clover option "Inject NVIDIA" (no other "video" options should be present)
 
Joined
Feb 21, 2011
Messages
101
Motherboard
Asus Rampage V Extreme X99
CPU
i7-5960
Graphics
GTX 1080 Ti
1) Uninstall web drivers completely.
2) Install kext from El Capitan (yhiraki post)
3) Boot with active clover option "Inject NVIDIA" (no other "video" options should be present)

Thanks. It worked.
 
Joined
Sep 12, 2010
Messages
53
Motherboard
MSI Z170A Krait Gaming
CPU
i5-6500
Graphics
GTX 710
Well ... as i feared .. the GTX 560 didn't work so well in High Sierra. Got a cheap GT 710 ... no problems :)
 
Joined
Apr 30, 2013
Messages
33
Motherboard
Gigabyte Z490 Vision D rev 1.1
CPU
i5-10400
Graphics
Sapphire RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
To upgrade from Sierra to High Sierra using a GTX260, I managed to resolve KP at startup in this way.
Remove GTX260 and install High Sierra through HD4600 or another motherboard graphic chipset.
Then remove High Sierra NVDA startup kext and install El Capitan NVDA Startup kext as before.
Start Clover 4174+ flagging inject Nvidia and NvidiaGeneric. That's all.
Hope it helps.
 
Joined
Aug 20, 2011
Messages
1
Motherboard
MacPro 5,1
CPU
Dual Xeon 5685 3,33 Ghz 6 Core
Graphics
EVGA GTX 980 TI
Mac
  1. MacBook
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. iMac
  2. Portable
  3. Power Mac
  4. PowerBook
  5. Quadra
Mobile Phone
  1. Android
Thanks yhiraki!!!!

Just done your procedure with High Sierra 10.13.2

With this hardware:

GA-Z68X-UD3H-B3

GTX 285 1GB

It WORKS!!!!

HS is perfectly working. Tested with Cinebench and Uningine Heaven.

Yeah :headbang:
 
Joined
Apr 30, 2013
Messages
33
Motherboard
Gigabyte Z490 Vision D rev 1.1
CPU
i5-10400
Graphics
Sapphire RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
Upgraded from 10.13.1 to 10.13.4 without removing graphic card with combo update. It works. Just updated apfs.efi in EFI. Good!
 
Top