Contribute
Register

[SOLVED] Nvidia GeForce GTX 1080/1070

Status
Not open for further replies.
Joined
Jun 29, 2016
Messages
14
CPU
2 x 3.46GHz Xeon
Graphics
EVGA GTX 1080
Mac
  1. Mac Pro
Mobile Phone
  1. Android
I wonder if the pascal gpus will work in a real mac such as the mac pro 5,1. I would love to have a gtx 1080ti working on my mac pro 5.1
It works
Screen Shot 2017-04-12 at 20.22.06.png

Just to confirm, even with the Nvidia web drivers, un-flashed cards still run at PCIe 1.0 speeds in a Mac Pro, correct?
16x
Screen Shot 2017-04-12 at 20.20.48.png

...with the dual-DisplayPort 5K Dell UP2715K monitor
 
Last edited:
Joined
Oct 16, 2011
Messages
26
Motherboard
ASUS P8Z77-V PRO
CPU
i7-2700k
Graphics
MSI 1080Z
Mobile Phone
  1. Android
  2. iOS
So... I probably missing something.

Have a clean Sierra install, trying do magic things like @hagop, but its not working.
Can't turn off SIP and install AGDPfix. Setting 0x14 or 3 or 67 won't helping, and fix still saying SIP ENABLED.
Drivers have installed, and obliviously I have black screen at loading system. Using usb-flash for loading now, and don't know what to do. Mac ID is 14.2, GPU - MSI 1080 Z. Anyone help, please?

@tharealmb I see u have same configuration like me, how u make it work?
 
Last edited:
Joined
Oct 2, 2016
Messages
26
Motherboard
Gigabyte GA-Z170-UD5 TH
CPU
i7-6700k
Graphics
GTX 1080
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
  5. Mac Pro
Classic Mac
  1. iMac
  2. Performa
  3. Plus
  4. Power Mac
  5. Quadra
Mobile Phone
  1. iOS
Just got my 1080 working on the Web Driver but have a couple of questions (screenshots):

1. My 1080 is showing only 1 MB on the About this Mac and System Report. Did I do something wrong?
2. The Clover screen that allows me to choose the OS is black. Again, I must have missed something?

Thanks!
 

Attachments

  • Screen Shot 2017-04-12 at 5.07.05 PM.png
    Screen Shot 2017-04-12 at 5.07.05 PM.png
    93.8 KB · Views: 339
  • Screen Shot 2017-04-12 at 5.08.42 PM.png
    Screen Shot 2017-04-12 at 5.08.42 PM.png
    70 KB · Views: 344
Joined
Oct 16, 2011
Messages
26
Motherboard
ASUS P8Z77-V PRO
CPU
i7-2700k
Graphics
MSI 1080Z
Mobile Phone
  1. Android
  2. iOS
So, my brain totally get so much pain, but I found solution.
Its.... Display port 1.2 mode in my pair of dell U2415 monitors.
I was reinstall OS, setup latest clover with EmuVariableUefi-64 and RC scripts, setup WebDriver-378.05.05.05f01, set web driver flag in config, and nothing. For the last word i just open monitors settings, change dp1.2 to dp 1.1 and it is just start working. What a shame...
 
Joined
Jan 3, 2015
Messages
66
Motherboard
Asus ROG GL502VS
CPU
Core i7-9750H
Graphics
Intel UHD 630
Mobile Phone
  1. Android
Hi guys, i have Laptop with GTX 1070 + Sierra 10.12.4 + installed nvidia web driver beta. It works, but how to make brightness control work? I don't see brightness slider on Display Preference, i think it because Nvidia Web Driver are for desktop not laptop. I already use ACPIBacklight.kext, IntelBacklight.kext and AppleBacklightInjector.kext. none of those work.
 
Joined
Mar 3, 2011
Messages
2
Motherboard
GA-Z68A-UD3-B3
CPU
Core i7 2600k
Graphics
EVGA Nvidia Geforce 1070 GTX Superclocked
I just want to say after lurking and following this thread, I am happy with the results!

Screen Shot 2017-04-12 at 11.47.20 PM.png
 
Joined
Jul 6, 2010
Messages
2,583
Motherboard
Asus Z170M-Plus
CPU
i5-6600K
Graphics
R9 280
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Just to confirm, even with the Nvidia web drivers, un-flashed cards still run at PCIe 1.0 speeds in a Mac Pro, correct?
In OS X the WebDrivers will enable PCIE 2.0 in MacPro4,1 & 5,1. In Windows it'll be limited to PCIE 1.1 speed unless it's flashed.

This only applies to genuine Macs though, it has never been an issue with Hackintoshs.
 
Joined
Jul 6, 2010
Messages
2,583
Motherboard
Asus Z170M-Plus
CPU
i5-6600K
Graphics
R9 280
Mac
  1. MacBook Pro
  2. Mac Pro
Mobile Phone
  1. iOS
Status
Not open for further replies.
Top