Contribute
Register

[Solved] No network access after waking from sleep with High Sierra

Joined
Jun 10, 2017
Messages
20
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
Intel 6700K
Graphics
MSI GTX 1080
Mac
MacBook Air
Mobile Phone
iOS
Hi everyone,
I recently updated from Sierra to High Sierra. I use the MTB Intel built-in ethernet adapter (no Wi-FI). Network works fine, but when it wakes up from sleep, the network adapter doesn't get an IP address from DHCP, even if I <Renew DHCP Lease> in Ethernet / Advanced. If I click Renew it self-assigs an IP in the 169. range. Obviously I do not have Internet with that.
If I reboot everything is OK again.
Anyone with the same problem, any ideas guys?
Thanks a lot

MTB: Z170 and Intel Ethernet
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
21,578
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Hi everyone,
I recently updated from Sierra to High Sierra. I use the MTB Intel built-in ethernet adapter (no Wi-FI). Network works fine, but when it wakes up from sleep, the network adapter doesn't get an IP address from DHCP, even if I <Renew DHCP Lease> in Ethernet / Advanced. If I click Renew it self-assigs an IP in the 169. range. Obviously I do not have Internet with that.
If I reboot everything is OK again.
Anyone with the same problem, any ideas guys?
Thanks a lot

MTB: Z170 and Intel Ethernet
Not a solution but it may get you back online without rebooting :

In Terminal :
Code:
sudo ifconfig en0 down
Followed by :
Code:
sudo ifconfig en0 up
Which Ethernet kext are you using ?
 
Joined
Jun 10, 2017
Messages
20
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
Intel 6700K
Graphics
MSI GTX 1080
Mac
MacBook Air
Mobile Phone
iOS
I checked my notes from the initial Sierra installation and it seems I used IntelMausiEthernet 2.2.1d1 with Multibeast.
But I did not do anything special during the High Sierra update about Ethernet
 
Joined
Jun 10, 2017
Messages
20
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
Intel 6700K
Graphics
MSI GTX 1080
Mac
MacBook Air
Mobile Phone
iOS
Not a solution but it may get you back online without rebooting :

In Terminal :
Code:
sudo ifconfig en0 down
Followed by :
Code:
sudo ifconfig en0 up
Which Ethernet kext are you using ?
Actually, I've tried to do what you told me, to bring down and up the interface, but it doesn't help. The problem seems to be the DHCP. The network interface cannot get and IP from the DHCP and instead it self-assigns one.
 
Joined
Jun 10, 2017
Messages
20
Motherboard
Gigabyte GA-Z170X-UD5 TH
CPU
Intel 6700K
Graphics
MSI GTX 1080
Mac
MacBook Air
Mobile Phone
iOS
[SOLVED] OK guys, I reply to my own post with a solution. I hope it will help someone in the future with this kind of issue.
The problem was certainly replace to the kext I used for the Ethernet. Don't know what I used, maybe AppleIntelE1000 or a wrong version of the IntelMausi... But I fixed this by following this link:
http://www.insanelymac.com/forum/topic/304235-intelmausiethernetkext-for-intel-onboard-lan/
Though I used MultiBeast to install. I just deleted all AppleIntelE1000.kext from my Mac, and the I used the IntelMausiethernet.kext v2.1.0 which is for my Intel I-219V. And bingo... it works even after sleep
 
Joined
Jan 9, 2014
Messages
34
Motherboard
GA-Z87X-OC
CPU
Intel i5-4670K
Graphics
Sapphire R9-270X
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Thanks for this information - I'm working on a build with a GA-Z270X-UD3 and this was driving me crazy.
I used the newest version (2.3) of the IntelMausiethernet.kext and the network connection works as it should after waking from sleep. I had used the AppleIntelE1000 at first, which would lose its connection after sleep.
 
Last edited:
Joined
Nov 1, 2011
Messages
6
Motherboard
Gigabyte Z87-D3HP
CPU
I5 4440
Graphics
Integrated Graphics
Mac
MacBook Pro
Mobile Phone
iOS
This worked for me on my Gigabyte Z87-D3HP.

Thanks!

[SOLVED] OK guys, I reply to my own post with a solution. I hope it will help someone in the future with this kind of issue.
The problem was certainly replace to the kext I used for the Ethernet. Don't know what I used, maybe AppleIntelE1000 or a wrong version of the IntelMausi... But I fixed this by following this link:
http://www.insanelymac.com/forum/topic/304235-intelmausiethernetkext-for-intel-onboard-lan/
Though I used MultiBeast to install. I just deleted all AppleIntelE1000.kext from my Mac, and the I used the IntelMausiethernet.kext v2.1.0 which is for my Intel I-219V. And bingo... it works even after sleep
 
Joined
Sep 22, 2011
Messages
288
Motherboard
Thinkpad T61-Clover
CPU
T9300/ICH8M
Graphics
Quadro NVS 140m, 1280x800
Mac
MacBook Pro
Not a solution but it may get you back online without rebooting :

In Terminal :
Code:
sudo ifconfig en0 down
Followed by :
Code:
sudo ifconfig en0 up
Which Ethernet kext are you using ?
Thank you for this tip. toggling with en0 down/en0 up restores my Ethernet connection until I find a permanent solution. My old Thinkpad T61 running Sierra (perfectly except for this issue) has an Intel 82566MM which doesn't appear to be supported by IntelMausiethernet.kext, so I'm using AppleIntelE1000e.kext v3.3.6.
 
Joined
Feb 3, 2011
Messages
38
Motherboard
GA-Z97X-UD5H
CPU
i7-4790K 4,4 GHz
Graphics
GTX 760
Mac
Classic Mac
Mobile Phone
iOS
Thanks for this solution, this helped me with my GA-Z97X-UD5H motherboard. Installed IntelMausiEthernet v2.2.0 and removed AplleIntelE1000e.kext v3.3.6.
[SOLVED] OK guys, I reply to my own post with a solution. I hope it will help someone in the future with this kind of issue.
The problem was certainly replace to the kext I used for the Ethernet. Don't know what I used, maybe AppleIntelE1000 or a wrong version of the IntelMausi... But I fixed this by following this link:
http://www.insanelymac.com/forum/topic/304235-intelmausiethernetkext-for-intel-onboard-lan/
Though I used MultiBeast to install. I just deleted all AppleIntelE1000.kext from my Mac, and the I used the IntelMausiethernet.kext v2.1.0 which is for my Intel I-219V. And bingo... it works even after sleep

 
Joined
Oct 7, 2013
Messages
45
Motherboard
Z87X-UD5H
CPU
Core i7 4770K 3.5GHz
Graphics
NVIDIA GeForce GTX 760 2048 MB
Mac
iMac
Classic Mac
Mobile Phone
Does the IntelMausiEthernet work for the GA-Z87X-UD5H?
 
Top