Contribute
Register

[Solved] No boot after 10.12.6 update

Status
Not open for further replies.
Joined
Nov 19, 2016
Messages
6
Motherboard
Gigabyte Z68XP-UD4
CPU
Intel Core i7 2700K
Graphics
Gigabyte GeForce GTX 570
Mobile Phone
  1. iOS
Hi guys. I had a very stable Sierra build until today. I updated to 10.12.6 and it's bad. Apple must have changed some kext, because now I can't boot. I'm using clover 4063. Running a gigabyte Z68XP-UD4 and a i7 2700k. GTX 570 gpu. I don't have a copy of Sierra to try and get back in. What can I do?
Did anyone have the same problem with this update? Photo of errors attached.
Thanks in advance
John
 

Attachments

  • 4967EE7F-7545-4919-BB4D-17A4F1D6C77D.jpeg
    4967EE7F-7545-4919-BB4D-17A4F1D6C77D.jpeg
    3.9 MB · Views: 94
Last edited:
Joined
Nov 19, 2016
Messages
6
Motherboard
Gigabyte Z68XP-UD4
CPU
Intel Core i7 2700K
Graphics
Gigabyte GeForce GTX 570
Mobile Phone
  1. iOS
I had this problem as I was running old versions of lilu and NvidiaGraphicsFixup et al. Upgrade your kexts to the latest versions. Upgrade your clover to the latest version.
Thankyou for your response. What kexts do I need to upgrade?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,380
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
@Johnny05, please update your profile (personal details) with your Motherboard, CPU and Graphics Card.
If you have a prebuilt computer enter make and model instead of motherboard (Mobo).
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Joined
Nov 19, 2016
Messages
6
Motherboard
Gigabyte Z68XP-UD4
CPU
Intel Core i7 2700K
Graphics
Gigabyte GeForce GTX 570
Mobile Phone
  1. iOS
@Johnny05, please update your profile (personal details) with your Motherboard, CPU and Graphics Card.
If you have a prebuilt computer enter make and model instead of motherboard (Mobo).
My bad. I put those details in my question, but I should have seen that in the rules.
 
Joined
Nov 19, 2016
Messages
6
Motherboard
Gigabyte Z68XP-UD4
CPU
Intel Core i7 2700K
Graphics
Gigabyte GeForce GTX 570
Mobile Phone
  1. iOS
C83E31ED-BED2-4E88-B4B3-0F22FBF7D5C1.jpeg
The problem is that I can't get in to make any changes. Safe mode won't boot.
Verbose mode screenshot above.
 
Joined
Nov 19, 2016
Messages
6
Motherboard
Gigabyte Z68XP-UD4
CPU
Intel Core i7 2700K
Graphics
Gigabyte GeForce GTX 570
Mobile Phone
  1. iOS
I had this problem as I was running old versions of lilu and NvidiaGraphicsFixup et al. Upgrade your kexts to the latest versions. Upgrade your clover to the latest version.
I was able to boot with -liluoff
I tried to update Lilu.Kext but after several tries using kextbeast I had no luck. Any ideas?
 
Joined
Nov 19, 2016
Messages
6
Motherboard
Gigabyte Z68XP-UD4
CPU
Intel Core i7 2700K
Graphics
Gigabyte GeForce GTX 570
Mobile Phone
  1. iOS
I use "Kext Utility" which installs extensions in /System/Library/Extensions. It may be that you have different versions of lilu.kext in several places, /EFI/CLOVER/kext/..., /Library/Extensions and /System/Library/Extensions. Look there and remove all old versions you find.

Furthermore it is not sufficient to update lilu only if that's what you tried. Lilu loads further extensions, in my case NvidiaGraphicsFixup and IntelGraphicsFixup. Both need an upgrade too. I run both of them along with lilu in /S/L/E.

Eventually there are incompatible extensions around graphics patching, most notably NvidiaGraphicsFixup and NVWebDriverLibValFix. The latter is no longer needed with latest version of NvidiaGraphicsFixup and in fact may cause crashes if loaded together.
Thankyou so much. Worked a treat. I highly recommend Kext Utility
 
Status
Not open for further replies.
Top