Contribute
Register

[solved] No audio

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,144
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Yeah true...my bad
Now is probably time to try other layout-id values supported by AppleALC for ALC255.
Note:
Code:
NUC6i7KYK:~ rehabman$ ls ~/Projects/lilu/applealc.git/Resources/ALC255/layout*
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout13.xml
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout13.xml.zlib
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout17.xml
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout17.xml.zlib
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout18.xml
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout18.xml.zlib
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout27.xml
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout27.xml.zlib
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout28.xml
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout28.xml.zlib
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout3.xml
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout3.xml.zlib
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout30.xml
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout30.xml.zlib
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout99.xml
/Users/rehabman/Projects/lilu/applealc.git/Resources/ALC255/layout99.xml.zlib
Also, sometimes FakePCIID.kext+FakePCIID_Intel_HDMI_Audio.kext is needed.
I think AppleALC is doing what we expect now (I see alc-layout-id in the ioreg).
 
Joined
Oct 11, 2012
Messages
86
Motherboard
Asus N552VX-FW131T
CPU
i7-6700HQ
Graphics
HD 530 + GT 950m, 1920x1080
Also, sometimes FakePCIID.kext+FakePCIID_Intel_HDMI_Audio.kext is needed.
I think AppleALC is doing what we expect now (I see alc-layout-id in the ioreg).
After installed the 2 kexts the audio seems to work, tried 10 boots without problems.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,144
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
After installed the 2 kexts the audio seems to work, tried 10 boots without problems.
So, is lilucpudelay still needed? How small can the value be? (just wondering about the severity of the timing issue).
 
Joined
Oct 11, 2012
Messages
86
Motherboard
Asus N552VX-FW131T
CPU
i7-6700HQ
Graphics
HD 530 + GT 950m, 1920x1080
So, is lilucpudelay still needed? How small can the value be? (just wondering about the severity of the timing issue).
Tried without lilupcdelay (and even with the standard release of Lilu) and no audio problems in 6 boots.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
189,144
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Tried without lilupcdelay (and even with the standard release of Lilu) and no audio problems in 6 boots.
So issue all along was that you never thought to use FakePCIID_Intel_HDMI_Audio.kext? (for spoofing audio chip).
 
Joined
Oct 11, 2012
Messages
86
Motherboard
Asus N552VX-FW131T
CPU
i7-6700HQ
Graphics
HD 530 + GT 950m, 1920x1080
Seems like that. Its my first build and im working on it step by step
 
Top