Contribute
Register

[SOLVED] New Nvidia web driver(378.05.05.05f01) will break night shift in Sierra 10.12.4

Status
Not open for further replies.
Joined
Jan 15, 2011
Messages
118
Motherboard
Gigabyte Z490 Vision D
CPU
i7-10700K
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
No need to be sad anymore, folks. Nvidia just released a new driver and I can confirm it fixed this!!! Calibration and Night Shift now works!!!

Just update your drivers through the NVIDIA Driver Manager. The latest driver is:

378.05.05.05f02
Thanks for the info - f.lux is working with the new driver.
 
Joined
Aug 2, 2013
Messages
38
Motherboard
GA-Z77X-UD5H
CPU
i7 3770K
Graphics
GTX 970
Mac
  1. MacBook Pro
Does anybody have this working with a calibration created on a third party calibration platform? I calibrated with x-rite and that profile doesn't work, always comes back blue, even with the latest update from NVidia. System boots blue, if the displays turn off it goes blue... If I use the default profile for my display I don't have the problem, so it must be the profile I guess. Anyone with an X-Rite/Spyder/etc had this issue?
 
Joined
Mar 15, 2017
Messages
2
Motherboard
Asus Z170-P
CPU
I5 6500
Graphics
MSI GTX 1080 Gaming X
Does anybody have this working with a calibration created on a third party calibration platform? I calibrated with x-rite and that profile doesn't work, always comes back blue, even with the latest update from NVidia. System boots blue, if the displays turn off it goes blue... If I use the default profile for my display I don't have the problem, so it must be the profile I guess. Anyone with an X-Rite/Spyder/etc had this issue?

05f02 works for me.
I calibrated my monitor with X-rite with the Maxwell driver and a gtx 750 ti when I first build my rig.
When the 05f01 Pascal driver came out, the calibration didn't work, neither the gtx 750 ti nor the gtx 1080.
Now with the latest driver, everithing works.
Have you tried to make a new color profile ?
 
Joined
Aug 2, 2013
Messages
38
Motherboard
GA-Z77X-UD5H
CPU
i7 3770K
Graphics
GTX 970
Mac
  1. MacBook Pro
05f02 works for me.
I calibrated my monitor with X-rite with the Maxwell driver and a gtx 750 ti when I first build my rig.
When the 05f01 Pascal driver came out, the calibration didn't work, neither the gtx 750 ti nor the gtx 1080.
Now with the latest driver, everithing works.
Have you tried to make a new color profile ?

I tried a bunch of different things this weekend and it appears the issue I am having is specific to 10.12.4 and how it handles root color profiles. Apparently my issue is caused by the fact that the root profile on my system is using the same color profile as my user. I made this change so that the login screen reflects the calibrated display. When both root and the user have the same color profile, the systems boots and comes back from display sleep with incorrect colors. This occurs even when I duplicate the .icc profile, rename it and put it in a different directory for the root profile.

When I changed the root color profile to default, the problem went away and my calibrated profile and NightShift are working now. Very weird! Since I only have to look at the login screen every once in a while when I reboot, I'll live with it being uncalibrated for the time being.
 
Status
Not open for further replies.
Top