Contribute
Register

[solved] Need help patching hdmi/hdmi audio on Cube Mix Plus

Status
Not open for further replies.
Joined
Jan 9, 2016
Messages
219
Motherboard
Cube mix plus
CPU
M3-7y30
Graphics
HD 615, 1920 × 1080
Hi,
I'm trying to patch my HDMI audio following the guide on Mojave laptop support but I have some troubles.
I think I followed the guide correctly but I have these two problems:
-if I start the tablet with the HDMI cable in clover is shown in both the tablet and the HDMI device but mac os (after the boot) is only showing in the HDMI device, the tablet screen is completely black and it is not turning alive until I reboot without the HDMI cable plugged in. When booted audio via HDMI works very well but after less than a minute I get a green screen that I can only fix disconnecting and connecting the cable again... The problem is that the green screen comes again.
-if I start the tablet without the HDMI cable plugged in the tablet boots without problems, then I insert the HDMI cable and it is working well but I have no audio via HDMI.
I tried with and without pipe patch in config.plist but the results are the same.
This is my debug report made in the second scenario (in the first scenario I can't gen_debug takes too much to do his job).
Hope someone can help me.
Thanks
 

Attachments

  • debug_7315.zip
    2.5 MB · Views: 22

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,702
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi,
I'm trying to patch my HDMI audio following the guide on Mojave laptop support but I have some troubles.
I think I followed the guide correctly but I have these two problems:
-if I start the tablet with the HDMI cable in clover is shown in both the tablet and the HDMI device but mac os (after the boot) is only showing in the HDMI device, the tablet screen is completely black and it is not turning alive until I reboot without the HDMI cable plugged in. When booted audio via HDMI works very well but after less than a minute I get a green screen that I can only fix disconnecting and connecting the cable again... The problem is that the green screen comes again.
-if I start the tablet without the HDMI cable plugged in the tablet boots without problems, then I insert the HDMI cable and it is working well but I have no audio via HDMI.
I tried with and without pipe patch in config.plist but the results are the same.
This is my debug report made in the second scenario (in the first scenario I can't gen_debug takes too much to do his job).
Hope someone can help me.
Thanks

What tablet are you referring to? There is no tablet in your profile, just a laptop.
Please fix your profile.
 
Joined
Jan 9, 2016
Messages
219
Motherboard
Cube mix plus
CPU
M3-7y30
Graphics
HD 615, 1920 × 1080
What tablet are you referring to? There is no tablet in your profile, just a laptop.
Please fix your profile.
I fixed my profile, the tablet is the cube mix plus as shown now in my profile and in my thread title.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,702
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I fixed my profile, the tablet is the cube mix plus as shown now in my profile and in my thread title.

Missing screen resolution. Please read the FAQ request carefully.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,702
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS

You should try without FakePCIID_Intel_HDMI_Audio.kext (it is not always needed).

Keep in mind you should always hotplug (problems booting with HDMI connected is common, no known solution).
 
Joined
Jan 9, 2016
Messages
219
Motherboard
Cube mix plus
CPU
M3-7y30
Graphics
HD 615, 1920 × 1080
You should try without FakePCIID_Intel_HDMI_Audio.kext (it is not always needed).

Keep in mind you should always hotplug (problems booting with HDMI connected is common, no known solution).
OK thanks, uninstalling the kext solved the problem. You can mark the thread as solved.
 
Status
Not open for further replies.
Top