Contribute
Register

[Solved] Mouse cursor freezes cyclically every few seconds.

Joined
Jun 5, 2014
Messages
29
Motherboard
ASUS Z87-A
CPU
i7 4770
Graphics
MSI RX-470
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I think I nailed it down to USB issue. My pendrives suck under Mojave, so I started digging and found IORegistryExplorer. It would mark green devices attached to the system for about 5 seconds, and mark red the ones you disconnect.

If you re-use the same USB port multiple times, it would list the devices.

View attachment 363223

Here's a DataTraveler pendrive I disconnected, and another DT Elite I connected. It's a front panel USB 3.0 port (SSP1).

IORegistryExplorer will list all devices that are connected to this port and removed.

Look at my mouse tho:

View attachment 363224

Seems that it disconnects and reconnects... Now it's black, cos I did not catch it green at the last such freeze. But I suspect, in the background due to some USB drivers not being correctly added it keeps disconnecting and reconnecting - hence the freeze.

Will do some more tests and see how to fix USB drivers.

EDIT:

Totally USB thing, managed to catch it this time, and there are loads of disconnects above it... :S

View attachment 363248

Thanks for testing, it's very interesting. Will be waiting for updates though it's ok with my mouse now.
 
Joined
Dec 28, 2016
Messages
61
Motherboard
Asus Z87-Plus
CPU
i5-4460
Graphics
GTX 960
Thanks for testing, it's very interesting. Will be waiting for updates though it's ok with my mouse now.
changed my mouse for now, and also used USBInjectAll and then created custom SSDT for only the ports that I use. It seems to have stopped now. :)
 
Joined
Jan 5, 2020
Messages
43
Motherboard
Intel NUC
CPU
i7-8559U
Graphics
Iris Plus 655
Classic Mac
  1. Portable
Mobile Phone
  1. iOS
changed my mouse for now, and also used USBInjectAll and then created custom SSDT for only the ports that I use. It seems to have stopped now. :)

could you please explain how to so that?

i have same issue with Catalina 10.15.2 after installed wireless drivers (issue disappear if i turn off USB wireless)
 
Joined
Apr 4, 2019
Messages
4
Motherboard
Asus Z170I Pro Gaming
CPU
i5-6600K
Graphics
2x RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
PUSH I have the same problem under Catalina 10.5.2 and also since I changed the Clover bootloader to 5102. before that, everything ran fine. I did a reinstall afterwards and the error remains. Is it because of my USBPort.kext? More pictures will follow. I have the assumption that the mouse always reconnects. But the mouse is wired.
 
Joined
Apr 4, 2019
Messages
4
Motherboard
Asus Z170I Pro Gaming
CPU
i5-6600K
Graphics
2x RX 580
Mac
  1. iMac
Mobile Phone
  1. iOS
could you please explain how to so that?

i have same issue with Catalina 10.15.2 after installed wireless drivers (issue disappear if i turn off USB wireless)

Here the link:

 
Joined
Jan 5, 2020
Messages
43
Motherboard
Intel NUC
CPU
i7-8559U
Graphics
Iris Plus 655
Classic Mac
  1. Portable
Mobile Phone
  1. iOS
PUSH I have the same problem under Catalina 10.5.2 and also since I changed the Clover bootloader to 5102. before that, everything ran fine. I did a reinstall afterwards and the error remains. Is it because of my USBPort.kext? More pictures will follow. I have the assumption that the mouse always reconnects. But the mouse is wired.



Because there is no officially drivers for my USB wireless adapter from this project:


wireless works with slow down internet speed(I’m ok with it), then mouse cursor freezes every 5-10 seconds . If i turn off USB WIRELESS everything works fine and perfectly!

My devices:
- NUC8i7BEH
- Catalina 10.15.2
- D-LINK DWA-131 usb wireless adapter

could anyone fix this for me?
 
Top