Contribute
Register

[Solved] Mouse cursor freezes cyclically every few seconds.

Joined
Jun 5, 2014
Messages
29
Motherboard
ASUS Z87-A
CPU
i7 4770
Graphics
MSI RX-470
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Mouse cursor freezes on very short period (maybe 100ms) cyclically every few seconds. After freezing it appears a bit further where it should be if was not freezed. Sometimes every 10 seconds, sometimes (after wakeup) 4-5 seconds. I tried another mouse and removed AppleUpstreamUserClient.kext. No result, mouse still freezes. Help somebody!

OS — 10.10.3 Yosemite
System — Z87-A
CPU — i7 4770
Graphics — HD 5770
 
Joined
Apr 4, 2014
Messages
14
Motherboard
GIGABYTE GA-Z97X-UD7
CPU
Intel Core i7-4790K
Graphics
EVGA 02G-P4-3757-KR
Mac
Classic Mac
Mobile Phone
I'm actually experiencing this same issue on one of my computers under El Capitan. Were you able to find a resolution?
 
Joined
Jun 5, 2014
Messages
29
Motherboard
ASUS Z87-A
CPU
i7 4770
Graphics
MSI RX-470
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Nope, I still have this issue, did not found recipe to fix it.
 

c26

Joined
Aug 22, 2015
Messages
1
Mac
Classic Mac
Mobile Phone
I have this exact issue with 10.12.2. Seems to be a USB issue as other things still continue to run even while this happens. This doesn't always happen but if it does, it occurs right on start up, or after waking from sleep. If it does occur, then I restart the computer and hope that the computer is working okay. Sometimes it's fine.

Has anyone found a solution to this problem?
 
Joined
Jun 9, 2013
Messages
10,781
Motherboard
Gigabyte GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
  1. MacBook
  2. Mac mini
Mobile Phone
  1. Android
Mouse cursor freezes on very short period (maybe 100ms) cyclically every few seconds. After freezing it appears a bit further where it should be if was not freezed. Sometimes every 10 seconds, sometimes (after wakeup) 4-5 seconds. I tried another mouse and removed AppleUpstreamUserClient.kext. No result, mouse still freezes. Help somebody!

OS — 10.10.3 Yosemite
System — Z87-A
CPU — i7 4770
Graphics — HD 5770

What is you're USB configuration? Attach Clover folder removing themes & ioreg ZIP attach. [Guide] How to Make a Copy of IOReg | tonymacx86.com
 
Joined
May 13, 2011
Messages
1,699
Motherboard
Z68X-UD4-B3
CPU
i7-2600K
Graphics
XFX 6870 Dual Fan
Mac
  1. iMac
  2. MacBook
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. iMac
  2. Power Mac
Mobile Phone
  1. iOS
Wifi may interfere with some USB receivers (for wireless mouse).
Sometimes communication interference between mouse and USB receiver will also cause "laggy" performance -- depends on distance between your computer and mouse, and/or any interference/block between mouse and receiver.
For me, I put my keyboard and mouse receivers at the back of my Apple Cinema Display monitor (it has USB ports), and this gave me stable operation. The short distance between monitor and keyboard also assures good communication. Putting the USB mouse receiver in the front USB jacks of my computer case is the next best thing. But putting my mouse receiver in the back of my computer was the worst place for me.... dropped connection/laggy performance.
YMMV.
 
Joined
Jun 5, 2014
Messages
29
Motherboard
ASUS Z87-A
CPU
i7 4770
Graphics
MSI RX-470
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hi. Thanks a lot for interest. I had problems with emails and did not get notification on thread. Now problem with mouse disappeared after I had been updated to Sierra 10.12 (looks like Apple made some changes that solved my problem). I have lags only few seconds after booting or awaking, so now everything is perfect here, now High Sierra also great. Thanks again.
 
Joined
Dec 28, 2016
Messages
61
Motherboard
Asus Z87-Plus
CPU
i5-4460
Graphics
GTX 960
I have the same issue, both on Sierra and Mojave. on Sierra both with NVidia GTX960 and with the card removed and just using the CPU'd Graphics too... On Mojave I removed the GTX 960 since there are no drivers yet.

Can't think of any possible solutions. On Sierra I have Logitec Control Center installed, I believe that adds a kext for the mouse, on Mojave it's a fresh install.

I will try all USB ports one by one and see if that helps. Has anyone had to configure something or change settings to get this resolved?
 
Joined
Jun 5, 2014
Messages
29
Motherboard
ASUS Z87-A
CPU
i7 4770
Graphics
MSI RX-470
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have the same issue, both on Sierra and Mojave. on Sierra both with NVidia GTX960 and with the card removed and just using the CPU'd Graphics too... On Mojave I removed the GTX 960 since there are no drivers yet.

Can't think of any possible solutions. On Sierra I have Logitec Control Center installed, I believe that adds a kext for the mouse, on Mojave it's a fresh install.

I will try all USB ports one by one and see if that helps. Has anyone had to configure something or change settings to get this resolved?

On my side it disappeared almost completely on Sierra. Only sometimes I can see single lag. I did not fix it by myself.
 
Joined
Dec 28, 2016
Messages
61
Motherboard
Asus Z87-Plus
CPU
i5-4460
Graphics
GTX 960
I think I nailed it down to USB issue. My pendrives suck under Mojave, so I started digging and found IORegistryExplorer. It would mark green devices attached to the system for about 5 seconds, and mark red the ones you disconnect.

If you re-use the same USB port multiple times, it would list the devices.

Screenshot 2018-11-05 at 20.42.40.png

Here's a DataTraveler pendrive I disconnected, and another DT Elite I connected. It's a front panel USB 3.0 port (SSP1).

IORegistryExplorer will list all devices that are connected to this port and removed.

Look at my mouse tho:

Screenshot 2018-11-05 at 20.42.56.png

Seems that it disconnects and reconnects... Now it's black, cos I did not catch it green at the last such freeze. But I suspect, in the background due to some USB drivers not being correctly added it keeps disconnecting and reconnecting - hence the freeze.

Will do some more tests and see how to fix USB drivers.

EDIT:

Totally USB thing, managed to catch it this time, and there are loads of disconnects above it... :S

clipboard_image_1d47fb6866a.jpg
 
Last edited:
Top