Contribute
Register

[Solved] Mojave on EP45-UD3L

Status
Not open for further replies.
Joined
Dec 12, 2010
Messages
100
Motherboard
Gigabyte Z77P
CPU
i7-3770
Graphics
Sapphire RX580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Yes, I know it's an ancient setup, but is still fun to hackintosh it...so don't judge.

Trying to get Mojave on an EP45-UD3L with a C2D E8400 and 650 Ti (build #3). Actually got all the way through the installation phase and 3 or so reboots, but it won't get into the final GUI. It gets through a full verbose boot (no obvious hangups) but then freezes at the black screen, apple boot logo, empty progress bar and mouse in the top left. Attached pic of where it gets stuck and my zipped Clover setup. Any suggestions how i can break this logjam?

Many Thanks
 

Attachments

  • Clover.zip
    10.7 MB · Views: 176
  • stuck here.jpg
    stuck here.jpg
    10.7 KB · Views: 166
Last edited:
Joined
Jul 25, 2012
Messages
6,804
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Yes, I know it's an ancient setup, but is still fun to hackintosh it...so don't judge.

Trying to get Mojave on an EP45-UD3L with a C2D E8400 and 650 Ti (build #3). Actually got all the way through the installation phase and 3 or so reboots, but it won't get into the final GUI. It gets through a full verbose boot (no obvious hangups) but then freezes at the black screen, apple boot logo, empty progress bar and mouse in the top left. Attached pic of where it gets stuck and my zipped Clover setup. Any suggestions how i can break this logjam?

Many Thanks
Change of PCIE Graphics to one that is fully supported in Mojave is the way to get out of current Black screen if you have already set your BIOS and CLOVER/kexts/Other and CLOVER/config.plist to use a PCIE Kepler 600 Series Graphics Card.
Check the Forums for Nvidia 600 Series or 700 series with Kepler that have worked.
I cannot recall reading anyone successfully installing GeF GTX 650 in Mojave but read about successful 680 GTX and 700 Series.
My budget Nvidia GT 710 works very well in Mojave 14.1.
 
Joined
Dec 12, 2010
Messages
100
Motherboard
Gigabyte Z77P
CPU
i7-3770
Graphics
Sapphire RX580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
cmn699...Thank you kindly for the assist. I'll try to find another GPU.

I have had three different 650 Ti's, a GT 710 and a Titan Black run perfectly in Mojave with full acceleration, Metal support, etc. (albeit on Z68 motherboards and obviously without Nvidia web drivers at this point). The commonality is these are all Kepler-based GPU's.

But back to my OP, I simply can't get a Mojave setup booted on the old EP45-UD3L (legacy bios) regardless of the GPU's I've tried. But will continue the effort. Suggestions welcome.
 

Attachments

  • Kepler in Mojave.png
    Kepler in Mojave.png
    510.4 KB · Views: 518
Last edited:
Joined
Dec 12, 2010
Messages
100
Motherboard
Gigabyte Z77P
CPU
i7-3770
Graphics
Sapphire RX580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
A guess is that my Clover/EFI from the OP contains an incompatibility between my hardware and Mojave (either patches or kexts or config.plist or something). The same Clover/EFI installs and boots 10.13.6 flawlessly...and even installs Mojave but chokes in booting to the GUI in the final phase.
 
Last edited:
Joined
Jan 18, 2018
Messages
108
Motherboard
GA EP45-UD3P
CPU
Q9550
Graphics
Evga GTX 770 SC 2GB
Mac
  1. iMac
  2. MacBook
Mobile Phone
  1. iOS
Replace file
/System/Library/UserEventPlugins/com.apple.telemetry.plugin
com.apple.telemetry.plugin(High Sierra)
 
Joined
Dec 12, 2010
Messages
100
Motherboard
Gigabyte Z77P
CPU
i7-3770
Graphics
Sapphire RX580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Juseon123...AMAZING!!! That did it! Replacing the High Sierra telemetry.plugin into Mojave worked. How did you figure that out? Many kudos to you for helping. I'm now fully booted into Mojave on this old EP45-UD3L. In fact, it was your config.plist from another thread that got me a working Clover bootloader. You're two for two!
 
Joined
Dec 12, 2010
Messages
100
Motherboard
Gigabyte Z77P
CPU
i7-3770
Graphics
Sapphire RX580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
The next challenge is getting Mojave to work with an SSD. With most HDD/SSD's on this EP45-UD3L, I get an "I/O error" during verbose boot and the disk will show uninitialized in disk utility (unable to initialize, erase, etc and is stuck at "creating partition map"). Oddly, an old spinning Toshiba HDD is the one drive I haven't had this problem with and is the only one I've been successful in getting a working Mojave. Still using the Clover/EFI from the OP and have a feeling it's something in there that can be manipulated to fix this issue. Thoughts?
 

Attachments

  • Clover.zip
    10.7 MB · Views: 192

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,445
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
The next challenge is getting Mojave to work with an SSD. With most HDD/SSD's on this EP45-UD3L, I get an "I/O error" during verbose boot and the disk will show uninitialized in disk utility (unable to initialize, erase, etc and is stuck at "creating partition map").
Some SATA controllers have issues with AppleAHCIPort v329 (eg ICH10, 5 series, 7 series, ASMedia 1061)
Disks may fail to initialise, not readable or hot plug may fail.
See [Solved] Problem: HDD not supported and add new ICH patch to your config.plist.

ahci.png
 
Joined
Dec 12, 2010
Messages
100
Motherboard
Gigabyte Z77P
CPU
i7-3770
Graphics
Sapphire RX580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Some SATA controllers have issues with AppleAHCIPort v329 (eg ICH10, 5 series, 7 series, ASMedia 1061)
Disks may fail to initialise, not readable or hot plug may fail.
See [Solved] Problem: HDD not supported and add new ICH patch to your config.plist.

View attachment 369949
BreBo, that worked! Great suggestion. Applied the vit9696 AppleAHCIPort patch and I’ve got full access to my SSD’s now. Now i’m just cleaning up a few more items like resume from sleep (it fully reboots) and audio. Will keep at it until it’s near perfect.
 
Joined
Dec 12, 2010
Messages
100
Motherboard
Gigabyte Z77P
CPU
i7-3770
Graphics
Sapphire RX580
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Closing the loop on this project. This EP45-UD3L now working flawlessly on 10.14.2. Many thanks to those who chipped in to assist. Summary of lessons learned here.
 
Status
Not open for further replies.
Top