Contribute
Register

[Solved] macOS installer not showing up in Clover

Joined
Feb 23, 2014
Messages
13
Motherboard
Dell Optiplex
CPU
i7-4770
Graphics
HD4600
Hello everyone. I've been wanting to try hackintoshing for a while but I've never had a machine that wasn't already doing something important. I'm trying to install High Sierra on a Dell Optiplex 9020 SFF.

Specs:
Dell Optiplex 9020
i7-4770
Onboard HD4600 graphics
Installing on a SATA SSD if that matters.

Problem: I'm using the standard High Sierra Installation Guide using Unibeast, but when I try to boot from the USB, I just get Clover with a bunch of Windows partitions. There's no Install macOS High Sierra Option. How can I get the installer to show up? Thanks in advance!
 
Joined
Jul 25, 2012
Messages
6,676
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hello everyone. I've been wanting to try hackintoshing for a while but I've never had a machine that wasn't already doing something important. I'm trying to install High Sierra on a Dell Optiplex 9020 SFF.

Specs:
Dell Optiplex 9020
i7-4770
Onboard HD4600 graphics
Installing on a SATA SSD if that matters.

Problem: I'm using the standard High Sierra Installation Guide using Unibeast, but when I try to boot from the USB, I just get Clover with a bunch of Windows partitions. There's no Install macOS High Sierra Option. How can I get the installer to show up? Thanks in advance!
Current Unibeast has a problem that causes the macOS High Sierra 10.13.4 USB installer to be a 'No Show" on Clover Boot Manager(CBM) Screen.
A workaround is posted and you can find it here:UniBeast 8.2 and macOS 10.13.4 Workaround

This problem is also noted by me with Standalone Clover EFI 4411. Using Clover Efi 4423 from RehabMan Clover_v2.4k_r4423.RM-4614.cf0897a3.zip to create the boot loader on USB installer created using Terminal CreateInstallMedia command and editing the CLOVER/Other with added ESSENTAIL kexts like the latest FakeSMC. kext, Ethernet.kext and any other needed Graphics Support kexts like IntelGraphicsFixup.kext, Lilu.kext , NvidiaGraphicsFixup.kext , WhateverGreen.kext etc from RehabMan and editing config.plist for our hardware will prevent this problem of missing USB installer in CBM screen and help in successful installation.
 
Joined
Feb 23, 2014
Messages
13
Motherboard
Dell Optiplex
CPU
i7-4770
Graphics
HD4600
Current Unibeast has a problem that causes the macOS High Sierra 10.13.4 USB installer to be a 'No Show" on Clover Boot Manager(CBM) Screen.
A workaround is posted and you can find it here:UniBeast 8.2 and macOS 10.13.4 Workaround

This problem is also noted by me with Standalone Clover EFI 4411. Using Clover Efi 4423 from RehabMan Clover_v2.4k_r4423.RM-4614.cf0897a3.zip to create the boot loader on USB installer created using Terminal CreateInstallMedia command and editing the CLOVER/Other with added ESSENTAIL kexts like the latest FakeSMC. kext, Ethernet.kext and any other needed Graphics Support kexts like IntelGraphicsFixup.kext, Lilu.kext , NvidiaGraphicsFixup.kext , WhateverGreen.kext etc from RehabMan and editing config.plist for our hardware will prevent this problem of missing USB installer in CBM screen and help in successful installation.
That worked and now I have it installed, but after running MultiBeast, I can't boot back into macOS, it just sits on the Apple logo, even if I try to use clover from my install usb. Did I miss something in MultiBeast?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,664
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
I can't boot back into macOS, it just sits on the Apple logo, even if I try to use clover from my install usb.
Boot your system in Verbose Mode and post a picture of your screen when it freezes/hangs.
At Clover Boot Screen press space bar and select Verbose (-v)
 
Joined
Feb 23, 2014
Messages
13
Motherboard
Dell Optiplex
CPU
i7-4770
Graphics
HD4600
Boot your system in Verbose Mode and post a picture of your screen when it freezes/hangs.
At Clover Boot Screen press space bar and select Verbose (-v)
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,664
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
Use the forum Search tool for Mach reboot.
 
Joined
Feb 23, 2014
Messages
13
Motherboard
Dell Optiplex
CPU
i7-4770
Graphics
HD4600
Since the original problem in this thread is solved, I'm going to mark it solved and start a new one concerning the mach reboot issue.
 
Joined
Feb 22, 2018
Messages
93
Motherboard
GIGABYTE Z390 Designare
CPU
i7-8700K
Graphics
RX 580 & WX7100
Mac
MacBook Pro
Mobile Phone
iOS
I get an error when trying to install Clover_v2.4k_r4423.RM-4614.cf0897a3.zip. (Pictures attached)

However, when I use MacMan's code:
Code (Text):

rm -f /Volumes/Install\ macOS\ High\ Sierra/.IAPhysicalMedia

Code (Text):

rm -rf /Volumes/ESP/EFI/CLOVER/kexts/Other/USBInjectAll.kext

I'm able to see the install High Sierra Installer USB in Clover Boot Manager, but end at a No entry Icon, scrambled graphics, and stops at HID Legacy shim 2. Picture attached
 

Attachments

Joined
Feb 23, 2014
Messages
13
Motherboard
Dell Optiplex
CPU
i7-4770
Graphics
HD4600
I get an error when trying to install Clover_v2.4k_r4423.RM-4614.cf0897a3.zip. (Pictures attached)

However, when I use MacMan's code:
Code (Text):

rm -f /Volumes/Install\ macOS\ High\ Sierra/.IAPhysicalMedia

Code (Text):

rm -rf /Volumes/ESP/EFI/CLOVER/kexts/Other/USBInjectAll.kext

I'm able to see the install High Sierra Installer USB in Clover Boot Manager, but end at a No entry Icon, scrambled graphics, and stops at HID Legacy shim 2. Picture attached
It looks like you're having a very different issue. I would recommend starting a new thread in the Installation forum with the issues you're having to get better help as this has already been marked solved.
 
Joined
Jan 8, 2017
Messages
35
Motherboard
Thinkpad Yoga 12 (clover)
CPU
i5-5200U
Graphics
HD 5500, 1920 x 1080
Mobile Phone
iOS
since I have the same problem with Mojave -does this problem still exist? I am running High Sierra and wanted to make a clean install. Unibeast ---> boot into usb --> only the normal partitions
 
Top