Contribute
Register

[solved] Mac OSX fails to boot, Panic in DSMOS

Status
Not open for further replies.
Joined
Jan 2, 2017
Messages
67
Motherboard
HP Spectre x360 (Clover) Board:827E
CPU
i5-7200U
Graphics
Intel HD 620, 1920 x 1080
My installation of high sierra recently stopped booting after I reset the nvram to try to fix sleep related issues. OSX panics while loading DSMOS.kext. I believe the error is related to the line in verbose boot "DSMOS: SMC Returned incorrect key :000000000000000000000000000" Attached is a photo of the panic and my Clover folder

Thanks for any help in advance.

17-11-04 20-18-28 0731.jpg
 

Attachments

  • CLOVER.zip
    2.1 MB · Views: 93
Joined
Sep 9, 2011
Messages
935
Motherboard
HP 250 G5 (81EF) Clover UEFI
CPU
i3 5005u
Graphics
HD 5500 (1366x768)
Mobile Phone
  1. Android
My installation of high sierra recently stopped booting after I reset the nvram to try to fix sleep related issues. OSX panics while loading DSMOS.kext. I believe the error is related to the line in verbose boot "DSMOS: SMC Returned incorrect key :000000000000000000000000000" Attached is a photo of the panic and my Clover folder

Thanks for any help in advance.

View attachment 290150
Remove EmuVariableUefi-64.efi and replace VBoxHfs-64.efi with HFSPlus-64.efi.
 
Joined
Jan 2, 2017
Messages
67
Motherboard
HP Spectre x360 (Clover) Board:827E
CPU
i5-7200U
Graphics
Intel HD 620, 1920 x 1080
Done, same error. Only notable differences are now in verbose boot OSX pauses at "Waiting for DSMOS" before throwing error. In single use mode, nvram -p returns no values, whereas it did with EmuVariableUefi-64.efi installed.
 

Attachments

  • CLOVER.zip
    2.1 MB · Views: 82

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,624
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Joined
Jan 2, 2017
Messages
67
Motherboard
HP Spectre x360 (Clover) Board:827E
CPU
i5-7200U
Graphics
Intel HD 620, 1920 x 1080
Thanks so much! Your config.plist worked, looks like I was missing dart=0 and some kernel patch options in kextstopatch. I'm still having the issue others on the forum have mentioned where the computer does not properly wake from sleep (backlight but nothing on display). Should I open a new thread for that issue?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,624
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks so much! Your config.plist worked, looks like I was missing dart=0 and some kernel patch options in kextstopatch. I'm still having the issue others on the forum have mentioned where the computer does not properly wake from sleep (backlight but nothing on display). Should I open a new thread for that issue?

Open a separate thread.

No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Status
Not open for further replies.
Top