Contribute
Register

[Solved]Lenovo Yoga 720 15IKB 10.14 PB7&10.13.6 - 3 Issues(Webcam) (Repost)

Joined
Aug 20, 2018
Messages
28
Motherboard
Dell Latitude 5290 2-in1
CPU
i5 8350u
Graphics
UHD 630
20181229
Now I'm using 10.14.2
There's USB 3.0 problem but, replaced IOUSBFamily, IOUSBHostFamily from 10.14 then it works.
Block sleep using "sudo pmset -a disablesleep 1"
Webcam problem seems from USB, I didn't fix it but automate active webcam trick with 'controllermate'
(It can make nice Touch Gesture!)
Second boot glich disappeared almost
HDMI Audio not works now.

Attached my EFI(clover) here again for 10.14.2
In config.plist, boot timeout set 0 with last booted volume. (should check it before use it)
Detailed installation process is uploaded to Korean web page 'x86.co.kr'
If someone use it and makes more stable, please share process :)
Happy New Year.





----------------------------------------------

Hello

I'm using LENOVO Yoga 720 15IKB with 10.13.6 (From App Store)&10.14 Public Beta 6 (18A365a, Apple Beta Software Program)
Wireless Signal, HD 630 graphics with 4K Touchscreen, USB ports and speed, sound, trackpad, keyboard etc..
Almost works nice but there's 3 main issues
(It is common issues both 10.13.6 and 10.14 beta)



First, sleep/wake issue

After sleep, charging not works.
It is same issue with this post.
https://www.tonymacx86.com/threads/yoga-720-try-out-high-sierra-issues.227222/page-17
As a temporary measure, I disabled sleep with this terminal code

"sudo pmset -a disablesleep 1"


Second, Webcam works abnormally

This is big issue for me, webcam works only Photo Booth.app or Windows in Parallels.
In Facetime and another apps for camera, Webcam light turns on but can't read image.
(just black screen on it)
If I run Facetime then run Photo Booth.app or Camera in Parallels, Facetime can read image.

Third, Boot Glitch

Between 1st boot and 2nd boot, there's short graphic glich or short blackout.
It is not a big problem to using macOS, but I want to fix it

Attached my EFI

I deleted USBInjectAll.kext and USB Limit kext patch
Because there's no problem at USB without these patches, and also there's still 3 issues with these patches
there's no additional kexts in s/l/e or l/e

Please advise what I would like to try.

Thanks for read



{Yoga 720 15IKB Spec}
HM175
i7 7700HQ
GTX1050 / HD630
SAMSUNG PM961 NVMe 512GB
16GB 2133 MHz DDR4 RAM
4K Touchscreen Display
DW1560(Replaced from Intel AC8265)
Realtek ALC236
USB 3.0 x 2
TYPE-C x 1 (USB 3.1, Display Port, Thunderbolt)
Audio Jack x 1
JBL Branded Speaker
Built-in microphone × 2

{Bios}
- Configuration
Wireless LAN [Enabled]
* SATA Controller Mode [AHCI]
Graphic Device [Switchable Graphics]
Power Beep [Disabled]
Intel Virture Technology [Enabled]
Bios Back Flash [Disabled]
Hotkey Mode [Disabled]
Always On USB [Enabled]
Thunderbolt (TM) Device Boot Surpport [Enabled]
Thermal Control [Performance]

- Security
* Intel Platform Trust Technology [Disabled]
* Intel SGX [Software Controlled]
* Secure Boot [Disabled]

- Boot
* Boot Mode [UEFI]
Fast Boot [Enabled]
USB Boot [Enabled]
PXE Boot to LAN [Enabled]
IPV4 PXE First [Enabled]
 

Attachments

Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
(The previous post has been removed by make my mistake writing Public Beta to Developer Beta. I'm sorry.)

View attachment 347117

Hello

I'm using LENOVO Yoga 720 15IKB with 10.13.6 (From App Store)&10.14 Public Beta 7 (18A365a, Apple Beta Software Program)
Wireless Signal, HD 630 graphics with 4K Touchscreen, USB ports and speed, sound, trackpad, keyboard etc..
Almost works nice but there's 3 main issues
(It is common issues both 10.13.6 and 10.14 beta)



First, sleep/wake issue

After sleep, charging not works.
It is same issue with this post.
https://www.tonymacx86.com/threads/yoga-720-try-out-high-sierra-issues.227222/page-17
As a temporary measure, I disabled sleep with this terminal code

"sudo pmset -a disablesleep 1"


Second, Webcam works abnormally

This is big issue for me, webcam works only Photo Booth.app or Windows in Parallels.
In Facetime and another apps for camera, Webcam light turns on but can't read image.
(just black screen on it)
If I run Facetime then run Photo Booth.app or Camera in Parallels, Facetime can read image.

Third, Boot Glitch

Between 1st boot and 2nd boot, there's short graphic glich or short blackout.
It is not a big problem to using macOS, but I want to fix it

Attached my EFI

I deleted USBInjectAll.kext and USB Limit kext patch
Because there's no problem at USB without these patches, and also there's still 3 issues with these patches
there's no additional kexts in s/l/e or l/e

Please advise what I would like to try.

Thanks for read



{Yoga 720 15IKB Spec}
HM175
i7 7700HQ
GTX1050 / HD630
SAMSUNG PM961 NVMe 512GB
16GB 2133 MHz DDR4 RAM
4K Touchscreen Display
DW1560(Replaced from Intel AC8265)
Realtek ALC236
USB 3.0 x 2
TYPE-C x 1 (USB 3.1, Display Port, Thunderbolt)
Audio Jack x 1
JBL Branded Speaker
Built-in microphone × 2

{Bios}
- Configuration
Wireless LAN [Enabled]
* SATA Controller Mode [AHCI]
Graphic Device [Switchable Graphics]
Power Beep [Disabled]
Intel Virture Technology [Enabled]
Bios Back Flash [Disabled]
Hotkey Mode [Disabled]
Always On USB [Enabled]
Thunderbolt (TM) Device Boot Surpport [Enabled]
Thermal Control [Performance]

- Security
* Intel Platform Trust Technology [Disabled]
* Intel SGX [Software Controlled]
* Secure Boot [Disabled]

- Boot
* Boot Mode [UEFI]
Fast Boot [Enabled]
USB Boot [Enabled]
PXE Boot to LAN [Enabled]
IPV4 PXE First [Enabled]
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Aug 20, 2018
Messages
28
Motherboard
Dell Latitude 5290 2-in1
CPU
i5 8350u
Graphics
UHD 630
"Problem Reporting" files are incomplete.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.

Thank you.
Here is Problem Report file.
Today I updated PB7 (18A371) with System Software Update.
After Update, brightness adjustment not activated.
So I deleted AppleBacklightInjector.kext in efi, it makes can brightness control but can't uniform brightness adjustment.
(There is brightness gap between minimum level and one level above)
I do not know if this is beta 7 error or hackintosh error.

Brightness is solved with restore AppleBacklightInjector.kext in EFI and add PNLF in config.plist
 
Last edited:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Thank you.
Here is Problem Report file.
Today I updated PB7 (18A371) with System Software Update.
After Update, brightness adjustment not activated.
So I deleted AppleBacklightInjector.kext in efi, it makes can brightness control but can't uniform brightness adjustment.
(There is brightness gap between minimum level and one level above)
I do not know if this is beta 7 error or hackintosh error.

Brightness is solved with restore AppleBacklightInjector.kext in EFI and add PNLF in config.plist
AddPNLF is not to be used.
Read the guide carefully:
https://www.tonymacx86.com/threads/guide-laptop-backlight-control-using-applebacklightinjector-kext.218222/
 
Joined
Dec 9, 2018
Messages
1
Motherboard
YOGA 720 15IKB 80X7
CPU
i7-7700HQ/C230
Graphics
HD 630 / GTX 1050
Hello! I have exactly or very similar configuration of yoga laptop, I like to experiment, but some of the tricks here are over my knowledge and it will take me a lot of time to find the way.. pleas can you share your clover config, and/or another techniques you used on your laptop? Will be very nice.. thank you!
 
Joined
Dec 11, 2018
Messages
2
Motherboard
yoga 720-ibk
CPU
i5-7600hq
Graphics
hd630/gtx1050
hello i have the same laptop and im trying to install 10.14 but i meet a lot of problems.
could u share ur efi ? plz.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
hello i have the same laptop and im trying to install 10.14 but i meet a lot of problems.
could u share ur efi ? plz.
Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html

Although you should read the FAQ for an overview of issues, the Clover guide is linked from the first question: "Q. Where do I start?", just after the bold face "Clover Guide".
Here is a direct link, just to be clear:
https://www.tonymacx86.com/threads/guide-booting-the-os-x-installer-on-laptops-with-clover.148093/

Also, your profile must be filled out with complete details as requested in the FAQ, again under "Q. Where do I start?". All seven details requested are equally important.

And if you have an issue (after following the guide), or on any other problem, you must provide a detailed description of the problem including information that helps us understand what you're doing. Always attach "Problem Reporting" files as per FAQ.
http://www.tonymacx86.com/el-capitan-laptop-support/164990-faq-read-first-laptop-frequent-questions.html
The required files and data are fully detailed in the last question in the FAQ:
"Q. What are typical "Problem Reporting" files?"
 
Joined
Aug 20, 2018
Messages
28
Motherboard
Dell Latitude 5290 2-in1
CPU
i5 8350u
Graphics
UHD 630
Hello! I have exactly or very similar configuration of yoga laptop, I like to experiment, but some of the tricks here are over my knowledge and it will take me a lot of time to find the way.. pleas can you share your clover config, and/or another techniques you used on your laptop? Will be very nice.. thank you!
Hello! I have exactly or very similar configuration of yoga laptop, I like to experiment, but some of the tricks here are over my knowledge and it will take me a lot of time to find the way.. pleas can you share your clover config, and/or another techniques you used on your laptop? Will be very nice.. thank you!
I edited post with attaching EFI.
Good Luck.
 
Last edited:
Top