Contribute
Register

[solved] Kernel Panic with running El Capitan on memory channel B

Status
Not open for further replies.

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi kylec,
I think I have the very same problem! I'm trying to install El Capitan on an HP notebook (model 15-ac191nl, i5 5200 @2.2GHz, HD 1TB, 8Gbyte RAM, Radeon M330), I was not able (the installer crashes). I installed linux instead and, from what I see from acpi tools, I've probably the same channel B problem.

I'd like to give a try to your solution, but I have a very stupid question: how can I replace the (manually edited) config.plist in my USB boot stick? Where is the EFI/ directory located, and all the support files? I've created the USB boot stick with the standard clover installer, I can see just the HFS+ partition containing the El Capitan installer... Are the support files contained in the PBR? Or in some invisible partitions? And how can I mount them in order to manually modify/edit the config.plist?

Thank you very much!

Follow the Clover guide linked from the FAQ.

http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html
 
Joined
Mar 29, 2011
Messages
858
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
You should be able to use Rehabman's mount_efi.sh. Or just look for the EFI partition in `diskutil list` and then mount it with `diskutil mount`.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
You should be able to use Rehabman's mount_efi.sh. Or just look for the EFI partition in `diskutil list` and then mount it with `diskutil mount`.

Mounting EFI is clearly documented in the FAQ.

And also in the Clover guide (post #2, as indicated in the FAQ).
 
Joined
Mar 29, 2011
Messages
858
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Mounting EFI is clearly documented in the FAQ.

And also in the Clover guide (post #2, as indicated in the FAQ).

So what, I can't provide a little additional guidance IN MY OWN THREAD!?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
So what, I can't provide a little additional guidance IN MY OWN THREAD!?

I was just pointing out (for the person who asked about it) that there are more detailed instructions in the FAQ and Clover guide.

Not everyone will be able to run with 'use mount_efi.sh' as there are not enough details provided. Most people will not know where to get it, how to install it, nor how to run it.

No reason to take offense.

Note that generally the USB stick is created MBR and the Clover files exist on a normal partition, not EFI. The OP had asked questions which made it sound like still dealing with the USB installer... which is why I pointed to the FAQ and the Clover guide originally.
 
Joined
Mar 29, 2011
Messages
858
Motherboard
ASRock X99 Extreme6
CPU
E5-2690 v4
Graphics
Radeon VII
Something about the phrase "clearly documented" made it sound like a rebuke. "I have already answered this, peon." ;)

Sorry for the misunderstanding.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,497
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Something about the phrase "clearly documented" made it sound like a rebuke. "I have already answered this, peon." ;)

I think you're reading things into my post that aren't there.
 
Joined
Apr 18, 2012
Messages
3
CPU
Core i3 3.08GHz
Graphics
ATI Radeon HD 5000
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
Thanks, thanks, thanks to all!!!
 
Joined
May 1, 2016
Messages
1
Thank you kylec for this absolute brilliant solution to this issue!
And many thanks to RehabMan for his fantastic clover guide as well!

You guys rock! :clap:
 
Joined
May 2, 2010
Messages
68
Motherboard
HP Probook 4530s-Clover
CPU
i5-2430M
Graphics
HD 3000
Just for info I have installed El Capitan on an older Gigabyte (in my signature) P55 UD3-L board, installation ok, ran multibeast with minimal options.
When I try to boot on the actual El capitan partition, it just reboots at the apple logo it seems to stop at
zone_init: kmem_suballoc failed.
I think I am going to try to edit the SMBIOS tab as advised by Kylec...
 
Status
Not open for further replies.
Top