Contribute
Register

[solved] Intel UHD 630 Graphics Problem High Sierra

Joined
Dec 14, 2017
Messages
49
Motherboard
GIGABYTE z370xp SLI
CPU
i7 8700k
Graphics
NVIDIA GeForce GTX 1050 ti
Mac
  1. iMac
Hey guys,
I just build my first Hackintosh with a Gigabyte z370xp SLI with an i7 8700k processor and I am using a dell p2715q monitor. I do not use a graphics card and am using the Intel UHD630 Graphics from the processor.
Heres the problem,
When I boot up macos, it starts out in 4k, but at about 3/4 the way of the progress bar, it swithces to 1080p and I dont have an option to run 4k in the display menu. I am running the IntelGFX at 0x59128086 and the ig-platform-id 0x59120000.

After looking through the forums here, someone suggested to have the IntelGFX at 0x3e928086 and after doing that, it boots into 4k, but the graphics are not good. Very glitchy everytime im move the mouse or open an application, and it is unusable. I looked more into it and I saw that you should install the lilu and IntelGraphicsFixup kexts, and I downloaded Kextbeast and followed the instructions and I think i installed the kexts but Im not sure if it worked. Im not sure how to use kextbeast and I think im using it wrong.

I am very new to computers and how to use them, so any help would help!!

Thanks.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,867
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hey guys,
I just build my first Hackintosh with a Gigabyte z370xp SLI with an i7 8700k processor and I am using a dell p2715q monitor. I do not use a graphics card and am using the Intel UHD630 Graphics from the processor.
Heres the problem,
When I boot up macos, it starts out in 4k, but at about 3/4 the way of the progress bar, it swithces to 1080p and I dont have an option to run 4k in the display menu. I am running the IntelGFX at 0x59128086 and the ig-platform-id 0x59120000.

After looking through the forums here, someone suggested to have the IntelGFX at 0x3e928086 and after doing that, it boots into 4k, but the graphics are not good. Very glitchy everytime im move the mouse or open an application, and it is unusable. I looked more into it and I saw that you should install the lilu and IntelGraphicsFixup kexts, and I downloaded Kextbeast and followed the instructions and I think i installed the kexts but Im not sure if it worked. Im not sure how to use kextbeast and I think im using it wrong.

I am very new to computers and how to use them, so any help would help!!

Thanks.

Are you certain you're not in 4k but scaled? Check in SysPrefs->Displays and in System Information.app.
You might be able to select 4k resolution (might be kind of small on a 27" monitor) by using RDM (Retina Display Menu).
 
Joined
Dec 14, 2017
Messages
49
Motherboard
GIGABYTE z370xp SLI
CPU
i7 8700k
Graphics
NVIDIA GeForce GTX 1050 ti
Mac
  1. iMac
I solved the problem by installing the CoreDisplayFixup.kext , lilu.kext, and the IntelGraphicsFixup.kext and everything works perfectly.
 
Joined
Sep 24, 2012
Messages
98
Motherboard
Alienware m15 R1
CPU
i7-8750H
Graphics
Intel HD 630/GTX 1070
I solved the problem by installing the CoreDisplayFixup.kext , lilu.kext, and the IntelGraphicsFixup.kext and everything works perfectly.
HI, which ig-platform-id and IntelGFX did you end up using?
 
Top