Contribute
Register

[Solved] - Intel HD 630 Mojave - what kext do you need - no DVMT?

Joined
Feb 21, 2018
Messages
127
Motherboard
Dell optiplex 7050 sff
CPU
Intel(R) Core(TM) i7-7700 CPU @ 3.60 GHZ
Graphics
Intel HD Graphics 630
Mac
MacBook Pro
Mobile Phone
iOS
Any luck with this??
Was going to try but had to reprioritze:/, might be able to try next week, an arguent thing unfortunately came up, if you get it to work please post here, I`ll do the same as soon as I have tried.
 
Joined
Feb 21, 2018
Messages
127
Motherboard
Dell optiplex 7050 sff
CPU
Intel(R) Core(TM) i7-7700 CPU @ 3.60 GHZ
Graphics
Intel HD Graphics 630
Mac
MacBook Pro
Mobile Phone
iOS
Neither.
Most people only need :
ApfsDriverLoader-64.efi (or apfs.efi)
AptioMemoryFix-64.efi
FSInject-64.efi
HFSPlus.efi (or vboxhfs-64-efi)


If you don't know what it is doing then don't enable it.
Ok, So, It's moving forward, no more "IGPU driver failed to load", but, still I only have 8mb and no HDMI.
Any tips :/?
Is there any change someone can glanze in my config.plist :(?

THANKS!!!!
 

Attachments

Joined
Feb 21, 2018
Messages
127
Motherboard
Dell optiplex 7050 sff
CPU
Intel(R) Core(TM) i7-7700 CPU @ 3.60 GHZ
Graphics
Intel HD Graphics 630
Mac
MacBook Pro
Mobile Phone
iOS
aight, will read again, do you need I need the frambuffer patch to make the ram work or is it more likely that I just have the wrong device/plattform id for my gpu? :/

Added my config with the frambuffer patches I've tried. I don't quite get who to get for ex "AQAAAA==" to the device properties in clover, how do you translate your values in Intel FB-Patcher patch for the ram to the proterites values under devices in clover :/?
 

Attachments

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
21,583
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
do you need I need the frambuffer patch to make the ram work or is it more likely that I just have the wrong device/plattform id for my gpu? :/
If you leave everything up to Lilu.kext and WhatEverGreen.kext then it may/should work.

Added my config with the frambuffer patches I've tried. I don't quite get who to get for ex "AQAAAA==" to the device properties in clover, how do you translate your values in Intel FB-Patcher patch for the ram to the proterites values under devices in clover :/?
You can use Text Mode in Clover Configurator or Xcode, PlistEditPro etc.
 
Joined
Feb 21, 2018
Messages
127
Motherboard
Dell optiplex 7050 sff
CPU
Intel(R) Core(TM) i7-7700 CPU @ 3.60 GHZ
Graphics
Intel HD Graphics 630
Mac
MacBook Pro
Mobile Phone
iOS
For those having problem with this and have a Dell 7050 sff, try this config.plist, I use one HDMI and one DVI.
I haven't fixed all issues, but this is a good way forward.
 

Attachments

Joined
Jan 9, 2017
Messages
19
Motherboard
Q270
CPU
i7 7700
Graphics
HD 630
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iBook, iMac, Power Mac
Mobile Phone
iOS
For those having problem with this and have a Dell 7050 sff, try this config.plist, I use one HDMI and one DVI.
I haven't fixed all issues, but this is a good way forward.
Hi,

What kind of issues are you still dealing
 
Joined
Feb 21, 2018
Messages
127
Motherboard
Dell optiplex 7050 sff
CPU
Intel(R) Core(TM) i7-7700 CPU @ 3.60 GHZ
Graphics
Intel HD Graphics 630
Mac
MacBook Pro
Mobile Phone
iOS
Hi,

What kind of issues are you still dealing
Had some issues with sound / and youtube video in safari couldn't skip forward, installed voodokext seemed to have worked. Gave up AppleALC, using bluetooth when listening to music anyway.

Sleep won't work.

No USB / external disk symbol on ex. USB disks (orange symbol).

FixShutdown was needed for restart etc.

Don't know, but It seems like the secondary screen (the one connected via HDMI) sometimes, like every third hour or whatever flickers for an instance, driving me a bit crazy not knowing why :).
 
Last edited by a moderator:
Joined
Feb 21, 2018
Messages
127
Motherboard
Dell optiplex 7050 sff
CPU
Intel(R) Core(TM) i7-7700 CPU @ 3.60 GHZ
Graphics
Intel HD Graphics 630
Mac
MacBook Pro
Mobile Phone
iOS
Had some issues with sound / and youtube video in safari couldn't skip forward, installed voodokext seemed to have worked. Gave up AppleALC, using Bluetooth when listening to music anyway.

Sleep won't work.

No USB / external disk symbol on ex. USB disks (orange symbol).

FixShutdown was needed for restart etc.

Don't know, but It seems like the secondary screen (the one connected via HDMI) sometimes, like every third hour or whatever flickers for an instance, driving me a bit crazy not knowing why :).
USB symboled fixed, but no USB 3.0 speed.
 
Last edited by a moderator:

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Top