Contribute
Register

[Solved] Intel HD 4000 on i7 3770, no graphics

Status
Not open for further replies.
Joined
Oct 26, 2013
Messages
1,054
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
I don't think I have a DSDT?

If you do not know mobo DSDT table, set IMEI to 0x1e3a8086 in Devices / Fake ID / IMEI, also check AddDTGP and AddIMEI in Acpi section.
 
Joined
Nov 25, 2017
Messages
34
Motherboard
Shuttle hx61v
CPU
I7 3770
Graphics
HD4000
IMEI in Devices tab, may need check AddDTGP and AddIMEI in Acpi section, depended on DSDT.
This didn't work, the computer would not boot. I got the NO screen.
 
Joined
Oct 26, 2013
Messages
1,054
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
This didn't work, the computer would not boot. I got the NO screen.

6 series mobo IMEI is 0x1c3a8086, default FB kext is AppleIntelSNBGraphicsFB for HD3000, does not work with HD4000, use Fake ID / IMEI 0x1e3a8086 is the basic step, without IMEI 0x1e3a8086, Ivy kexts AppleIntelFramebufferCapri will never load, retry others ig-platform-id again.

Try attached config.plist
 

Attachments

  • config.plist
    6.2 KB · Views: 1,195
Last edited:
Joined
Nov 25, 2017
Messages
34
Motherboard
Shuttle hx61v
CPU
I7 3770
Graphics
HD4000
6 series mobo IMEI is 0x1c3a8086, default FB kext is AppleIntelSNBGraphicsFB for HD3000, does not work with HD4000, use Fake ID / IMEI 0x1e3a8086 is the basic step, without IMEI 0x1e3a8086, Ivy kexts AppleIntelFramebufferCapri will never load, retry others ig-platform-id again.

Try attached config.plist
This config.plist works!!!! Thank you!
 
Joined
Sep 18, 2016
Messages
1
Motherboard
GIGABYTE GA-H61M-S1
CPU
i7-3770
Graphics
Intel HD Graphics 4000
Mac
  1. iMac
Classic Mac
  1. Apple
  2. iMac
Mobile Phone
  1. iOS
This config.plist works!!!! Thank you!
Hey man what ig plataform are you using?? I have the same hardware but this config.plist doesn't works for me :((
 
Joined
Nov 25, 2011
Messages
43
Motherboard
Gigabyte GA-Z77X-UD5H
CPU
i5-3570K
Graphics
HD 4000
Mac
  1. iMac
  2. Mac mini
Classic Mac
  1. Classic
  2. PowerBook
Mobile Phone
  1. iOS
6 series mobo IMEI is 0x1c3a8086, default FB kext is AppleIntelSNBGraphicsFB for HD3000, does not work with HD4000, use Fake ID / IMEI 0x1e3a8086 is the basic step, without IMEI 0x1e3a8086, Ivy kexts AppleIntelFramebufferCapri will never load, retry others ig-platform-id again.

Try attached config.plist

I have a h61n-usb3 and I just upgraded from i3 to i5 3570K and had graphics issues (HD4000 only showing 3MB). I tried a few things then I installed your config file and BAM, problem solved and it boots faster than ever now!

Much thanks!!
 
Joined
Aug 18, 2014
Messages
92
Motherboard
Gigabyte Z490 Vision D
CPU
i7 10900K
Graphics
Vega VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
6 series mobo IMEI is 0x1c3a8086, default FB kext is AppleIntelSNBGraphicsFB for HD3000, does not work with HD4000, use Fake ID / IMEI 0x1e3a8086 is the basic step, without IMEI 0x1e3a8086, Ivy kexts AppleIntelFramebufferCapri will never load, retry others ig-platform-id again.

Try attached config.plist

Hello! By any chance, do you know de FAKE ID IMEI for Intel 7 series and Intel HD 4000?
Many thanks!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
184,623
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello! By any chance, do you know de FAKE ID IMEI for Intel 7 series and Intel HD 4000?
Many thanks!

No need use use a fake IMEI device-id with 7-series/HD4000 combo.
 
Joined
Aug 18, 2014
Messages
92
Motherboard
Gigabyte Z490 Vision D
CPU
i7 10900K
Graphics
Vega VII
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
  4. Mac Pro
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
No need use use a fake IMEI device-id with 7-series/HD4000 combo.
No need use use a fake IMEI device-id with 7-series/HD4000 combo.

Hello there!

Well, I did it and it was the only way to get Full QE/QI Acceleration. I looked inside AppleIntelFramebufferCapri.kext-->Show Package Contents-->Info.plist, I saw that the IOPCIPrimaryMatch value was 0x1e3a8086. I apply this to the Fake IMEI device-id and then it started to work smoothly! As well I set Intel Inject as True, and I use 0x0166000a as the ig-platform-id. My mobo is an ASUS P8Z77-M...
Thanks!
 
Status
Not open for further replies.
Top