Contribute
Register

[Solved] Intel HD 4000 on i7 3770, no graphics

Status
Not open for further replies.
Joined
Nov 25, 2017
Messages
34
Motherboard
Shuttle hx61v
CPU
I7 3770
Graphics
HD4000
So, I’m putting together a desktop with H61 board, i7 3770k and Intel HD 4000.

I have smbios set to iMac 13,2 and platform set to 01660003. Graphics card is not being picked up.

I have tried several combinations of platform and device Id, most resulting in no boot with the no symbol or indefinite loading bar. Basically anything in platform other than 01660003 won’t boot.

Does anyone happen to have experience with this combo?
 
Joined
Nov 25, 2017
Messages
34
Motherboard
Shuttle hx61v
CPU
I7 3770
Graphics
HD4000
Joined
Nov 25, 2017
Messages
34
Motherboard
Shuttle hx61v
CPU
I7 3770
Graphics
HD4000
The monitor is an HP Pavilion 27xw, I am connecting with an HDMI cable. I am getting 1920 x 1080 resolution when I boot off the USB drive, but system doesn't recognize the monitor and reports Intel HD 4000 7mb as the GPU.

Something weird - when I boot off UEFI, I am stuck in 1024 x 768 and system reports Intel HD 4000 3mb as the GPU.
 
Joined
Jul 25, 2012
Messages
6,809
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
The monitor is an HP Pavilion 27xw, I am connecting with an HDMI cable. I am getting 1920 x 1080 resolution when I boot off the USB drive, but system doesn't recognize the monitor and reports Intel HD 4000 7mb as the GPU.

Something weird - when I boot off UEFI, I am stuck in 1024 x 768 and system reports Intel HD 4000 3mb as the GPU.
Since you have been doing graphics card changes, I am just wondering if your BIOS setup might have changed.
Please check BIOS and make sure the Initial DISPLAY = IGFX and Internal Graphics Memory size=96 and DVMT Total 256M and save and on reboot go to CBM >screen and Options>Graphics Injector-->
and try ig-platform ID =0166000a and [√] Inject Intel no FakeID and try to boot the System disk ( I presume that is what you are calling UEFI) and see if you can get the full QE/CI.
 
Joined
Jul 6, 2011
Messages
40
Motherboard
Intel Nuc6i5SYH
CPU
I5-6260U
Graphics
Intel Iris 540
Mobile Phone
  1. Android
So, I’m putting together a desktop with H61 board, i7 3770k and Intel HD 4000.

I have smbios set to iMac 13,2 and platform set to 01660003. Graphics card is not being picked up.

I have tried several combinations of platform and device Id, most resulting in no boot with the no symbol or indefinite loading bar. Basically anything in platform other than 01660003 won’t boot.

Does anyone happen to have experience with this combo?

try 0x01660009
 
Joined
Oct 26, 2013
Messages
1,054
Motherboard
MSI B250M PRO-VHD
CPU
i3-7100
Graphics
RX 570
Does it go in IMEI or IntelGFX in Devices tab?

IMEI in Devices tab, may need check AddDTGP and AddIMEI in Acpi section, depended on DSDT.
 
Status
Not open for further replies.
Top