Contribute
Register

[Solved] Installation couldn't allocate runtime area error

Status
Not open for further replies.
Joined
Mar 11, 2017
Messages
13
Motherboard
MSI X299 SLI PLUS
CPU
i7-7800X
Graphics
GTX 1080 Ti
Hi, I've tried to install a mojave os for my computer without success.
Here is the error in the shared media when I activate the verbose mode.

I tried to do this without success and it's way complicated compared to a simple installation. I don't have also the half of the BIOS options compared to an Asus motherboard. https://www.tonymacx86.com/threads/...ojave-successful-build-extended-guide.255082/

I don't really know what to do to fix this error, I tried many possibilities with the drivers64UEFI folder and others clovers versions but I'm clearly blocked... It's been one year I'm waiting for help, I thanks you in advance for you replies.
 

Attachments

  • IMG_5664.jpg
    IMG_5664.jpg
    1.1 MB · Views: 966
Joined
Jul 25, 2012
Messages
6,822
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi, I've tried to install a mojave os for my computer without success.
Here is the error in the shared media when I activate the verbose mode.

I tried to do this without success and it's way complicated compared to a simple installation. I don't have also the half of the BIOS options compared to an Asus motherboard. https://www.tonymacx86.com/threads/...ojave-successful-build-extended-guide.255082/

I don't really know what to do to fix this error, I tried many possibilities with the drivers64UEFI folder and others clovers versions but I'm clearly blocked... It's been one year I'm waiting for help, I thanks you in advance for you replies.
  • First check the Intel CPU name listed in your Personal Details and edit it correctly. There is a Typo in i7X-7800
    .
  • With your EVGA 1080 ti PCIE Graphics and lack of Intel HD Graphics from your CPU, you won't be able to install Mojave with the listed MoBo
  • If you can get a PCIE Graphics that its natively supported by macOS Mojave 10.14.X , your Motherboard should support Mojave Installation with the current CPU.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,287
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Start by powering off the machine, pulling the power cable for 10 seconds, re-plug and boot up.

At Clover boot screen, press Spacebar and enable the 4th item: Disable KASLR (slide=0).

Then try again.

If the error persists, replace AptioMemoryFix-64 in your driversUEFI64 folder with one of the alternatives:

OsxAptioFixDrv.efi
OsxAptioFix2Drv.efi
OsxAptioFix3Drv.efi
OsxAptioFix2Drv-free2000.efi (search Google for this keyword)

Install only one of these at a time with and without “slide=0”.

One of the combinations should hopefully work.
 
Joined
Mar 11, 2017
Messages
13
Motherboard
MSI X299 SLI PLUS
CPU
i7-7800X
Graphics
GTX 1080 Ti
  • First check the Intel CPU name listed in your Personal Details and edit it correctly. There is a Typo in i7X-7800
    .
  • With your EVGA 1080 ti PCIE Graphics and lack of Intel HD Graphics from your CPU, you won't be able to install Mojave with the listed MoBo
  • If you can get a PCIE Graphics that its natively supported by macOS Mojave 10.14.X , your Motherboard should support Mojave Installation with the current CPU.

Thank you for your fast answer, here is my personal detail updated. Unfortunately I don't have an other graphic card, does it have an other way with some kext or a clover configuration to clear this issue ? (sorry I don't really know what is usefull at the install or post install) I keep trying with others configs.
 
Joined
Mar 11, 2017
Messages
13
Motherboard
MSI X299 SLI PLUS
CPU
i7-7800X
Graphics
GTX 1080 Ti
Start by powering off the machine, pulling the power cable for 10 seconds, re-plug and boot up.

At Clover boot screen, press Spacebar and enable the 4th item: Disable KASLR (slide=0).

Then try again.

If the error persists, replace AptioMemoryFix-64 in your driversUEFI64 folder with one of the alternatives:

OsxAptioFixDrv.efi
OsxAptioFix2Drv.efi
OsxAptioFix3Drv.efi
OsxAptioFix2Drv-free2000.efi (search Google for this keyword)

Install only one of these at a time with and without “slide=0”.

One of the combinations should hopefully work.

I tried each case without success, got the error for kernel cache, I don't know if it's an usefull information. It's been 12hours I tried to past the first part of the installation...
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,287
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Joined
Mar 11, 2017
Messages
13
Motherboard
MSI X299 SLI PLUS
CPU
i7-7800X
Graphics
GTX 1080 Ti

Attachments

  • EFI.zip
    3.5 MB · Views: 145

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,287
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
There is my EFI
There are a lot of settings in your config.plist, which seems as if you've gotten past Step 11 (i.e. you have finished Post-Installation) and are trying to reboot the machine after Post-Installation. Is this correct?

You also have multiple Aptio Memory Fix drivers in driversUEFI64. Only 1 can be installed at a time.

I'll upload a modified version shortly.
 
Joined
Mar 11, 2017
Messages
13
Motherboard
MSI X299 SLI PLUS
CPU
i7-7800X
Graphics
GTX 1080 Ti
There are a lot of settings in your config.plist, which seems as if you've gotten past Step 11 (i.e. you have finished Post-Installation) and are trying to reboot the machine after Post-Installation. Is this correct?

I used Unibeast to generate the config, and a clover config to edit the EFI after this config. I'm blocked just after starting the macOS partition of my USB drive I can't event pass to the screen to install macOS.

Thank you so much.
 
Last edited:

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
16,287
Motherboard
Gigabyte Z490 Vision D
CPU
i5-10400
Graphics
RX 580
Mac
  1. MacBook Air
  2. MacBook Pro
  3. Mac Pro
Classic Mac
  1. Quadra
Mobile Phone
  1. iOS
Attached is a modified EFI. Please backup your existing EFI folder, then delete it from USB disk and replace with the attached version (be sure to rename it to "EFI").

Please note that your nVidia card is not supported by Mojave. I have disabled everything in EFI pertaining to nVidia cards. Your system should still function using Apple's default display driver. It will give you very slow video performance, but right now we're not concerned about accelerated video -- we're just concerned about getting Mojave installed.

This version uses "AptioMemoryFix-64.efi" without "slide=0". As mentioned earlier, we have have to try:

  • AptioMemoryFix-64 with slide=0 --> does it work?
  • Replace AptioMemoryFix-64 with OsxAptioFix2Drv-free2000.efi and slide=0 --> does it work?
  • Try again but without slide=0, does it work?
OsxAptioFix2Drv-free2000 can be downloaded from Bullet #3 here:
https://nickwoodhams.com/x99-hackintosh-osxaptiofixdrv-allocaterelocblock-error-update/
 

Attachments

  • EFI-MrGlox.zip
    3.3 MB · Views: 302
Status
Not open for further replies.
Top