Contribute
Register

[Solved] iMessage stopped working with Clover >4428

Status
Not open for further replies.
Joined
Aug 21, 2011
Messages
25
Motherboard
Gigabyte GA-EP45-DS3
CPU
Q9550
Graphics
GT640
I updated successfully to 10.13.5 and all worked fine, including iMessage. All-of-a-sudden, iMessage stopped working and can't be activated anymore. I logged out from icloud and relogged in, but still no iMessage activation possible. I am using the latest Clover 4509 (4497 didn't work either)

Does anyone else have problems activating iMessage (since) today?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
25,323
Motherboard
Lenovo ThinkStation p700
CPU
2x E5-2620 V3
Graphics
RX 560
Mac
  1. MacBook Pro
  2. Mac mini
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I updated successfully to 10.13.5 and all worked fine, including iMessage. All-of-a-sudden, iMessage stopped working and can't be activated anymore. I logged out from icloud and relogged in, but still no iMessage activation possible.

Does anyone else have problems activating iMessage (since) today?
See Post #2 regarding requests for help.
 
Joined
Aug 21, 2011
Messages
25
Motherboard
Gigabyte GA-EP45-DS3
CPU
Q9550
Graphics
GT640
See Post #2 regarding requests for help.

I was just curious if anyone else was experiencing iMessage Login problems since the update or if it was something unrelated to the update on my side. I still can't login (Error 18 - invalid login), very strange.
 

ModBot

Super Moderator
Staff member
Joined
Jan 9, 2011
Messages
1,350
Motherboard
01010
CPU
10101
Graphics
01010
Moved to a standalone thread to received more visibility.
 
Joined
Sep 27, 2011
Messages
17
Motherboard
GA-B85M-D3H
CPU
i5-4670K
Graphics
PowerColor Red Devil RX580 8G
Mac
  1. iMac
  2. MacBook Air
  3. MacBook Pro
  4. Mac mini
Classic Mac
  1. Apple
Mobile Phone
  1. Android
  2. iOS
My imessage/facetime is normal on 10.13.5. With MLB/ROM parameters obtained from my old Mac mini in Clover settings, imessage/facetime never failed me after any updates/upgrades including 10.13.5 ;)
 
Last edited:
Joined
Aug 21, 2011
Messages
25
Motherboard
Gigabyte GA-EP45-DS3
CPU
Q9550
Graphics
GT640
After many wasted hours i found the Solution: it was CLOVER. I have the habit to update CLOVER before installing new OS Releases. That was a big mistake this time ;)

I rolled back to CLOVER 4428 and iMessage works again like it (always) did before. 4428 seems to be the last working Version, i tried 4497, 4509, 4458 and 4522.

Admin: please add solved and solution to the Thread. Holy moly.

Final EDIT:

As it turns out: Clover won't no longer do automatic Network Injection as "built-in" with Version >4428. You can check if your primary network interface is listed as "IOBuiltin" with IORegistryexlorer". It MUST be "true" for iMessage to activate.

You have to add
Code:
                <key>LANInjection</key>
                <true/>

into "Devices" of your config.plist.



A moderator should adapt Thread Title: iMessage stopped working with Clover >4428, it isn't related to macOS 10.13.5.
 
Last edited:
Status
Not open for further replies.
Top