Contribute
Register

[Solved] ICH10R and High Sierra

Going Bald

Moderator
Joined
Aug 14, 2010
Messages
23,025
Motherboard
GA-X58A-UD7-F7
CPU
W3670
Graphics
RX 580
Mac
iMac, MacBook Pro, Mac mini
Classic Mac
iMac
installing on an internal HD... regular HD...
Using macpro5,1 or Macpro6,1 bios settings...
get a big No Circle...

A USB installer of High Sierra cannot see the HD at all...
As if the HD is not connected...
post config.plist with MacPro5,1 system definition
 
Joined
Jun 24, 2011
Messages
34
Motherboard
DX58sO
CPU
990x
Graphics
2x GTS 250
Fix for ICH10 with High Sierra. Now with hot-plug support.

For this we need two binary patches.

First patch fix I/O error for ICH10:
Code:
4585F60F 95C289C8 83E0FE66 85C9780F 84D2750B -> 89C883E0 FE6685C9 0F98C141 08CC9090 9090750B
With second patch for hot-plug:

Code:
89C82540 6002003D 40200000 750C81E1 BF7FFFFF 898B5101 0000 -> 90909090 90909090 90909090 90909090 90909090 90909090 9090
Снимок экрана 2017-09-29 в 22.08.04.png


Screen Shot 2017-10-16 at 5.58.32 PM.jpg



This is not my work...

This patch was found on insanelymac.com
 
Last edited:
Joined
Oct 11, 2010
Messages
4
Motherboard
Asus P6X58D-E
CPU
i7 3Ghz
Graphics
Geforce GTX 470
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
Yes... legacy mode...
I already have Sierra Installed...
I have an Asus P6X58d-e, and I guess the USB controller should be the same...
I've installed with success High Sierra (no apfs conversion by now, and was a pain to get Clover to work), but none of my USB are working. The OS is not freezed at login cause the clock n the top right is going....
Did you have any issue with USB on Sierra?
Did you installed FakePCIID and FakePCIID_XHCIMux to get them work?
 
Joined
Oct 11, 2010
Messages
4
Motherboard
Asus P6X58D-E
CPU
i7 3Ghz
Graphics
Geforce GTX 470
Mac
MacBook Pro
Classic Mac
Mobile Phone
iOS
I've FIXED the usb problem on Asus P6X58d-e, installed the two kext FakePCIID and FakePCIID_XHCIMux and renamed the EHCI0 and EHCI1 in Clover... Don't have usb3.0 working but it's not a problem right now! I'm writing from High Sierra :p
 
Joined
Jul 25, 2012
Messages
54
Motherboard
Dell Precision T3500
CPU
Xeon 3503
Graphics
RX 560
Mobile Phone
Android
Fix for ICH10 with High Sierra. Now with hot-plug support.

For this we need two binary patches.

First patch fix I/O error for ICH10:
Code:
4585F60F 95C289C8 83E0FE66 85C9780F 84D2750B -> 89C883E0 FE6685C9 0F98C141 08CC9090 9090750B
With second patch for hot-plug:

Code:
89C82540 6002003D 40200000 750C81E1 BF7FFFFF 898B5101 0000 -> 90909090 90909090 90909090 90909090 90909090 90909090 9090
View attachment 286301

View attachment 286308
Assuming these changes should be made to the config.plist file using Clover Configurator? Also which section on Clover Configurator?

Thanks
 
Joined
Jun 24, 2011
Messages
34
Motherboard
DX58sO
CPU
990x
Graphics
2x GTS 250
I think this fix does not work for 10.13.2

Can someone verify this?
 
Joined
Jan 25, 2011
Messages
742
Motherboard
GA-X58A-UD3R
CPU
X5650
Graphics
R9 290
Mac
MacBook
Mobile Phone
Android, iOS
I think this fix does not work for 10.13.2

Can someone verify this?
I'm interested in this too-- because I'm trying to do a new install on my system as well, with 10.13.2. I can boot into the installer made with Unibeast, "install" HS (only took ~5 minutes; assume this is round one, as it were), but on reboot I get a kernel panic post Clover when I try to boot the new install from the USB stick. I also get the big no circle.

Can someone detail how to do this manually in the config file since I don't use clover configurator (don't trust it; want to understand the config file more directly myself).
 
Joined
Oct 1, 2012
Messages
25
Motherboard
Gigabyte Z68A-D3H-B3-F13
CPU
I5-2500K
Graphics
GTX 760
Mobile Phone
iOS
I think this fix does not work for 10.13.2

Can someone verify this?
Sorry to disappoint you... It's working fine with my build. I applied the fix in Clover Configurator as explained in post #14.
 
Top