Contribute
Register

[Solved] i7 4770k to i7 4790k - What changes are necessary?

jaymonkey

Moderator
Joined
Aug 27, 2011
Messages
3,458
Motherboard
ASRock-Z97 EX6
CPU
i7-4790K OC @ 4.8GHz
Graphics
Vega 64LC + HD4600
Mac
MacBook Air, MacBook Pro
Mobile Phone
Android, iOS
Am I using the correct PlatformID for the HD4600 IGPU setup in the uploaded EFI?
@Lumberjack88,

I don't see any information in the config.plist in the EFI you uploaded in Post #1 that relates a IGPU PlatformID ...
perhaps you deleted it as its a very truncated config file if not then you are not setting any Device Properties for IGPU.

The best match would be PlatformID 0x4160000 therefore the Device Properties for WhatEverGreen would be :-

AAPL,ig-platform-id = 00006041
device-id = 60410000

Data for PlatformID 0x4160000 :-

Code:
ID: 04160000, STOLEN: 64 MB, FBMEM: 16 MB, VRAM: 1024 MB, Flags: 0x00000004
TOTAL STOLEN: 209 MB, TOTAL CURSOR: 1 MB (1572864 bytes), MAX STOLEN: 209 MB, MAX OVERALL: 210 MB (220737536 bytes)
GPU Name: Intel HD Graphics 4600
Model Name(s):
Camelia: Disabled, Freq: 5273 Hz, FreqMax: 5273 Hz
Mobile: 0, PipeCount: 3, PortCount: 3, FBMemoryCount: 3
[0] busId: 0x00, pipe: 8, type: 0x00000002, flags: 0x00000030 - LVDS
[1] busId: 0x05, pipe: 9, type: 0x00000004, flags: 0x00000004 - DigitalDVI
[2] busId: 0x04, pipe: 9, type: 0x00000800, flags: 0x00000082 - HDMI
00000800 02000000 30000000
01050900 04000000 04000000
02040900 00080000 82000000

If you require further assistance please supply full and complete PR files as per this guide :-
https://www.tonymacx86.com/threads/tool-generate-proper-problem-reporting-files.235953/

Cheers
Jay
 
Top