Contribute
Register

[Solved] i7-3770K Freq max at 3.7Ghz Mojave

pastrychef

Moderator
Joined
May 29, 2013
Messages
8,573
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 + UHD 630
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
[B]pastrychef[/B], can you explain my other questions, please. I'm not sure I'm using my PC at maximum ))
Yes, you should enable KernelXCPM. This is supposed to help Sandy Bridge and Ivy Bridge with Turbo mode.

AppleIntelCPUPM depends on your motherboard. Check to see if MSR 0xE2 is locked. You can use DPCIManager to check. Please see this post for more info.
 
Joined
Dec 4, 2014
Messages
152
Motherboard
GA-Z170X Ultra Gaming
CPU
i7-7700K
Graphics
Vega 56
Mac
iMac, MacBook Pro, Mac Pro
Mobile Phone
Android
I should check that it is definitely stays locked? or it is better if I have no 0xE2 locked?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
8,573
Motherboard
Asus ROG Strix Z370-G Gaming (Wi-Fi AC)
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 + UHD 630
Mac
MacBook, Mac Pro
Classic Mac
iBook, Power Mac, PowerBook
Mobile Phone
iOS
I should check that it is definitely stays locked? or it is better if I have no 0xE2 locked?
If it is unlocked, you are fine.

If it is locked, you should enable AppleIntelCPUPM in config.plist.
 
Joined
Jan 13, 2017
Messages
181
Motherboard
Astock Z390 extreme 4
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
HI I got it.
I start system, Z77 - 3570K - generate SSDT / clock work perfect except boot problem.I need few restart before got desktop screen.. I upload debug and photos of boot stuck.
I need help
 

Attachments

Last edited:
Joined
Dec 16, 2012
Messages
81
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
jk2309, you sir are a legend. Re-flashing the bios fixed my speed step issues. Another telltale sign was that Mojave wasn't reporting my ram speed correctly, and now it is. Thanks!

Hi,

Just want to mention that I have my problem resolved!!! :D :D :D

What I did:-

1) I reflash my MB BIOS with the same F12 version.

I think Clover or some other injection methods made the motherboard BIOS went into limbo mode where the max freq at 3.7GHz. So I thought maybe I just reflash the bios and see how it goes.

Ta-da! Then after the reflashing, my manufacturer 3.9GHz Freq is back! then I OC it to 4.0Ghz ! Yeah it is back as well!! Now the hackintosh back to the fully working Mojave !!! Audio works, RX560 works, PM works, USB works, everything just works like the normal MAC !! except it is more awesome MAC machine !! :)

Thanks guys. Thanks for the tips. Keep up the good work..
 
Top