Contribute
Register

[Solved] How to get rid of the ATHR: unknown locale 21 errors

Joined
Feb 26, 2011
Messages
20
Motherboard
Gigabyte GA-Z97-D3H
CPU
i7-4790K
Graphics
GTX 760
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi guys,

here's a simple fix to get rid of the annoying "unknown locale" messages in your system.log. These are caused by the TP-LINK WDN-4800 card, which has a regulatory domain value in its eeprom that is not recognized by OS X. It works by simply replacing the check for regdomain 0x37 (ETSI) by checking for the one in the EEPROM, i.e. 0x21.

Patch kext: AirPortAtheros40
Find: 83 fb 37 (cmpl $0x37, %ebx)
Replace: 83 fb 21 (cmpl $0x21, %ebx)

Simply add this to your KextsToPatch array in Clover config.plist

Code:
			<dict>
				<key>Comment</key>
				<string>Atheros Locale Fix</string>
				<key>Find</key>
				<data>
				g/s3
				</data>
				<key>Name</key>
				<string>AirPortAtheros40</string>
				<key>Replace</key>
				<data>
				g/sh
				</data>
			</dict>

I hope this doesn't break anything else - it is in fact a very dirty hack. There are apparently other places in the kext where the regdomain is checked, but this one causes the error to be logged. Also, please note that this will most likely make you (maybe partially?) conformant to the ETSI regulations and limit your channels accordingly. There are other values instead of the 0x37 that should work as well, namely 0x5E (APL5_WORLD), 0x64 (WOR4_WORLD), 0x65 (WOR5_ETSIC), and 0x6A (WORA_WORLD). I honestly have little idea what will change when you use any of them instead of 0x37.

Anyway, I hope this helps somebody, instead of breaking their wifi :) The nice part is, that unlike an EEPROM hack (I haven't found any way to modify the EEPROM of WDN-4800) this is only as permanent as the entry in your Clover config, so you can remove it any time you wish.

Regards,
Stefan
 
Last edited:
Joined
Aug 16, 2012
Messages
16
Motherboard
GA-Z77X-UD5H
CPU
Core i7-3770K Ivy Bridge
Graphics
GTX 680
Mac
  1. MacBook Pro
Classic Mac
Mobile Phone
  1. Android
It works, thank you.
 
Joined
Jul 13, 2013
Messages
2
Mac
Classic Mac
Mobile Phone
Hi
Patch don't work on 10.10.1
???????? 2014-11-22 01.32.57.png???????? 2014-11-22 01.34.15.png????????_2014-11-22_01_33_49.png
 
Joined
May 23, 2014
Messages
2
Motherboard
ASUS VivoBook S15 S530Fn
CPU
i5-8265U
Graphics
UHD 620
Mobile Phone
  1. iOS
It works, thank you. :thumbup:

10.10.1

Code:
<dict>
                <key>Comment</key>
                <string>Atheros Locale Fix</string>
                <key>Find</key>
                <data>
                g/s3
                </data>
                <key>Name</key>
                <string>AirPortAtheros40</string>
                <key>Replace</key>
                <data>
                g/sh
                </data>    
</dict>
 
Joined
Mar 12, 2015
Messages
6
Motherboard
GA-Z97X-UD7 TH
CPU
I7 4790K
Graphics
GT740 2G
Mac
Classic Mac
Mobile Phone
Hey I have this issue but I am booting with Chimera. Is there a way to do this without clover. I currently can't use wifi and it will sometimes cause my boot to hang up.

Thanks
 
Top