Contribute
Register

[Solved] High Sierra X299 10.13 with AMD ATI Radeon HD 6670

Joined
Nov 14, 2015
Messages
27
Motherboard
ASUS Z97M, ASUS X299
CPU
i5-4690K, i7-7800X
Graphics
GTX750, HD6670
Hello! I'm hoping someone can point me in the right direction please.

ASUS Tuf Mk 2 X299
i7800x
850 EVO

I've installed MacOS High Sierra thanks to the "kgp" guide on the site. As the X299 board doesn't come with any internal gfx. I've installed an AMD ATI Radeon (Sapphire) HD 6670 2Gb. (I know!)

The Vendor/Product Id 0x1002 0x6758 appear in the AMD6000Controller.kext
I'm using WhateverGreen and Lilu in my EFI/CLOVER/Kexts/Other and MacOS reports all of these as loaded in kextwizard.

I've read of greater support (>10.12.6) for ATI/AMD and seen reports of successful builds with this card.

For some reason (unknown to me) the color is both ok (as expected) and yet switches often and quickly back & forth to a strange blue with some flicker with mouse movement. Very odd.

I've tried a different keyboard/mouse, monitor and both DVI and Analog.

Should I try something other than WhateverGreen and Lilu ? How do I know I'm using them ?
Are the built-in AMD6000Controller.kext any better? and how would I use them ?
Any votes for just buying an Nvidia card ? I'm more sure this will be compatible.

Let me know if there is other info I've missed (debug logs, etc.)

Daniel
 

Attachments

  • IMG_0001.JPG
    IMG_0001.JPG
    1.1 MB · Views: 2,154
  • Screen Shot 2017-12-13 at 11.27.44.png
    Screen Shot 2017-12-13 at 11.27.44.png
    142.3 KB · Views: 2,718
  • Screen Shot 2017-12-13 at 11.42.56.png
    Screen Shot 2017-12-13 at 11.42.56.png
    57.8 KB · Views: 2,253
Joined
Jul 20, 2013
Messages
15
Motherboard
GIGABYTE GA-H77-DS3H LGA 1155 Intel H77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
CPU
Intel Core i5-3570K Ivy Bridge 3.4GHz (3.8GHz Turbo) LGA 1155 77W Quad-Core Desktop Processor Intel
Graphics
rx 580 nitro+ Radeon 8gb
Hey I'm running the same card in my system and it has stoped working since the update to 10.13

Any help getting the card configured would be much appreciated!
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,490
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
Joined
Nov 14, 2015
Messages
27
Motherboard
ASUS Z97M, ASUS X299
CPU
i5-4690K, i7-7800X
Graphics
GTX750, HD6670
Brebo is bang on the money, much kudos, well done and thanks !
I quick download of ResXtreme and select 8 bits 1920x1080 and colour is perfect !
 
Joined
Oct 18, 2014
Messages
11
Motherboard
PC
CPU
Q6600
Graphics
AMD Radeon 4550
Mac
Classic Mac
Mobile Phone
i'm also trying to use 6670 on my hackintosh build. But i get a black screen. I was able to see and pull up the mac os installer just fine and was able to get it installed. On first boot i get a black screen. Seems active thou. After i let it sit my monitor goes to sleep. I shook the mouse and the screen went back to the black screen. Been using diff kext but havn't been able to get the perfect fit. Any help would be appreciated. Thanks!
 
Joined
Nov 14, 2015
Messages
27
Motherboard
ASUS Z97M, ASUS X299
CPU
i5-4690K, i7-7800X
Graphics
GTX750, HD6670
i'm also trying to use 6670 on my hackintosh build. But i get a black screen. I was able to see and pull up the mac os installer just fine and was able to get it installed. On first boot i get a black screen. Seems active thou. After i let it sit my monitor goes to sleep. I shook the mouse and the screen went back to the black screen. Been using diff kext but havn't been able to get the perfect fit. Any help would be appreciated. Thanks!

My HD 6670 just worked. I did use lilu & whatevergreen kext though.
My problem was the colors flickering which was fixed with ResXtreme.com
 
Joined
Oct 18, 2014
Messages
11
Motherboard
PC
CPU
Q6600
Graphics
AMD Radeon 4550
Mac
Classic Mac
Mobile Phone
My HD 6670 just worked. I did use lilu & whatevergreen kext though.
My problem was the colors flickering which was fixed with ResXtreme.com
I seem to have gotten it to boot up with only 5 mb of video memory. Do you mind helping me out with those kexts you used. I seem to have the outdated ones. If you wouldn't mind. Whenever you the chance. I'd really appreciate it. Thanks man!
 
Joined
Oct 18, 2014
Messages
11
Motherboard
PC
CPU
Q6600
Graphics
AMD Radeon 4550
Mac
Classic Mac
Mobile Phone
Looks like the solution was installing a couple of Sierra roll back kext via kext editor or any kext injecting tool. After maybe 2 installs don’t know why 2 but.... it worked. Perfectly. Though it took a while. Played paladins on steam perfectly. Rocket league as well. On par with my win 10 installation. Diving into the 6870 as I type this. I’ve become addicted to getting Mac OS running on other hardware. Lol
 
Top