Contribute
Register

[Solved] help needed with HS install/upgrade on 16,2 with M.2 SSD

Status
Not open for further replies.
Joined
Jan 10, 2012
Messages
126
Motherboard
AsRock Z97E-ITX/AC
CPU
i5-5675C
Graphics
HD 6200
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
Hello everybody.

I am desperate with upgrading my build to High Sierra. Any help would be highly appreciated.

My configuration does not seem to be very common, even though I quite like it, and it did not have major problems up to and including 10.12.6.

When trying to upgrade to 10.13.1 or 10.13.2 I get kernel panics when rebooting from the Install part of my system disk after starting the upgrade/install.

The verbose output of my boot (when not allowing a restart upon panic):
IMG_8510.jpg

It seems the panic occurs in cleanup_Installer:

Code:
Process:               cleanup_installer [67]
Path:                  /macOS Install Data/*/cleanup_installer
Identifier:            cleanup_installer
Version:               1073.8
Code Type:             X86-64 (Native)
Parent Process:        launchd [1]
Responsible:           cleanup_installer [67]
User ID:               0

Date/Time:             2018-01-04 17:37:49.650 +0100
OS Version:            Mac OS X 10.12.6 (16G1114)
Report Version:        12
Anonymous UUID:        3878DCFF-CC3E-ADEB-AB0E-D389E0F4127D


Time Awake Since Boot: 2 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Reason:    DYLD, [0x4] Symbol missing

Dyld Error Message:
  Symbol not found: _syslog$DARWIN_EXTSN
  Referenced from: /macOS Install Data/*/cleanup_installer (which was built for Mac OS X 10.13)
  Expected in: /usr/lib/libSystem.B.dylib

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   dyld                              0x000000010ab3f9ee __abort_with_payload + 10
1   dyld                              0x000000010ab3f43b abort_with_payload_wrapper_internal + 90
2   dyld                              0x000000010ab3f464 abort_with_payload + 9
3   dyld                              0x000000010ab1a793 dyld::halt(char const*) + 361
4   dyld                              0x000000010ab1a89e dyld::fastBindLazySymbol(ImageLoader**, unsigned long) + 139
5   libdyld.dylib                     0x00007fff9668f282 dyld_stub_binder + 282
6   ???                               0x000000010783e008 0 + 4421050376
7   libdyld.dylib                     0x00007fff96693235 start + 1

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000002000209  rbx: 0x0000000000000004  rcx: 0x00007fff583c2b38  rdx: 0x00007fff583c2fb0
  rdi: 0x0000000000000006  rsi: 0x0000000000000004  rbp: 0x00007fff583c2b90  rsp: 0x00007fff583c2b38
   r8: 0x00007fff583c2bb0   r9: 0x0000000000000000  r10: 0x0000000000000077  r11: 0x0000000000000246
  r12: 0x0000000000000077  r13: 0x00007fff583c2fb0  r14: 0x0000000000000006  r15: 0x0000000000000000
  rip: 0x000000010ab3f9ee  rfl: 0x0000000000000246  cr2: 0x0000000107875000
Logical CPU:     0
Error Code:      0x02000209
Trap Number:     133

I am somewhat bewildered as it mentioned that cleanup_installer was built for Mac OS X 10.13. Further up it says OS Version 10.12.6. Is that normal? I am trying to update from 10.12.6 with the Install macOS High Sierra app and would have assumed that the reboot would then run under 10.13...

Another thing that might be causing this is my M.2 SSD (ADATA SP600NS34) that I am booting from. As I wrote earlier, I did not have any problems with that under Sierra, but with High Sierra I do. Other people seem to have problems with M2 and High Sierra, and might be connected to the new file system - I have tried without as well.

I have so far not used lilu.kext - but have tried with it with both IntelGraphicsDVMTFixup.kext and IntelGraphicsFixup.kext without success.

For older versions of MacOS I was using several patches and a patched DSDT. Here are the patches:
Screen Shot 2018-01-14 at 13.36.17.png

If needed, I can post my SSDT (using my own, and i5-5675c)

Thanks for any ides you might have!
Best wishes,
Rudolf
 

Attachments

  • IMG_8510.jpg
    IMG_8510.jpg
    1.5 MB · Views: 86
Joined
Jul 25, 2012
Messages
6,714
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Any ideas?

  • The verbose boot screen shows that it is a bit complicated and would require multiple steps to untangle the web of problems and straighten things to begin the step-by step installation.
  • Can you upload the screen shot of Clover Boot Manager screen showing the disk icons to get a clearer feel for the issue?
  • Can you boot back to your previous 10.12.6. from CBM screen?
 
Joined
Jan 10, 2012
Messages
126
Motherboard
AsRock Z97E-ITX/AC
CPU
i5-5675C
Graphics
HD 6200
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  • The verbose boot screen shows that it is a bit complicated and would require multiple steps to untangle the web of problems and straighten things to begin the step-by step installation.
  • Can you upload the screen shot of Clover Boot Manager screen showing the disk icons to get a clearer feel for the issue?
  • Can you boot back to your previous 10.12.6. from CBM screen?
Will take a screen shot tonight.
And yes, my system still boots from 10.12.6 when I choose my old install on the Clover screen.
By default it does want to boot from the Install portion of my system drive and fails - quite annoying...
Thanks!
 
Joined
Nov 3, 2010
Messages
63
Motherboard
MSI B250M-Pro VD
CPU
Intel Core i3-7100
Graphics
Sapphire Pulse Rx 560
Mac
  1. iMac
Classic Mac
  1. Power Mac
Mobile Phone
  1. iOS
I'm trying to upgrade to 10.13.2 with the same KP... very similar error messages (but I'm on a normal SSD, not M.2)
I'm also on a fully working 10.12.6 and I don't know why I cannot upgrade to HS. I follow this thread to see if someone could help you (and me too)
 
Joined
Jul 25, 2012
Messages
6,714
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
I'm trying to upgrade to 10.13.2 with the same KP... very similar error messages.
I'm also on a fully working 10.12.6 and I don't know why I cannot upgrade to HS. I follow this thread to see if someone could help you (and me too)
 
Last edited:
Joined
Jul 25, 2012
Messages
6,714
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Will take a screen shot tonight.
And yes, my system still boots from 10.12.6 when I choose my old install on the Clover screen.
By default it does want to boot from the Install portion of my system drive and fails - quite annoying...
Thanks!
  • Now it is clearer what you are facing.
  • Boot into your 10.12.6
  • Once you reach Desktop, First go to Finder >Preferences and click to change [√] Hard disks [√] External disks to display attached disks icons on the Right side of Desktop screen
  • Next unhide, hidden Folders and Files in your System disk by either of the following to locate macOS Install Data Folder or it can be a file using the following steps:
  1. Install, launch and click on [Show] menu of "ShowAllFiles" from Download Now 77.1 KB .zip [See image] OR
  2. Launch Terminal and type and execute the command and other steps (faster is #1)
  • defaults write com.apple.finder AppleShowAllFiles YES.[See Terminal cmd image]
  • Press return.
  • Hold the 'Option/ALT' key, then RIGHT- click on the "Finder" icon in the dock and click "Relaunch" . [See image]
  1. Once you have performed unhide files , find your System disk icon and click open to locate the Folder or file named macOS Install Data
  2. Right click and Send To Trash macOS Install Data
  3. Restart the computer , you should not see the macOS Install File stub in CBM
  4. Boot back to Sierra 10.12.6 and re-download 10.13.2.
  5. At this stage, before doing anything post back for further steps.
 

Attachments

  • 1.ShowAllFiles.png
    1.ShowAllFiles.png
    10.3 KB · Views: 69
  • 2.Terminal Cmd .png
    2.Terminal Cmd .png
    4.1 KB · Views: 74
  • 3.Finder Relaunch.png
    3.Finder Relaunch.png
    85.4 KB · Views: 59
Joined
Jul 25, 2012
Messages
6,714
Motherboard
Gigabyte GA-Z77X-UP5 TH
CPU
i7-3770K
Graphics
HD 4000+GT 710
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Joined
Jan 10, 2012
Messages
126
Motherboard
AsRock Z97E-ITX/AC
CPU
i5-5675C
Graphics
HD 6200
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
  • Now it is clearer what you are facing.
  1. "ShowAllFiles"
  2. Right click and Send To Trash macOS Install Data
  1. Restart the computer , you should not see the macOS Install File stub in CBM
  2. Boot back to Sierra 10.12.6 and re-download 10.13.2.
  3. At this stage, before doing anything post back for further steps.
Thanks...

I have Show all files on by default, removed /macOS Install Data
I do still have the 10.13.2. Install macOS High Sierra App in my App Folder - should I reload it anyways?

If you do not mind, you can try to explain what you are aiming at. I have been hackintoshing for a number of years now - and used to be a unix system administrator yes ago. I do keep forgetting things - and really do not know what to do now ;o)

IMG_8646.jpg
I assume the highlighted boot choice only shows up when I have that drawer in /?

Will reboot and see whether it is gone...

Question once I started the Install macOS app and it fails when rebooting - when booting from 10.12.6 again, rerunning the command - does it overwrite the /macOS Install Data folder? When booting the Boot macOS Install from my disk it did make a difference what kexts I had loaded...

Thanks again!
Rudolf
 
Status
Not open for further replies.
Top