Contribute
Register

[solved] Help needed to Patch SSDT

Status
Not open for further replies.
Joined
Nov 20, 2018
Messages
46
Motherboard
MSI B360M Bazooka
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
Hi

Need help to patch the SSDT. i followed the instructions in https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/ and manage to figure out the ports i need

HS03/SS03
HS04/SS04
HS05/SS05
HS06/SS06
HS07
HS08
but unable to find out which ports is for the internal USB 2 (2 of them) and i guess they are HS09 and HS10

so i configured the SSDT-UIAC.dsl as attached and successfully compile it to SSDT-UIAC.aml
copied it to EFI/Clover/ACPI/patched and rebooted.

but when i check ioReg. it is still the same as previously (HS01-HS14 and USR1).

1. how do i "activate" the SSDT when booting? i tried SortedOrder, PluginType = 1 but both methods did not work.
2. i have the BCM943602CS card connected to my internal USB 2 connector, how do i check if it is working? it was working fine previously until i shutdown my system. when i start my PC, bluetooth is gone. i checked the ioReg but nothing on it.

thank you so much
 

Attachments

  • SSDT-UIAC.dsl
    2.8 KB · Views: 78

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hi

Need help to patch the SSDT. i followed the instructions in https://www.tonymacx86.com/threads/guide-creating-a-custom-ssdt-for-usbinjectall-kext.211311/ and manage to figure out the ports i need

HS03/SS03
HS04/SS04
HS05/SS05
HS06/SS06
HS07
HS08
but unable to find out which ports is for the internal USB 2 (2 of them) and i guess they are HS09 and HS10

so i configured the SSDT-UIAC.dsl as attached and successfully compile it to SSDT-UIAC.aml
copied it to EFI/Clover/ACPI/patched and rebooted.

but when i check ioReg. it is still the same as previously (HS01-HS14 and USR1).

1. how do i "activate" the SSDT when booting? i tried SortedOrder, PluginType = 1 but both methods did not work.
2. i have the BCM943602CS card connected to my internal USB 2 connector, how do i check if it is working? it was working fine previously until i shutdown my system. when i start my PC, bluetooth is gone. i checked the ioReg but nothing on it.

thank you so much
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Joined
Nov 20, 2018
Messages
46
Motherboard
MSI B360M Bazooka
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
i tried to generate the PR by using gen_debug but it keeps giving me "Unable to connect to the internet. Aborted."
then i tried the offline method but got the error "This version of IORegistryExplorer is not recommended."

which version does it need? i downloaded the latest IOReg
 

Attachments

  • Screenshot 2018-12-15 at 03.30.08.png
    Screenshot 2018-12-15 at 03.30.08.png
    49.7 KB · Views: 182
  • Screenshot 2018-12-15 at 03.31.39.png
    Screenshot 2018-12-15 at 03.31.39.png
    28.5 KB · Views: 145

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
i tried to generate the PR by using gen_debug but it keeps giving me "Unable to connect to the internet. Aborted."
then i tried the offline method but got the error "This version of IORegistryExplorer is not recommended."

which version does it need? i downloaded the latest IOReg

Instructions for downloading IORegistryExplorer v2.1 are in the off-line instructions.
But you need to also:
Code:
touch /Applications/IORegistryExplorer.app/isVerified
 
Joined
Nov 20, 2018
Messages
46
Motherboard
MSI B360M Bazooka
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
touch /Applications/IORegistryExplorer.app/isVerified

thanks RehabMan. i manage to gen the report after using the above code. here it is ..
 

Attachments

  • debug_32409.zip
    1.6 MB · Views: 137
Joined
Nov 20, 2018
Messages
46
Motherboard
MSI B360M Bazooka
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
today when I shutdown the system and power on again, the Bluetooth came back on HS10.

but after I shutdown, it's gone again . the system don't seem to be able to detect it consistently.
 
Last edited:

RehabMan

Moderator
Joined
May 2, 2012
Messages
183,827
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
thanks RehabMan. i manage to gen the report after using the above code. here it is ..
today when I shutdown the system and power on again, the Bluetooth came back on HS10.

but after I shutdown, it's gone again . the system don't seem to be able to detect it consistently.
No ioreg in the attached debug zip. Please check your files carefully before upload.
 
Joined
Nov 20, 2018
Messages
46
Motherboard
MSI B360M Bazooka
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
my apologies. wasnt sure whats suppose to be in the debug zip. think the new debug zip should have the ioreg.

thanks again
 

Attachments

  • debug_28763.zip
    2 MB · Views: 150
Joined
Nov 20, 2018
Messages
46
Motherboard
MSI B360M Bazooka
CPU
i5-8400
Graphics
RX 580
Mac
  1. MacBook Pro
Mobile Phone
  1. Android
  2. iOS
uploaded another report with sys dump
 

Attachments

  • debug_22094_sysdump.zip
    2.2 MB · Views: 125
Status
Not open for further replies.
Top