Contribute
Register

[solved] [HD5500] Broadwell display issue

Joined
Apr 26, 2014
Messages
17
CPU
i5-5200U Broadwell
Graphics
Intel HD Graphics 5500 + AMD Radeon M265
Mobile Phone
  1. iOS
Hello there again!

I am trying to run Sierra 10.12.5 on my Lenovo e550 Broadwell notebook with i5-5200U CPU. I have a problem with Intel HD 5500 Graphic. I managed to get away the kernel panic with some kexts:
  1. AppleIntelBDWGraphics.kext
  2. AppleIntelBDWGraphicsFramebuffer.kext
  3. AppleIntelBDWGraphicsGLDriver.bundle
  4. AppleIntelBDWGraphicsMTLDriver.bundle
  5. AppleIntelBDWGraphicsVADriver.bundle
  6. AppleIntelBDWGraphicsVAME.bundle
and with plist config:
  1. ig-platform: 0x16260006
  2. Inject Intel: true
  3. enable DVMT path (Name : AppleIntelBDWGraphicsFramebuffer Find : 8945C839C7764F Replace : 8945C839C7EB4F)
Ok, my laptop is booting to Sierra but the screen is crashed like on attached picture. Strange, because when I will sleep the laptop and turn in on again, the screen is good but is still lagged. About this Mac is showing Intel HD Graphics 5500 1536 MB but there is no hardware acceleration... Could someone help me to fix this issue?
 

Attachments

  • IMG_0376.JPG
    IMG_0376.JPG
    1.9 MB · Views: 1,095

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hello there again!

I am trying to run Sierra 10.12.5 on my Lenovo e550 Broadwell notebook with i5-5200U CPU. I have a problem with Intel HD 5500 Graphic. I managed to get away the kernel panic with some kexts:
  1. AppleIntelBDWGraphics.kext
  2. AppleIntelBDWGraphicsFramebuffer.kext
  3. AppleIntelBDWGraphicsGLDriver.bundle
  4. AppleIntelBDWGraphicsMTLDriver.bundle
  5. AppleIntelBDWGraphicsVADriver.bundle
  6. AppleIntelBDWGraphicsVAME.bundle
and with plist config:
  1. ig-platform: 0x16260006
  2. Inject Intel: true
  3. enable DVMT path (Name : AppleIntelBDWGraphicsFramebuffer Find : 8945C839C7764F Replace : 8945C839C7EB4F)
Ok, my laptop is booting to Sierra but the screen is crashed like on attached picture. Strange, because when I will sleep the laptop and turn in on again, the screen is good but is still lagged. About this Mac is showing Intel HD Graphics 5500 1536 MB but there is no hardware acceleration... Could someone help me to fix this issue?

Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Follow the instructions carefully with regard to framebuffer patching for 32mb DVMT-prealloc.
 
Joined
Apr 26, 2014
Messages
17
CPU
i5-5200U Broadwell
Graphics
Intel HD Graphics 5500 + AMD Radeon M265
Mobile Phone
  1. iOS
Follow the Clover guide linked from the FAQ.
http://www.tonymacx86.com/el-capita...faq-read-first-laptop-frequent-questions.html

Follow the instructions carefully with regard to framebuffer patching for 32mb DVMT-prealloc.

Strange, because your config.plist file contains above patches. (0x16260006, 32MB BIOS, 19MB framebuffer, 9MB cursor bytes (credit RehabMan) patch is enabled by default) (im using these plist https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD5300_5500_6000.plist)

I don't know, what can I do more...
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Strange, because your config.plist file contains above patches. (0x16260006, 32MB BIOS, 19MB framebuffer, 9MB cursor bytes (credit RehabMan) patch is enabled by default) (im using these plist https://github.com/RehabMan/OS-X-Clover-Laptop-Config/blob/master/config_HD5300_5500_6000.plist)

I don't know, what can I do more...

As per guide, you must boot using an invalid ig-platform-id during initial install steps.
Only after you install and rebuild cache can you expect to use that patch.
It is clearly documented in the guide. You need to read it carefully.
 
Joined
Apr 26, 2014
Messages
17
CPU
i5-5200U Broadwell
Graphics
Intel HD Graphics 5500 + AMD Radeon M265
Mobile Phone
  1. iOS
As per guide, you must boot using an invalid ig-platform-id during initial install steps.
Only after you install and rebuild cache can you expect to use that patch.
It is clearly documented in the guide. You need to read it carefully.

Damn, probably I am stupid ;( Doing as in guide and nothing change...

0. I've done a clean install of Sierra 10.12.5, booting installer with invalid ig-platform-id

1. After post install Clover, in config.plist I have enabled 0x16260006, 32MB BIOS, 19MB framebuffer, 9MB cursor bytes (credit RehabMan) path
2. I am booting into Sierra using invalid ig-platform-id = 0x12345678
3. About this Mac is showing Intel HD Graphics 5500 7 MB
4. Now I am refreshing kext cache using sudo touch /System/Library/Extensions && sudo kextcache -u /
5. Rebooting Sierra with ig-platform-id = 0x16260006 gives me the same cash on my screen...


What am I doing wrong?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
186,689
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Damn, probably I am stupid ;( Doing as in guide and nothing change...

0. I've done a clean install of Sierra 10.12.5, booting installer with invalid ig-platform-id

1. After post install Clover, in config.plist I have enabled 0x16260006, 32MB BIOS, 19MB framebuffer, 9MB cursor bytes (credit RehabMan) path
2. I am booting into Sierra using invalid ig-platform-id = 0x12345678
3. About this Mac is showing Intel HD Graphics 5500 7 MB
4. Now I am refreshing kext cache using sudo touch /System/Library/Extensions && sudo kextcache -u /
5. Rebooting Sierra with ig-platform-id = 0x16260006 gives me the same cash on my screen...


What am I doing wrong?

Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Sep 9, 2011
Messages
935
Motherboard
HP 250 G5 (81EF) Clover UEFI
CPU
i3 5005u
Graphics
HD 5500 (1366x768)
Mobile Phone
  1. Android
Hi. It's a known issue that garbled screen on Intel graphics occurs when legacy boot mode is disabled in the BIOS. Also, by saying "but there is no hardware acceleration", you mean there's no QE/CI working?
 
Joined
Apr 26, 2014
Messages
17
CPU
i5-5200U Broadwell
Graphics
Intel HD Graphics 5500 + AMD Radeon M265
Mobile Phone
  1. iOS
you mean there's no QE/CI working?
Yeap, but now it is :) Conclusion - always read the full guide! I've turned CMS on and voilà...

But the Intel HD 5500 works without backlight regulation. Will it be hard to repair that? I see that you have BDW with HD5500 too.
 
Joined
Sep 9, 2011
Messages
935
Motherboard
HP 250 G5 (81EF) Clover UEFI
CPU
i3 5005u
Graphics
HD 5500 (1366x768)
Mobile Phone
  1. Android
You need to patch your DSDT with the PNLF haswell/broadwell patch for backlight control but this is broken since 10.12.4. There's a new guide for that.
 
Top