Contribute
Register

[Solved] GTX 1070 not detected!

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
22,163
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Can someone please help me?
You have already been given all of the required advice to enable you to boot successfully with your GTX 1070.
Either you have not followed the advice or there is something wrong with your installation, in which case you should try a fresh install.

You have not replied to @VoiletDragon 's suggestion in Post #19.

Do I really need to create another thread?
If you do it will be deleted :
The Rules said:
Do not cross post or create identical threads in multiple forums. Duplicate threads will be deleted
Suggest you zip your entire /EFI folder and attach it.
 
Last edited:
Joined
Sep 4, 2014
Messages
44
Motherboard
MSI Z270 Krait
CPU
Intel i7-7700K
Graphics
Nvidia GTX 1070 EVGA SC
Mac
MacBook Air
Mobile Phone
iOS
You have already been given all of the required advice to enable you to boot successfully with your GTX 1070.
Either you have not followed the advice or there is something wrong with your installation, in which case you should try a fresh install.

You have not replied to @VoiletDragon 's suggestion in Post #19.


If you do it will be deleted :


Suggest you zip your entire /EFI folder and attach it.
Yeah, I know the rules, I will not make another thread. Anyway, thanks for noticing me. I will try to follow that guide, even though I can't understand what this is for. I attach my /EFI folder as asked.
 

Attachments

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
22,163
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
I attach my /EFI folder as asked.
I can't see anything there that would cause you problems.
Maybe disable the rename of GFX0 to IGPU as per @VoiletDragon 's Post #19.
Otherwise all that I can suggest is a fresh install.
 
Joined
Sep 4, 2014
Messages
44
Motherboard
MSI Z270 Krait
CPU
Intel i7-7700K
Graphics
Nvidia GTX 1070 EVGA SC
Mac
MacBook Air
Mobile Phone
iOS
I can't see anything there that would cause you problems.
Maybe disable the rename of GFX0 to IGPU as per @VoiletDragon 's Post #19.
Otherwise all that I can suggest is a fresh install.
I try fresh install. Can you give me step by step what to do to make this not happen again?
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
22,163
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Of course with step by step I don't mean the installation guide :lol:
I can't see why it is happening so I don't know what you did that would cause it.
You can use the same config.plist.

Install with the FakeCPUID and boot with nv_disable=1 until you have installed the OS and the web drivers.
 
Joined
Jun 9, 2013
Messages
10,957
Motherboard
GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Yeah, I know the rules, I will not make another thread. Anyway, thanks for noticing me. I will try to follow that guide, even though I can't understand what this is for. I attach my /EFI folder as asked.
Rename GFX0 to IGPU is incorrect. Graphics thats coming under PEGP should be coming under GFX0. Remove Rename GFX0 to IGPU. Add Change PEGP to GFX0.

Code:
Voilets-Speedy-Hack:~ JackBamford$ echo -n PEGP|xxd
00000000: 5045 4750                                PEGP
Voilets-Speedy-Hack:~ JackBamford$ echo -n GFX0|xxd
00000000: 4746 5830                                GFX0
Voilets-Speedy-Hack:~ JackBamford$
Create SSDT with the following edits.

Code:
DefinitionBlock ("", "SSDT", 2, "hack", "GFX0_HDAU", 0)
{
    External(_SB_.PCI0.PEG0, DeviceObj)
    External(_SB_.PCI0.PEG0.GFX0, DeviceObj)
    Scope(_SB.PCI0.PEG0)
    {
        Scope(GFX0)
        {
            Method (_DSM, 4)
            {
                If (!Arg2) { Return (Buffer() { 0x03 }) }
                Return (Package()
                {
                    "@0,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@1,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@2,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@3,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@4,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@5,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "hda-gfx", Buffer () { "onboard-2" },
                })
            }
        }
        Device(HDAU)
        {
            Name(_ADR, 1)
            Method(_DSM, 4)
            {
                If (!Arg2) { Return (Buffer() { 0x03 }) }
                Return (Package()
                {
                    "hda-gfx",Buffer() { "onboard-2" },
                })
            }
        }
    }
}
//EOF
 
Joined
Sep 4, 2014
Messages
44
Motherboard
MSI Z270 Krait
CPU
Intel i7-7700K
Graphics
Nvidia GTX 1070 EVGA SC
Mac
MacBook Air
Mobile Phone
iOS
Rename GFX0 to IGPU is incorrect. Graphics thats coming under PEGP should be coming under GFX0. Remove Rename GFX0 to IGPU. Add Change PEGP to GFX0.

Code:
Voilets-Speedy-Hack:~ JackBamford$ echo -n PEGP|xxd
00000000: 5045 4750                                PEGP
Voilets-Speedy-Hack:~ JackBamford$ echo -n GFX0|xxd
00000000: 4746 5830                                GFX0
Voilets-Speedy-Hack:~ JackBamford$
Create SSDT with the following edits.

Code:
DefinitionBlock ("", "SSDT", 2, "hack", "GFX0_HDAU", 0)
{
    External(_SB_.PCI0.PEG0, DeviceObj)
    External(_SB_.PCI0.PEG0.GFX0, DeviceObj)
    Scope(_SB.PCI0.PEG0)
    {
        Scope(GFX0)
        {
            Method (_DSM, 4)
            {
                If (!Arg2) { Return (Buffer() { 0x03 }) }
                Return (Package()
                {
                    "@0,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@1,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@2,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@3,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@4,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "@5,connector-type", Buffer() { 0x00, 0x08, 0x00, 0x00 },
                    "hda-gfx", Buffer () { "onboard-2" },
                })
            }
        }
        Device(HDAU)
        {
            Name(_ADR, 1)
            Method(_DSM, 4)
            {
                If (!Arg2) { Return (Buffer() { 0x03 }) }
                Return (Package()
                {
                    "hda-gfx",Buffer() { "onboard-2" },
                })
            }
        }
    }
}
//EOF
Thanks for the reply, but I haven't quite understood what I need to do in order to rename the GPU and create an SSDT, can you please explain me how to do this two things?
 
Joined
Jun 9, 2013
Messages
10,957
Motherboard
GA-H77N-WIFI
CPU
i7-3770
Graphics
HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Top