Contribute
Register

[Solved] Gigabyte Brix i3 7100u HD620 graphics install

Joined
Apr 26, 2017
Messages
37
Motherboard
GIGABYTE GA-Z170N-Gaming 5
CPU
i7 6700K
Graphics
GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
I have one of the new Gigabyte Brix with a Kaby Lake i3 7100u. It has Intel 620 Graphics onboard. I'm having trouble getting the graphics working correctly. I can boot with an invalid FakeID (0x12345678), but that's about it.
https://www.gigabyte.com/Mini-PcBarebone/GB-BKi3HA-7100-rev-10#sp

The bios has an option for 64mb DVMT prealloc, which I have selected (32mb won't boot at all).

I've got Sierra 10.12.6 installed. Native Kaby Lake support, so no FakeCPUID.

Does anyone know what the correct process is for getting the onboard HD620 graphics to work?

I currently have Lilu.kext and IntelGraphicsDVMTFixup.kext installed and I'm injecting Intel graphics with a FakeID of 0x19168086. No other kexts or kernel/kext patches are applied regarding graphics.

I've tried a bunch of stuff but I can't get the graphics to work. I either get an error about DRMStatus and iTunes, which just hangs at boot or I get an error about graphics firmware which hangs at boot also.

Any help is greatly appreciated!

Cheers
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
I have one of the new Gigabyte Brix with a Kaby Lake i3 7100u. It has Intel 620 Graphics onboard. I'm having trouble getting the graphics working correctly. I can boot with an invalid FakeID (0x12345678), but that's about it.
https://www.gigabyte.com/Mini-PcBarebone/GB-BKi3HA-7100-rev-10#sp

The bios has an option for 64mb DVMT prealloc, which I have selected (32mb won't boot at all).

I've got Sierra 10.12.6 installed. Native Kaby Lake support, so no FakeCPUID.

Does anyone know what the correct process is for getting the onboard HD620 graphics to work?

I currently have Lilu.kext and IntelGraphicsDVMTFixup.kext installed and I'm injecting Intel graphics with a FakeID of 0x19168086. No other kexts or kernel/kext patches are applied regarding graphics.

I've tried a bunch of stuff but I can't get the graphics to work. I either get an error about DRMStatus and iTunes, which just hangs at boot or I get an error about graphics firmware which hangs at boot also.

Any help is greatly appreciated!

Cheers

No need for IntelGraphicsDVMTFixup.kext if you can set DVMT-prealloc to 64mb.
Remove.
But you will need IntelGraphicsFixup.kext. IntelGraphicsFixup not the same as IntelGraphicsDVMTFixup.kext.
Use config.plist/Devices/FakeID/IntelGFX=native-id (eg. 0x59128086).
config.plist/Graphics/Inject/Intel=true.
config.plist/Graphics/ig-platform-id=0x59120000
 
Joined
Apr 26, 2017
Messages
37
Motherboard
GIGABYTE GA-Z170N-Gaming 5
CPU
i7 6700K
Graphics
GTX 1060
Mac
  1. MacBook Pro
Mobile Phone
  1. iOS
No need for IntelGraphicsDVMTFixup.kext if you can set DVMT-prealloc to 64mb.
Remove.
But you will need IntelGraphicsFixup.kext. IntelGraphicsFixup not the same as IntelGraphicsDVMTFixup.kext.
Use config.plist/Devices/FakeID/IntelGFX=native-id (eg. 0x59128086).
config.plist/Graphics/Inject/Intel=true.
config.plist/Graphics/ig-platform-id=0x59120000

Thanks! That did the trick. I now seem to have full resolution (4k) and graphics acceleration on the HDMI port.

The minidisplay port is a different story. If I use that instead of the HDMI, it doesn't work right (default graphics). I tried ig-platform-id=0x19160000 and FakeID=0x19168086 and that gave me full resolution on the MD port but no graphics acceleration. It'd be great to get them both working, but I guess not really necessary.

Thanks again!
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,161
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Thanks! That did the trick. I now seem to have full resolution (4k) and graphics acceleration on the HDMI port.

The minidisplay port is a different story. If I use that instead of the HDMI, it doesn't work right (default graphics). I tried ig-platform-id=0x19160000 and FakeID=0x19168086 and that gave me full resolution on the MD port but no graphics acceleration. It'd be great to get them both working, but I guess not really necessary.

Thanks again!

I would need to see full "Problem Reporting" files.
Read FAQ, "Problem Reporting"
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Top