Contribute
Register

[Solved] FixShutdown not working after update to 10.13.2

Status
Not open for further replies.
Joined
Jun 15, 2017
Messages
31
Motherboard
Gigabyte Z270X UD5
CPU
I7 7700K
Graphics
Zotac GTX 970
Mac
  1. iMac
Does anyone has shutdown problem after the update? It worked before but after the updates, it's not. Should I update the clover bootloader?

Does anyone have some idea?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,449
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,449
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
HD 4600 / RX 580
At some point the actual wording got changed from fixshutdown_004 or something to fixshutdown and not all versions of clover recognise both ways of writing it.
Those new "friendly names" were introduced in Clover r4282
Clover r4282 and newer can handle both old ("FixShutdown_0004") & new ("FixShutdown") key.
 
Joined
Jun 15, 2017
Messages
31
Motherboard
Gigabyte Z270X UD5
CPU
I7 7700K
Graphics
Zotac GTX 970
Mac
  1. iMac
Those new "friendly names" were introduced in Clover r4282
Clover r4282 and newer can handle both old ("FixShutdown_0004") & new ("FixShutdown") key.
Thanks! It works for me after I upgrade the Clover bootloader to the newest version r4334.
 
Joined
Jul 5, 2016
Messages
58
Motherboard
ASUS Z97 A+
CPU
i7-4790
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Hello All !!! ... I updated to 10.13.2 succesfully and everything working fine ... except ... shutdown !!!
I have updated all required kexts and the computer boots and works fine but when I try to shutdown
... the computer reboots again !!! .. Any ideas ???
Thank you so much in advance.
P.S. I have tried the ticking the "fixShutdown" key with no good results !!!
 
Joined
Jun 15, 2017
Messages
31
Motherboard
Gigabyte Z270X UD5
CPU
I7 7700K
Graphics
Zotac GTX 970
Mac
  1. iMac
Hello All !!! ... I updated to 10.13.2 succesfully and everything working fine ... except ... shutdown !!!
I have updated all required kexts and the computer boots and works fine but when I try to shutdown
... the computer reboots again !!! .. Any ideas ???
Thank you so much in advance.
P.S. I have tried the ticking the "fixShutdown" key with no good results !!!
Did u try to update Clover bootloader?
 
Joined
Jul 5, 2016
Messages
58
Motherboard
ASUS Z97 A+
CPU
i7-4790
Graphics
RX 580
Mac
  1. iMac
Classic Mac
  1. iMac
Mobile Phone
  1. iOS
Did u try to update Clover bootloader?
Hello ztlevi !!!
Yes I have !!! ... If I am not wrong it must be the Clover v2.4k r4334 version ... That is the one I installed !!!
 
Joined
Feb 16, 2017
Messages
5
CPU
E6-2670
Graphics
GTX 750 Ti
If your still suffering with reboot on shutdown its probably related to USB ports. Just remove GenericUSBXHCI.kext and use USBInjectAll.kext only. Now my USB3.0 shows up and it shuts down.
 
Status
Not open for further replies.
Top