Contribute
Register

[SOLVED] Firewire Kexts issues

Joined
Mar 29, 2017
Messages
34
Motherboard
MSI H170I Pro AC
CPU
Intel i5 6400
Graphics
N/A
Mac
MacBook Air, Mac mini
Mobile Phone
Android, iOS
Hello to this great community...i've a "problem" after installing some kexts. But i want to start explaining what has happened step by step.
I set up a new build with an Asus X99-E-Ws + 5960x+64gb ddr4 and a titanx card. The main purpose of this setup is as audio workstation.
I own a firewire startech card natively supported by OSX (infact it works OTB with Mavericks in my previous build!).
I installed Yosemite 10.10.5.....everything work fine with clover bootloader etc. But when i installed any drivers for my firewire audio card or keyboards, the peripherals weren't recognized by the system. So i checked in system info and at firewire device the windows was blank. So my fw card was not recognized.
I checked in Extensions dirs and i didn't find any FW*.kext so i took those kext from my Yosemite USB installer :
AppleFWAudio.kext and other 4 IOFW*.kext. They had hidden attributes ( i used Showallfiles to see them in the correct dir!) and i installed them with kextwizard.
I restarted and finally my fw card was recognized and peripherals work perfectly.
But at OSX boot i've a message showing "Failed to Initialize" so maybe one of the 5 kext give me that msg.
How i can remove hidden kext? I checked extensions dir and the 5 FW kext i installed have still hidden attributes and if i try to delete them manually at restart they are still in the dir. So i want to remove all of them and see which of them gives me that "failed to initialize" error message.
Any help is appreciated...
Hi, did you have to modify any of the attributes in the kexts? if so which ones?
I have a 100% compatible FW card but my system does not recognize it, any help will be much appreciate it.
 
Joined
Mar 29, 2017
Messages
34
Motherboard
MSI H170I Pro AC
CPU
Intel i5 6400
Graphics
N/A
Mac
MacBook Air, Mac mini
Mobile Phone
Android, iOS
Firewire Kexts issues

I solved this problem in the simplest way...i copied those *FW*.kext from my Macbookpro with Mavericks installed, and with kexbeast i installed them in my Yosemite Hackintosh, and now everything work perfectly!
Hi, when you said that you copied the KEXTS into your new build, where exactly did you copy them?
 
Joined
Dec 31, 2012
Messages
524
Motherboard
Gigabyte Designare Ex X299
CPU
i9-9980XE
Graphics
GTX 1080 Ti
Mac
iMac, Mac mini
Mobile Phone
iOS
Hi, when you said that you copied the KEXTS into your new build, where exactly did you copy them?
That post was referred to Yosemite installation....i copied them into S/L/E dir...but from El Capitan on you don't need them
 
Joined
Jul 20, 2014
Messages
193
Motherboard
X299 UD4 PRO
CPU
i9-7900
Graphics
GTX 1080 Ti
Joined
Jul 20, 2014
Messages
193
Motherboard
X299 UD4 PRO
CPU
i9-7900
Graphics
GTX 1080 Ti
Hello
I buy this item, but my Mojave seems not to recognise it.
Someone has succeed or can confirm it doesn't work ?
Thanks for Any Help
I bought this item :
It works flawlessly with Mojave
capture 2019-03-29 à 06.32.56.pngcapture 2019-03-29 à 06.32.43.png
 
Top