Contribute
Register

[Solved] Fenvi WIFI/BT card, BT suddenly unavailable

Joined
Jul 7, 2018
Messages
40
Motherboard
Z370 Aorus Gaming 7
CPU
i7-8700K
Graphics
RX 580
Mac
iMac, MacBook Air, MacBook Pro, Mac Pro
Mobile Phone
iOS
I don't think I've changed anything since updating to 10.14.2 but my Bluetooth has spontaneously stopped working (Bluetooth: Not Available). I'm using the recommended Fenvi 919 card, wifi seems fine. I updated Lilu and AirportBrcmFixup just in case, but that didn't seem to help.
 
Joined
Jun 15, 2015
Messages
180
Motherboard
P5WE0
CPU
i5-2450M
Graphics
HD 3000
Mac
MacBook Air, Mac mini
Mobile Phone
Android, iOS
Is it working in any other OS you might have on the machine?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
2,538
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I don't think I've changed anything since updating to 10.14.2 but my Bluetooth has spontaneously stopped working (Bluetooth: Not Available). I'm using the recommended Fenvi 919 card, wifi seems fine. I updated Lilu and AirportBrcmFixup just in case, but that didn't seem to help.
This sounds like a USB port limit problem. If you don't have a custom USB SSDT, then you'll have to update your USB port limit patch for new versions of MacOS.

BlueTooth from the Fenvi card is connected to a USB port on your motherboard. If this port is not available, BlueTooth won't work.

You can run IORegistryExplorer and find "XHC" in the tree on the left side to see a list of all available USB ports. If a device is attached to a USB port, some information about the device will also be shown.
 
Joined
Sep 29, 2018
Messages
23
Motherboard
Gigabyte B360 AORUS Gaming 3 WIFI
CPU
i5-8600K
Graphics
RX 580
Mac
iMac
Classic Mac
Plus
Mobile Phone
iOS
I have the same problem with the Fenvi T919 card - WIFI works but not Bluetooth. I ran IORegistryExplorer (see attached), but don't know what to look for. My BT cable is plugged into the front panel USB Header. Can you tell if that is available?
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
2,538
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
I have the same problem with the Fenvi T919 card - WIFI works but not Bluetooth. I ran IORegistryExplorer (see attached), but don't know what to look for. My BT cable is plugged into the front panel USB Header. Can you tell if that is available?
Your Bluetooth controller is right there at HS07.
IORgistryLower25.png
 
Joined
Sep 29, 2018
Messages
23
Motherboard
Gigabyte B360 AORUS Gaming 3 WIFI
CPU
i5-8600K
Graphics
RX 580
Mac
iMac
Classic Mac
Plus
Mobile Phone
iOS
Great. Thanks. My system says "Bluetooth: Not Available." Any clues?
 

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
2,538
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
Great. Thanks. My system says "Bluetooth: Not Available." Any clues?
Is this coming from the About this Mac --> System Profile --> Bluetooth page?

If so, can you grab a screenshot of the USB page (may need to make window taller to grab as much of the USB listing as possible)?
 
Joined
Sep 29, 2018
Messages
23
Motherboard
Gigabyte B360 AORUS Gaming 3 WIFI
CPU
i5-8600K
Graphics
RX 580
Mac
iMac
Classic Mac
Plus
Mobile Phone
iOS
Is this coming from the About this Mac --> System Profile --> Bluetooth page?

If so, can you grab a screenshot of the USB page (may need to make window taller to grab as much of the USB listing as possible)?
This was from the IORegistryExplorer. Here is the USB page from About this Mac. The Bluetooth page just says "no information found."
 

Attachments

CaseySJ

Moderator
Joined
Nov 11, 2018
Messages
2,538
Motherboard
Gigabyte Designare Z390
CPU
i7-9700K
Graphics
RX 580
Mac
MacBook Air, Mac Pro
Classic Mac
Quadra
Mobile Phone
iOS
This was from the IORegistryExplorer. Here is the USB page from About this Mac. The Bluetooth page just says "no information found."
Your Broadcom Bluetooth seems to correctly configured and recognized by MacOS.

I wonder if the USB port limit patch is causing this problem -- because your system exceeds the 15 port limit of MacOS.

A quick thing to try:
  • Install USBInjectAll and XHCI-Unsupported.kext if not already done (files are attached and can be copied to CLOVER/kexts/Other)
  • Edit your config.plist with Clover Configurator, go to the Boot section, and add this to your boot argument:
Code:
uia_exclude=HS01,HS03,HS04,HS05,HS06,HS10,HS11,HS14,SS01
This will disable these ports temporarily. Don't worry -- your keyboard and mouse are on HS09 and Bluetooth is on HS07 so they won't be affected. This will reduce the total port count which might solve the Bluetooth problem.

Again -- no guarantees, but it's worth a try.
 

Attachments

Top