Contribute
Register

[Solved] Ethernet not working :/ Z170-HD3

Joined
Nov 27, 2016
Messages
18
Motherboard
Gigabyte GA-z170-hd3
CPU
I5-6600k
Graphics
1050 TI
Mac
iMac, MacBook Pro
Classic Mac
iMac
Mobile Phone
iOS
Hey everyone! I just had my Hackintosh re-installed because I dun-goofed, I got everything working except for the Ethernet, Here are my system specs
Gigabyte Z170-HD3
Intel core i5-6600k
16 GB G.Skill Ripjaws DDR4 2666Mhz
Gigabyte 1050 TI G1 Gaming 4GB
Running macOS 10.12.6
So the main problem is that I've made multiple attempts using Multibeast, installing different kexts, the one that should be working is the RealtekRTL8111.kext but for some reason it does absolutely nothing for me. Anybody have any ideas? Thanks I appreciate all the help!
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
20,299
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Remove any previous failed attempts from /Library/Extensions and /System/Library/Extensions.

Open Finder and browse to /Library/Preferences/SystemConfiguration/ then delete these two files :
  • NetworkInterfaces.plist
  • preferences.plist

Download the kext and put it on your desktop.
Download and run KextBeast selecting /Library/Extensions as the location.

In Terminal :
Code:
sudo kextcache -i /
Press return, type your password (it will not show on screen), press return again and when the command has completed restart.
 
Joined
Nov 27, 2016
Messages
18
Motherboard
Gigabyte GA-z170-hd3
CPU
I5-6600k
Graphics
1050 TI
Mac
iMac, MacBook Pro
Classic Mac
iMac
Mobile Phone
iOS
Works perfectly thanks!
 
Joined
Mar 23, 2016
Messages
1
Motherboard
Gigabyte H55M-D2H
CPU
Intel Core i5-650
Graphics
Gigabyte Geforce GT 240
Mac
iMac, Mac Pro
Classic Mac
iMac
Mobile Phone
Android, iOS
I tried this and my ethernet is still not working. Can someone please help?
 
Joined
Nov 27, 2016
Messages
18
Motherboard
Gigabyte GA-z170-hd3
CPU
I5-6600k
Graphics
1050 TI
Mac
iMac, MacBook Pro
Classic Mac
iMac
Mobile Phone
iOS
What are your specs?
 

BreBo

Moderator
Joined
Oct 17, 2011
Messages
9,681
Motherboard
Gigabyte GA-Z87X-OC
CPU
i7-4770K
Graphics
GTX 970
@Armando.Pedron, please update your profile (personal details) with your Motherboard, CPU and iGPU or Graphics Card.
If you have a prebuilt computer enter make and model instead of motherboard (Mobo).
The Rules said:
Profiles need to contain at least your primary system to assist others with helping you.
 
Joined
Dec 19, 2011
Messages
3
Motherboard
Z170-HD3
CPU
i7-6600K
Graphics
RX570
Mac
MacBook, MacBook Pro
Mobile Phone
iOS
I just wanted to say in there that post #2 was exactly what I needed to get my board running Mojave with Ethernet. Multibeast just wouldn't get ethernet working. Thanks!
 
Top