Contribute
Register

[solved] Ethernet for AppStore on GA-B250M-DS3H

Joined
Nov 13, 2016
Messages
436
Motherboard
Gigabyte Z270M-D3H
CPU
i3-7350K OC 4.5GHz
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac Pro
Classic Mac
Classic
Mobile Phone
iOS
I'm building a hack for my Dad's birthday and I'm stuck on the ethernet port. I've had success on the machine so far but can't seem to get the ethernet port to show up.

The specs on his machine are the rolling (more importantly the motherboard)

Gigabyte GA-B250M-DS3H
i3 6100
using iGPU
8GB Corsair Memory
Crucial SATA SSD
TP-Link 900N Wifi

The board states it's a realtek ethernet

Link to the site in case I'm missing a detail
http://www.gigabyte.us/Motherboard/GA-B250M-DS3H-rev-10
 
Joined
Nov 13, 2016
Messages
436
Motherboard
Gigabyte Z270M-D3H
CPU
i3-7350K OC 4.5GHz
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac Pro
Classic Mac
Classic
Mobile Phone
iOS
Ok with the help of linux (yeah linux) I was able to lookup the driver required:

Its a Realtek 8169. This is an old chip so I imagin it's supported in some capacity. I'm looking around for a compatible driver and it looks like Rehabman wrote something a long time ago in a galaxy far far away for old version of macOS.

Anyone had luck with this chipset?

I'm building a hack for my Dad's birthday and I'm stuck on the ethernet port. I've had success on the machine so far but can't seem to get the ethernet port to show up.

The specs on his machine are the rolling (more importantly the motherboard)

Gigabyte GA-B250M-DS3H
i3 6100
using iGPU
8GB Corsair Memory
Crucial SATA SSD
TP-Link 900N Wifi

The board states it's a realtek ethernet

Link to the site in case I'm missing a detail
http://www.gigabyte.us/Motherboard/GA-B250M-DS3H-rev-10
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,950
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
I'm building a hack for my Dad's birthday and I'm stuck on the ethernet port. I've had success on the machine so far but can't seem to get the ethernet port to show up.

The specs on his machine are the rolling (more importantly the motherboard)

Gigabyte GA-B250M-DS3H
i3 6100
using iGPU
8GB Corsair Memory
Crucial SATA SSD
TP-Link 900N Wifi

The board states it's a realtek ethernet

Link to the site in case I'm missing a detail
http://www.gigabyte.us/Motherboard/GA-B250M-DS3H-rev-10
Check in DPCIManager->PCI List or 'lspci -nn' in Linux Terminal to see what you have.
Then install the appropriate driver (kext).
 
Joined
Nov 13, 2016
Messages
436
Motherboard
Gigabyte Z270M-D3H
CPU
i3-7350K OC 4.5GHz
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac Pro
Classic Mac
Classic
Mobile Phone
iOS
Thanks as always for your reply. I installed the latest realtek driver for ethernet. I tried different versions actually. no luck. I suppose it's lost support as I found a lot of people with trouble on this forum now that I know the chipset.

Since I need some kind of en0 for App Store I'm going to try alternatives. Unless someone has a better idea.

Check in DPCIManager->PCI List or 'lspci -nn' in Linux Terminal to see what you have.
Then install the appropriate driver (kext).
 
Joined
Nov 13, 2016
Messages
436
Motherboard
Gigabyte Z270M-D3H
CPU
i3-7350K OC 4.5GHz
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac Pro
Classic Mac
Classic
Mobile Phone
iOS
Just for details the lspci reported the 8111 or better. Maybe it's a configuration thing?

Thanks as always for your reply. I installed the latest realtek driver for ethernet. I tried different versions actually. no luck. I suppose it's lost support as I found a lot of people with trouble on this forum now that I know the chipset.

Since I need some kind of en0 for App Store I'm going to try alternatives. Unless someone has a better idea.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,950
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Just for details the lspci reported the 8111 or better. Maybe it's a configuration thing?
I don't see where you attached the 'lspci' output.
If it is 8111 (10ec:8168), install RealtekRTL81111.kext from Mieze.
 
Joined
Nov 13, 2016
Messages
436
Motherboard
Gigabyte Z270M-D3H
CPU
i3-7350K OC 4.5GHz
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac Pro
Classic Mac
Classic
Mobile Phone
iOS
Is that the multi-beast driver? I tried all three.

I don't see where you attached the 'lspci' output.
If it is 8111 (10ec:8168), install RealtekRTL81111.kext from Mieze.
 
Joined
Nov 13, 2016
Messages
436
Motherboard
Gigabyte Z270M-D3H
CPU
i3-7350K OC 4.5GHz
Graphics
RX 580
Mac
MacBook, MacBook Pro, Mac Pro
Classic Mac
Classic
Mobile Phone
iOS
Is this perhaps something I need to inject in the config.plist? I don't see the realtek driver in the file?

I do find this fun to debug so hoping to figure out the trick here. It does appear to be supported somehow so it does seem like there is a way to enable this. Also since this is a new board I imagine somebody can benefit from my work here.
 

P1LGRIM

Moderator
Joined
Mar 2, 2012
Messages
23,377
Motherboard
Lenovo ThinkStation p300 ⌘
CPU
i7-4790K
Graphics
HD 4600
Mac
MacBook Pro, Mac mini
Classic Mac
Power Mac
Mobile Phone
iOS
Is this perhaps something I need to inject in the config.plist? I don't see the realtek driver in the file?

I do find this fun to debug so hoping to figure out the trick here. It does appear to be supported somehow so it does seem like there is a way to enable this. Also since this is a new board I imagine somebody can benefit from my work here.
See Ethernet cart not found
 
Top