Contribute
Register

[Solved] Error allocating 0x#### pages at 0x####alloc type 2

Joined
Oct 11, 2016
Messages
25
Motherboard
MSI H110M
CPU
i5-6400
Graphics
Gtx 1050 ti
Have you tried to replace OsxAptioFixDrv with OsxAptioFix2Drv in EFI/CLOVER/drivers64UEFI or the other way around. I had the same issue with my Dell Precision build, replaced OsxAptioFix2Drv with OsxAptioFixDrv and issue was resolved.
Hi
You can explain how I can replace OsxAptioFixDrv with OsxAptioFix2Drv?
 
Joined
Feb 12, 2017
Messages
7
Motherboard
GA-X99 UD4-CF4
CPU
Intel Core i7-5960X
Graphics
GeForce GTX 1080 & 960
Hello good day!

im stuck here
How to fix this?
I tried change the file but heres the message.

IMG_0518.JPG
Im using
GA-X99 UD4
I7 5960x
32gb ram
Gtx 1080 and 960
 
Joined
Dec 7, 2011
Messages
11
Motherboard
Asus Z270 ROG MAXIMUS IX FORMULA
CPU
Intel i7 7700K
Graphics
MSI Geforce 1080Ti Gaming X
Mac
MacBook Pro
Mobile Phone
iOS
I changed my drive boot priorities in BIOS and got pass the error.

Edit: This was unrelated and did not work the 20-30 tries after to boot.
The one thing that did solve it though was replacing OsxAptioFix2Drv with OsxAptioFix2Drv-free2000.efi (also removed "-free2000" so it replaces the old file).

I mounted the EFI-partition with Clover Configurator and followed these instructions https://nickwoodhams.com/x99-hackintosh-osxaptiofixdrv-allocaterelocblock-error-update/

Big thanks to hoangmrb for the link.
 
Last edited:
Joined
Dec 7, 2011
Messages
11
Motherboard
Asus Z270 ROG MAXIMUS IX FORMULA
CPU
Intel i7 7700K
Graphics
MSI Geforce 1080Ti Gaming X
Mac
MacBook Pro
Mobile Phone
iOS
Update: Had issues with this again but it came down to not having XMP activated in BIOS. I also deactivated memory/RAM fastboot which seems to have solved the issue
 
Last edited:
Joined
Oct 22, 2013
Messages
23
Motherboard
DELL T3600
CPU
Xeon E5-1650
Graphics
NVIDIA QUADRO 2000
Mac
MacBook Air, MacBook Pro, Mac Pro
Mobile Phone
iOS
I replaced OsxAptioFix2Drv with OsxAptioFixDrv and at least for 2 consecutive boots it worked.
I found OsxAptioFix2Drv in EFI/CLOVER/drivers64UEFI but I can't find OsxAptioFixDrv anywhere. Any advice would be appreciated.
 

Feartech

Moderator
Joined
Aug 3, 2013
Messages
12,920
Motherboard
Asus N752VX-Clover
CPU
i7-6700HQ / HM170
Graphics
HD530 + GTX 950m 1920 x 1080
Mac
iMac
Mobile Phone
iOS
I found OsxAptioFix2Drv in EFI/CLOVER/drivers64UEFI but I can't find OsxAptioFixDrv anywhere. Any advice would be appreciated.
when you install Clover you should be able to choose OsxAptioFixDrv or OsxAptioFix2Drv
 
Joined
Jun 9, 2013
Messages
10,935
Motherboard
GA-H77N-WIFI
CPU
Core i7-3770
Graphics
Intel HD 4000
Mac
MacBook, Mac mini
Mobile Phone
Android
Joined
Oct 22, 2013
Messages
23
Motherboard
DELL T3600
CPU
Xeon E5-1650
Graphics
NVIDIA QUADRO 2000
Mac
MacBook Air, MacBook Pro, Mac Pro
Mobile Phone
iOS
hah! Such a boob questions. Thanks gents, Still struggling tho. No matter what I try, Im still subject to two things bad, sprinkled in with a flawless boot.

1) a sudden reboot
2) the fun no smoking sign / error allocating.

So frustrating. How can I find more clues?

Thanks
 
Joined
Dec 8, 2012
Messages
43
Motherboard
Lenovo ThinkPad W520
CPU
i7-2760QM
Graphics
HD 3000 (disabled) + Quadro 1000M
Mobile Phone
Android, iOS
Try replace the OsxAptioFix2Drv with OsxAptioFix2Drv-free2000.efi. It worked for me so far.
More info here: https://nickwoodhams.com/x99-hackintosh-osxaptiofixdrv-allocaterelocblock-error-update/
Thank you so much! I've had this issue preventing me from installing 10.12.5.

The funny thing is, I made myself a pack file containing everything for my laptop for a perfect macOS install, it worked perfectly without any modifications until now.

I needed the command "slide=0" which uses OsxAptioFix2Drv because it fixes artifacting in macOS.

Again, thanks!
 
Top