Contribute
Register

[Solved] Dell Optiplex 7040 SFF, can't reach installer

Joined
Jan 2, 2019
Messages
19
Motherboard
Dell Optiplex 7040 SFF
CPU
i5-6500
Graphics
Intel integrated
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
pastrychef,

I'm not seeing any love from your EFI. I'm trying the EFI_v4 and trying to install Catalina. Using your file directly, I get the "Prohibited" sign. When I put the USBInjectAll kext in, I get all the way to the graphics part, then I reboot/loop there.

No love here. Any Ideas?
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,348
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
pastrychef,

I'm not seeing any love from your EFI. I'm trying the EFI_v4 and trying to install Catalina. Using your file directly, I get the "Prohibited" sign. When I put the USBInjectAll kext in, I get all the way to the graphics part, then I reboot/loop there.

No love here. Any Ideas?

Please boot in verbose mode (clicking do not reboot on panic will help too) and post a picture of where it gets stuck.
 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,348
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
Joined
Jan 2, 2019
Messages
19
Motherboard
Dell Optiplex 7040 SFF
CPU
i5-6500
Graphics
Intel integrated
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Please boot in to verbose mode and post a picture of where it stops.
my experience is identical to this post I made a while ago. There is a video

 

pastrychef

Moderator
Joined
May 29, 2013
Messages
17,348
Motherboard
Gigabyte Z390 M Gaming
CPU
i9-9900K OC'd @ 5.0GHz
Graphics
Vega 56 (Bios flashed to 64)
Mac
  1. MacBook
  2. Mac Pro
Classic Mac
  1. iBook
  2. Power Mac
  3. PowerBook
Mobile Phone
  1. iOS
my experience is identical to this post I made a while ago. There is a video


This is a graphics issue. Make sure that you have set DVMT Prealloc to at least 64MB.

Screen Shot 2020-02-27 at 8.54.21 AM.png
(Btw, nicely filmed!! What method did you use??)

On OEM Dell systems, this BIOS setting is often hidden. There are different ways to circumvent this; (1) change the hidden BIOS setting through EFI Shell (best option, more reliable) or (2) use patches in config.plist (less desirable, less reliable option).

Heporis detailed how he did it via EFI Shell in his build thread.

Please see this guide if you want to fix it via config.plist.
 
Joined
Jan 2, 2019
Messages
19
Motherboard
Dell Optiplex 7040 SFF
CPU
i5-6500
Graphics
Intel integrated
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
thanks, pastrychef, I'll give this a try.
BTW-- I have an HDMI capture card and I plugged the Optiplex SFF into an HDMI splitter: one HDMI into capture card with capture software, and one into the monitor I was using to install.
 
Last edited:
Joined
Feb 19, 2016
Messages
18
Motherboard
dell XPS 9360
CPU
i7 7660u
Graphics
iris plus 640
Mobile Phone
  1. iOS
thanks, pastrychef, I'll give this a try.
BTW-- I have an HDMI capture card and I plugged the Optiplex SFF into an HDMI splitter: one HDMI into capture card with capture software, and one into the monitor I was using to install.
Any news about?
 
Joined
Jan 2, 2019
Messages
19
Motherboard
Dell Optiplex 7040 SFF
CPU
i5-6500
Graphics
Intel integrated
Mac
  1. MacBook Air
Mobile Phone
  1. iOS
Hey everyone -- sorry I was hot and heavy about this earlier in the year because I had time, now I'm back into trying to get this to work. I'll be trying this over the next few days.
 
Joined
Aug 25, 2013
Messages
166
Motherboard
GIGABYTE GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi Irael,

what did you do with config.plist? is there some way to load it.(New to this.) I can't seem to find a guide to it...I got my Sierra installed to a test drive and but my shut down does log off. however, my fan still runs....
 
Joined
Aug 25, 2013
Messages
166
Motherboard
GIGABYTE GA-Z77X-UD5H
CPU
i7-3770
Graphics
RX 580
Mac
  1. iMac
  2. MacBook Pro
Mobile Phone
  1. iOS
Hi Isreal,

what do you do with the config.plist and EFI Folder when you get the file? I just loaded Sierra and it works with graphic but when I shut down my fan still runs and it doesn't complete turn off everything. any ideas? Thanks
 
Top