Contribute
Register

[Solved] Dell Inspiron 13 7359 (Mojave) No audio + Black screen after wake

Joined
Jun 10, 2019
Messages
46
Motherboard
Dell Inspiron 13 7359
CPU
i5 6200U
Graphics
HD 520
Hello guys,
Recently I installed Mojave to my laptop without any problems using the guides by @RehabMan. I applied the recommended patches and works fine. In addition my trackpad is working thanks to the VoodooI2C project and @ben9923 who help me a lot to get this work. My wifi/bt is working OOB just replacing my wireless card by the DW1560.

However I have some problems:
1. Laptop does not wake up after screen. Just black screen.
2. My audio is not working either. My audio PCI device is Intel Sunrise Point-LP HD Audio (Rev21). I have tried different ways but I could not make it work.

I generate my problem report according to FAQ using gen_debug.sh. If somebody can help me with this, I will try the best.

Thanks

411368
 

Attachments

Joined
Dec 20, 2018
Messages
328
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
Hello guys,
Recently I installed Mojave to my laptop without any problems using the guides by @RehabMan. I applied the recommended patches and works fine. In addition my trackpad is working thanks to the VoodooI2C project and @ben9923 who help me a lot to get this work. My wifi/bt is working OOB just replacing my wireless card by the DW1560.

However I have some problems:
1. Laptop does not wake up after screen. Just black screen.
2. My audio is not working either. My audio PCI device is Intel Sunrise Point-LP HD Audio (Rev21). I have tried different ways but I could not make it work.

I generate my problem report according to FAQ using gen_debug.sh. If somebody can help me with this, I will try the best.

Thanks

View attachment 411368
Hello guys,
Recently I installed Mojave to my laptop without any problems using the guides by @RehabMan. I applied the recommended patches and works fine. In addition my trackpad is working thanks to the VoodooI2C project and @ben9923 who help me a lot to get this work. My wifi/bt is working OOB just replacing my wireless card by the DW1560.

However I have some problems:
1. Laptop does not wake up after screen. Just black screen.
2. My audio is not working either. My audio PCI device is Intel Sunrise Point-LP HD Audio (Rev21). I have tried different ways but I could not make it work.

I generate my problem report according to FAQ using gen_debug.sh. If somebody can help me with this, I will try the best.

Thanks

View attachment 411368
try darkwake=0 boot arg
 
Joined
Dec 20, 2018
Messages
328
Motherboard
Gigabyte Z370 AORUS Gaming 7
CPU
i7-8700K OC 5GHz
Graphics
GTX 1080 Ti & UHD 630
Mac
iMac, MacBook Pro
Mobile Phone
iOS
did you try any other values?
 
Joined
Jun 26, 2016
Messages
32
Motherboard
Inspiron 13-7353
CPU
I7 6500U
Graphics
HD 520
Use the latest Lilo.kext and AppleALC.kext for audio. Here is my DSDT to use as a reference.
 

Attachments

Joined
Jun 26, 2016
Messages
32
Motherboard
Inspiron 13-7353
CPU
I7 6500U
Graphics
HD 520
Apply the Audio patch Layout 3 to your dsdt. Using MacIASL
 
Joined
Jun 10, 2019
Messages
46
Motherboard
Dell Inspiron 13 7359
CPU
i5 6200U
Graphics
HD 520
Thanks @ratboy10 I got my internal sound working. It was something stupid, I just uncomment #layout_id under devices/properties in my config.plist and inject audio layout 3. There was not need to manual patch my dsdt because I did it in my clover file (hot patch). However I am having these unknown characteres and option sound preferences is not showing under sound slider.

Screen Shot 2019-06-22 at 1.29.32 AM.pngScreen Shot 2019-06-22 at 1.30.16 AM.png
 
Top