Contribute
Register

[Solved] Cpu stepper - i5-3570k - P-States stuck at x16 = only 1,6ghz [on 10.13.6 & 10.14]

Joined
May 2, 2012
Messages
16
CPU
i5-3570K
Graphics
HD 4000
Hello,

Problem with my CPU which never change P-States (optimization of the voltage and CPU frequency during operation) and so stay stucked at 1,6Hhz (middle of the capacity of my cpu)

I'm trying to have CPU/GPU Native Power Management on 10.11 to 10.14 (Mojave) with a ivy bridge cpu (i5-3570k) on a Gigabyte z77-ds3h. Intel HD Graphics 4000 works goods with hw/accel, (sound could to with ssdt for alc887 with hdmi audio...).

My system detect the i5 at 3,4Ghz but when looking in the details the CPU speedstep is not working ! in fact all the cores stay permanently at 1,6Ghz.

I tryed with AppleIntelPowerManagement.kext, patch for ivy bridge cpu series, no error in log but still same problem..

i check the result in Intel Power Gadget App (v 3.5.5) even in HWMonitor with plugins from FakeSMS) same result:
-> No intel P-States (speedstep levels) working :/ .it stuck at x16 => 1,6GHz in my case (cf 1st screenshot)

Even with AppleIntelInfos.dat technics.. no good result

Then I tested with the activation of XCPM (Patch option in clover: KernelXCPM = YES)
After reboot XCPM seems to be activating in the system, :
#>sysctl -n machdep.xcpm.mode return 1
log : XCPM: registered
IOPPF: XCPM mode​
However cpu still stuck at 1,6GHz..


i've tested the SSDT.aml method (piker ssdtPRGen.sh with lot of options tested :workarounds 1 to 3 / xcpm 0/1 / ...) in EFI/CLOVER/ACPI/patched/ .

On my clover's config.plist i disable all the "Generate Options"
I keep only few "Kernel and Kext patches" : KernelXCPM and AppleRTC

I put my full ioreg file : ioreg i5-3570k.ioreg.
Looks at CPU0 / AppleACPICPU / X86PlatformPlugin / Cstates / ..​
(for information here is a fresh installation 10.13.6 to be sure there are no kext mods even for audio alc)


I've tested without SSDT.aml (deleting from patched) and using only config.plist with millions combinaisons of options :
SSDT : ACPI/Drop TablesSSDT/CpuPmSSDT+Cpu0Ist
Kernel & Patch : KernelXPCM / AppleIntelCPUPM / AppleRTC
Generate : Pstates / Cstates options​


i use SMBIOS models compatibles with ivy bridge (iMac13,2 / macmini6,2 / macpro..)
(actually iMac13,2 SMBIOS)


For information to test & verify the realtime cpu frequencies i use the "Intel Power Gadget" kext + app (not only the HWMonitor from FakeSMC which seems to be depreciated).
On app we can see the line for low frequency 0,8Ghz /medium 1,6Ghz (mine) / and max 2,4Ghz

I use (last versions of) Clover with kexts : FakeSMC / Lilu / Whatevergreen (placed in /EFI/kexts/others)

it's look like intel p-states cannot adjust cpu frequencies (levels)
I don't know exactly if it's working with EIST (intel speedstep) or turbo boost





ps : my bios setup is ok, and the cpu works on windows even in Vmware from mojave (that's funny!)




If you look at the screenshot your ll see on top the nominative line of cpu frequency. Mine is the blue one and never change..
 

Attachments

Last edited:
Joined
May 2, 2012
Messages
16
CPU
i5-3570K
Graphics
HD 4000
I forget to upload the ssdt info file from ssdtPRGen.sh script (ssdt.aml generation in Clover/ACPI/..SSDT.aml)

Found 23 P-States but only one level is active on my high-sierra/mojave system (and the 1,6ghz one.. it does not do much :)

i tested with differents options : xcpm (-x 0) and the workaround (-c 1 / -c 2 / -c 3)
.with -p i5-3570K (cpu model)
and -m iMac13,2 (smbios model)
I Activate XCPM on my system by kernel patch then i try options xcpm 1 "-x 1" but same problem..


With ApplinteInfos.kext, data the last lines of results (about P-States) :
P-State ratio * 100 = Frequency in MHz
------------------------------------------
CPU P-States [ (16) ] iGPU P-States [ (7) ]

????????
??
I tested with AppleIntelCPUPowerManagementInfo.kext and there are no more p-states generations found in
lines "AICPUPMI:")

A) You think ACPI specifications are evolved and need to create or patch others parameters to get it working on 10.13+ systems?

B) is it possible to provide the p-states data to ssdtPRGen script ? Like with -f option for provide frequency

C) I m looking in the ioreg, comparing values in dsl file .. Others solutions to manipulate and test realtime cpu p-states ?


i 'm actually checking all my configuration and making clean & doing logs...
 

Attachments

Last edited:
Joined
Jan 13, 2017
Messages
181
Motherboard
Astock Z390 extreme 4
CPU
i9 9900K
Graphics
RX580
Mac
iMac, Mac Pro
Classic Mac
Apple
Mobile Phone
iOS
Hi I have Z77 extreme 4 - ASRock. I try to disable
asrock bios intel speedstep but not luck again is crash and restart.
is some one have other idea how to enable ssdt cpu stepping on ivybridge ?
 
Top