Contribute
Register

[Solved] Clover 4674 Issues

Joined
Jan 2, 2018
Messages
28
Motherboard
Gigabyte Z370 Aorus Ultra Gaming
CPU
i7 8800 3.7 GHz
Graphics
Onboard (Intel HD 6xx)
Mac
iMac
Mobile Phone
iOS
I'm having a similar problem, Updated to r4674. I can make it to the clover boot screen however upon selecting any of my drive options my machine goes into a reboot cycle w/o ever getting a glimpse of the apple logo. I'm not even able to load my Bootable USB or CC clone backup drive.

Here's where I probably screwed myself over -- I updated clover AFTER installing Mojave update and my USB drive and Clone are for HS.

Do I have any hope here of getting my system back? Can I revert clover versions w/o being able to boot (shell?)
 
Joined
Jan 18, 2017
Messages
60
Motherboard
b250m-gaming 3
CPU
i5 7400
Graphics
gtx 1060
Mobile Phone
iOS
have same problem gonna try p1lgrim solution
 
Joined
Jan 18, 2017
Messages
60
Motherboard
b250m-gaming 3
CPU
i5 7400
Graphics
gtx 1060
Mobile Phone
iOS
I'm having a similar problem, Updated to r4674. I can make it to the clover boot screen however upon selecting any of my drive options my machine goes into a reboot cycle w/o ever getting a glimpse of the apple logo. I'm not even able to load my Bootable USB or CC clone backup drive.

Here's where I probably screwed myself over -- I updated clover AFTER installing Mojave update and my USB drive and Clone are for HS.

Do I have any hope here of getting my system back? Can I revert clover versions w/o being able to boot (shell?)
i dont think you can revert this way but just get another hdd from and old pc and boot into it and move the backup to efi
 
Joined
Sep 2, 2010
Messages
27
Motherboard
GA-P55-UD3L rev 2.3, socket LGA 1156
CPU
Intel Core I7 860 @t 2.93 MgHz
Graphics
Nvidia Geforce GTX 750 Ti OC 2GB GDDR5
Mobile Phone
iOS
I have the same problem. After update to 4674 simply can't reach the boat loader. Went back to older version. Booting without problem again .
 
Joined
Apr 3, 2017
Messages
3
Motherboard
Gigabyte Z170x-Gaming 6
CPU
i7-6700K
Graphics
GTX 960
Mac
iMac
Mobile Phone
Android
Use r4658 from RehabMan - Link.

Most people only need :
ApfsDriverLoader-64.efi (or apfs.efi)
AptioMemoryFix-64.efi
FSInject-64.efi
HFSPlus.efi (or vboxhfs-64-efi)

so make sure that you have at least those.
Sierra 10.12.4
CPU: Intel i7-6700k
GPU: Nvidia GTX 960 4gb
Motherboard: Gigabyte Z170x-Gaming 6

I just upgraded to Clover Version 2.4 rev 4674, and haven't been able to boot into MacOS Sierra. My install was working flawlessly up until I upgraded clover. When I boot into Sierra now, I am met with a black screen and nothing else... Have tried selecting "inject Nvidia" and "Use Web Drivers" but beyond those two things, I am quite lost.

SOLVED:
I went to use my backup USB but that didn't work. So I went to the store and got a new 16gb USB drive, store clerk was praying for me after I told him my computer problems lol.
  1. First I used my macbook to create a new MacOS Sierra 10.12.4 installer USB via this tonymacx86 guide

  2. After making the installer I went into my BIOS boot menu, and booted off of my new Kingston USB to get into my operating system. Now to reconfigure Clover!

  3. With what little VRAM I had, I proceeded to follow this guide. This is what I think this fixed the original boot problem. I replaced the files in my broken Sierra boot drive with what I downloaded from Rehabman. I used Clover_v2.4k_r4658 (this is a direct download link).

  4. Restarted my computer and tried booting into my original disk!
I tried doing this without copying over the "drivers64" folder the first time and Clover booted wrong, not showing ANY boot media at all. I wonder if that has to do with the HFSPlus.efi?

On top of this I found a guy in the hackintosh Discord (infinityespi) gave me his High Sierra EFI folder! I wasn't sure if it would work for my Sierra install, but looks like the High Sierra EFI files work for booting Sierra as well.
Replaced the files and rebooted the machine. Make sure you include the "drivers64" folder, and the "drivers64UEFI" folder into your /EFI/CLOVER folder. If the link doesn't work for you, then try and get a hold of someone's EFI folder. Special thanks to you infinity, cheers bro.

I'll happily share my EFI folder if anyone thinks it will help them. It's supposedly optimized for High Sierra, however this folder is working for my version of Sierra 10.12.4. I am now running Clover r4658.
 
Joined
Jan 17, 2018
Messages
6
Motherboard
z370 msi sli plus
CPU
8700k
Graphics
770
I don't have my original usb but have all my efi files and post files on my mac hard drive. Any way I can fix this without a backup usb?
 
Joined
Mar 3, 2014
Messages
618
Motherboard
Gigabyte Z390 I AORUS PRO WIFI
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Air
Classic Mac
Power Mac
Same problem here (sorry for my cross-post) but what if the install USB doesn't get me to the desktop? I just downloaded RehabMan's 4658 Clover, but how the heck can I get it onto my Hack if I can't get the OS up?
 
Joined
Mar 4, 2010
Messages
4,719
Motherboard
ASUS ROG Strix Z270E-Gaming
CPU
i5-7600K
Graphics
Vega 64
Mac
MacBook Pro
Classic Mac
Power Mac
Mobile Phone
Android, iOS
Same problem here (sorry for my cross-post) but what if the install USB doesn't get me to the desktop? I just downloaded RehabMan's 4658 Clover, but how the heck can I get it onto my Hack if I can't get the OS up?
Moin wstrohm.
Download a Clover iso file at https://sourceforge.net/projects/cloverefiboot/files/Bootable_ISO/

If you havn't any working Operating System, ask a friend for sharing his Computer to download any Linux Live Distribution and make a bootable Pendrive. On that LiveLinux you can extract and mount the Clover Iso. You can also mount your EFI Partition to copy Files from Clover Iso to your EFI Partition. To find your EFI, type in a Terminal sudo lsblk , to mount your EFI you must create a Folder to mount the EFI in that Folder. For example: /home/Liveuser/Desktop/1
Then in Terminal type sudo mount /dev/sda1 /home/Liveuser/Desktop/1
/dev/sda1 is just an example. You have to use the output of your EFI Partition from lsblk before. May be it's /dev/sdb1 or
/dev/sdc1...depending on how much Drives you have installed. You also can edit your config.plist

FYI: Updates to the newest Clover has switched from OsxAptioFix3Drv-64.efi to AptioMemoryFix-64.efi. And if you have PartitionDxe-64.efi and ApfsDriverLoader-64.efi, you don't need apfs.efi in EFI/Clover/drivers64UEFI any longer.

These are my Drivers for Mojave in EFI/CLOVER/drivers64UEFI

Good Luck.

Bildschirmfoto 2018-09-27 um 15.06.57.png
 
Joined
Jan 2, 2018
Messages
28
Motherboard
Gigabyte Z370 Aorus Ultra Gaming
CPU
i7 8800 3.7 GHz
Graphics
Onboard (Intel HD 6xx)
Mac
iMac
Mobile Phone
iOS
i dont think you can revert this way but just get another hdd from and old pc and boot into it and move the backup to efi
How about plugging my backup drive into another mac, loading up clover there and fixing the EFI? From there I could boot to my backup and then fix the EFI on my main harddrive (Since its an nVME and currently dont own an external enclosure for that).

MY backup has High Sierra and main drive is Mojave (didnt get a chance to update the backup prior to my mishap here.. Theoretically this should work right?
 
Top