[Solved] Can't get Network to work on i219-v

Discussion in 'Network' started by CHALRWSS, Jun 14, 2018.

  1. CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    Jun 14, 2018 at 9:09 AM #1
    CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    I hello all I'm quite confused and frustrated I've been trying to get my net work drives to work for hours and I've tried 3 so far, AppleIntel1000 and another one(named after a cat) that supports the v2 of my chip set. The way I go about installing is through kext utilities and I've tried unibeast and neither seem to work. I've tried older and newer versions of the kext with no luck, am I just missing a step ?

    MB: MSI h370 carbon pro
    GTX 1080
    I5 8600k
     
  2. P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jun 14, 2018 at 11:57 AM #2
    P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Remove any previous failed attempts from /System/Library/Extensions.

    Open Finder and browse to /Library/Preferences/SystemConfiguration/ then delete these two files :
    • NetworkInterfaces.plist
    • preferences.plist

    Download this kext (click Download Now) and put it on your desktop.
    Download and run KextBeast selecting /Library/Extensions as the location.

    In Terminal :
    Code (Text):
    sudo kextcache -i /
    Press return, type your password (it will not show on screen), press return again and when the command has completed restart.
     
    Last edited: Jun 14, 2018
  3. CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    Jun 14, 2018 at 9:32 PM #3
    CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    Thank you for the replay but unfortunately I still have no internet installed also I notice that I did not have the networkinterface.plist file when I removed the preference.plist, is there a log file I can locate to give further insite.
     
  4. P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jun 14, 2018 at 9:35 PM #4
    P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Make sure that your Ethernet interface is not disabled in your BIOS settings.
    Also, if possible test it with a different operating system such as Windows for example.
     
  5. CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    Jun 14, 2018 at 9:36 PM #5
    CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    I assume not because my dual boot into windows allows internet
     
  6. P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jun 14, 2018 at 9:38 PM #6
    P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    We only know what you tell us.
    If you fail to mention something then as far as we are concerned it didn't happen.
     
  7. CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    Jun 14, 2018 at 9:41 PM #7
    CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    Well I'm running 10.13.0 other than that I do not believe I have left any details out and yes Ethernet interfaces is enabled
     
  8. P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jun 14, 2018 at 9:43 PM #8
    P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    The procedure detailed in Post #2 is tried and tested, if it fails for you then I have no further ideas.
     
  9. P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Jun 14, 2018 at 9:51 PM #9
    P1LGRIM

    P1LGRIM Moderator

    Joined:
    Mar 2, 2012
    Messages:
    15,794
    Motherboard:
    Lenovo ThinkStation p300 ⌘
    CPU:
    Intel i5-4570 3.2 GHz
    Graphics:
    Intel HD Graphics 4600
    Mac:
    MacBook Pro, Mac mini
    Classic Mac:
    Power Mac
    Mobile Phone:
    iOS
    Oh, wait.
    You have fully disabled SIP haven't you ?

    Post output of Terminal :
    Code (Text):
    sudo kextcache -i /
     
  10. CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    Jun 14, 2018 at 10:04 PM #10
    CHALRWSS

    CHALRWSS

    Joined:
    Jun 8, 2018
    Messages:
    14
    Motherboard:
    msi pro gaming carbon h370
    CPU:
    i58600k
    Graphics:
    gtx 1080 g1
    no I have yet to do that I will do it now and report back
     

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice