Contribute
Register

[Solved] Built-in Sound not working in El Capitan (mobo GA-P55M-UD2)

Joined
Aug 24, 2013
Messages
12
Motherboard
GA-H55M-UD2H
Mac
Classic Mac
Mobile Phone
Thanks a lot for your reply. Still don't work. :banghead:

------------------

Intel High Definition Audio:


Audio ID: 1


S/PDIF Optical Digital Audio Output:


Connection: Internal


Line Output:


Connection: 1/8-Inch Jack


External Microphone / iPhone Headset:


Connection: 1/8-Inch Jack


External Microphone / iPhone Headset:


Connection: 1/8-Inch Jack


Headphone:


Connection: 1/8-Inch Jack


S/PDIF Optical Digital Audio Output:


Connection: Combination Output


S/PDIF Optical Digital Audio Input:


Connection: Combination Input




------------------


antonios-iMac:Downloads antonio$ sudo ./audio_cloverALC-110_v1.0g.command
Password:

Agreement
The audio_cloverALC-110 script is for personal use only. Do not distribute
the patch, any or all of the files or the resulting patched AppleHDA.kext
for any reason without permission. The audio_cloverALC-110 script is
provided as is and without any kind of warranty.

File: audio_cloverALC-110.command_v1.0g
EFI partition is not mounted
Confirm Clover Legacy Install (y/n): y
MACOSX Capitan/EFI folder found
System Integrity Protection status: enabled (Custom Configuration).


Configuration:
Apple Internal: disabled
Kext Signing: disabled
Filesystem Protections: disabled
Debugging Restrictions: enabled
DTrace Restrictions: enabled
NVRAM Protections: enabled


This is an unsupported configuration, likely to break in the future and leave your machine in an unknown state.
OK to patch
Confirm Realtek ALC889 (y/n): y
Clover Audio ID Injection (y/n): y
Use Audio ID: 1 (y/n): n
Audio IDs:
1 - 3/5/6 port Realtek ALCxxx audio
2 - 3 port (5.1) Realtek ALCxxx audio (n/a 885)
3 - HD3000/HD4000 HDMI and Realtek ALCxxx audio (n/a 885/1150 & 887/888 Legacy)
Select Audio ID: 1


Download ALC889 files ...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 24438 100 24438 0 0 35753 0 --:--:-- --:--:-- --:--:-- 35728
Edit config.plist/Devices/Audio/Inject/1
Edit config.plist/SystemParameters/InjectKexts/YES
Download kext patches
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 1404 100 1404 0 0 3087 0 --:--:-- --:--:-- --:--:-- 3085
usage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file
cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ... target_directory
Install /Volumes/MACOSX Capitan/EFI/CLOVER/kexts/10.11/realtekALC.kext
Download config kext and install ...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 3586 100 3586 0 0 7611 0 --:--:-- --:--:-- --:--:-- 7597
usage: cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file target_file
cp [-R [-H | -L | -P]] [-fi | -n] [-apvX] source_file ... target_directory
Install System/Library/Extensions/AppleHDA.kext/ALC889 zml files
Fix permissions ...
Kernel cache...
rebuilding //System/Library/PrelinkedKernels/prelinkedkernel
kext-dev-mode allowing invalid signature -67054 0xFFFFFFFFFFFEFA12 for kext AppleHDA.kext
kextcache updated critical boot files, requesting launchd reboot


Install finished, restart required.
To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
-------------------
 
Joined
Aug 24, 2013
Messages
12
Motherboard
GA-H55M-UD2H
Mac
Classic Mac
Mobile Phone
I am not sure. My motherboard Users Manuals says:
-----------
Realtek ALC889 codec
High Definition Audio
2/4/5.1/7.1-channel
Support for S/PDIF In/Out
Support for CD In.
-----------

I have tried all three values, but I my config.plist is the same.

Don´t work. :banghead:


Perhaps I must delete other driver from init process.

I am not sure that driver from Realtek loads on init. I can´t see any log on /var/log/system (Linux logs are better...)


less /var/log/system

[..]
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the IOKit user-client class RootDomainUserClient.
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the IOKit user-client class IOHIDLibUserClient.
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the IOKit user-client class IOBluetoothL2CAPChannelUserClient.
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the IOKit user-client class IOBluetoothHCIUserClient.
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the IOKit user-client class IOBluetoothDeviceUserClient.
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the IOKit user-client class IOHIDResourceDeviceUserClient.
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.blued.
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod.
Oct 9 18:20:07 antonios-iMac com.apple.audio.DriverHelper[197]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.BluetoothDOServer.
[...]

 

ammulder

Moderator
Joined
Sep 1, 2014
Messages
3,430
Motherboard
GA-H87N-WIFI
CPU
i7-4790S
Graphics
GT 740
Mac
MacBook Pro, Mac mini
Mobile Phone
iOS
I don't know that you were supposed to sudo the command. I wonder if it has put root permissions on some of the output in a way that prevents it from being updated by a later script run. I would have thought changing the layout ID when you run it would make some noticeable change. Can you make sure that config.plist and the Realtek kext in CLOVER/kexts/... are owned by your user and not owned by root?
 
Joined
Aug 24, 2013
Messages
12
Motherboard
GA-H55M-UD2H
Mac
Classic Mac
Mobile Phone
SOLVED!!!!!:thumbup::thumbup::thumbup::thumbup:

I boot from USB and I need to copy the config.plist from /EFI/CLOVER to /Volumes/MACUSB/EFI/CLOVER. The script modify /EFI/CLOVER/config.plist

(MACUSB is my Pendrive USB)

I have found my error when I was looking for permisions problem. :oops:

A lot of thanks to all!!!

¡¡¡¡Gracias jzrodriguez98!!!!
 
Joined
Jun 24, 2015
Messages
7
Motherboard
10.11.05
CPU
3.4 Ghz Intel Core i7
Graphics
NVIDIA GeForce GTX 650 2048 MB
Mac
MacBook Pro
Mobile Phone
Android
I hope this doesn't count as hijacking the thread, but I am so close!

I am only having trouble with the microphone input. I have tried all 3 configs in the audio clover command. The outputs may change physical locations, but I don't mind. It's the microphone input that wont work, even on the front input as per headphones.

Can anyone suggest anything?

Thanks
 
Top