Contribute
Register

[Solved] Black screen but NOT after updating, just after rebooting

Status
Not open for further replies.
Joined
Aug 15, 2012
Messages
17
Motherboard
Hp m6-1045dx
CPU
Ivy Brige i5
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
So I go through the Corsair Bulldog Hackintosh Guide and the NVIDIA web driver works, I get GPU acceleration and multiple display output. Hooray!

But after rebooting, without changing anything, I get that dreaded black screen issue and can only boot by not using the web drivers. All I did was install some apps and sign in to iCloud. No modifying/installing of kexts, changes to clover.config, or changes to the Patched AHCI folder in EFI.

I have tried getting the latest version of Lilu.kext and NVidiaGraphicsFixup.kext, as well as tweaking the CsrConfig and that one next to it (0x3, 0x67; 0x2 and 0x28 for the one to the left of CsrConfig). I have also tried booting with the HDMI connection disconnected from the GPU (leaving 3 DP connections). I have NVidiaWebDrivers checked in CloverConfig, and also have the use_nvidiaweb flag checked in boot args (but I have tried booting without it as well). If it worked the first time, it can't be anything with my settings/me going through the motions of installing the driver. Right?

I'm on High Sierra 14C88 with an i5-7600K (iGPU disabled completely).

I'm at wit's end, fellas, and it's driving me ****ing nuts.
 
Joined
Aug 15, 2012
Messages
17
Motherboard
Hp m6-1045dx
CPU
Ivy Brige i5
Graphics
HD4000
Mac
Classic Mac
Mobile Phone
Thanks for the reply steve!

I should have specified (there are so many things to specify!), I did choose the Clover with emulated NVRAM option in Multibeast. Is there a way I can verify emulated NVRAM is actually in effect beyond that first boot when graphics work?

Actually it's probably the CSM option at issue. I did not have it enabled! For Gigabyte Motherboards, it is hidden when "OtherOS" is selected (versus Windows 8/10 or Windows 8/10 (WHQL) ). I had to look up what it even is. Now it boots off a different monitor first, but by god it works! Thank you so much!
 
Status
Not open for further replies.
Top