Contribute
Register

[solved] Audio IDT 92HD91BXX (76e0) not working in Mojave

Joined
Jun 13, 2015
Messages
13
CPU
i7-3630QM
Graphics
HD 4000 + GT 630m
Mac
MacBook Pro, Mac mini
Classic Mac
iBook, Power Mac
Mobile Phone
Android, iOS
Hi! I have recently managed to upgrade my ivy bridge laptop to macos Mojave. Everything except the audio is working fine. In the previous versions of macos, I used an AppleHDA injector kext along with DSDT and clover config patches inorder to get working audio. Due to the recent changes in how macos handles the audio, I have decided to go with the AppleALC method due to it's various advantages. However, I can't get it to work. I have read various documentions and tried almost everything but it always fails for me.
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi! I have recently managed to upgrade my ivy bridge laptop to macos Mojave. Everything except the audio is working fine. In the previous versions of macos, I used an AppleHDA injector kext along with DSDT and clover config patches inorder to get working audio. Due to the recent changes in how macos handles the audio, I have decided to go with the AppleALC method due to it's various advantages. However, I can't get it to work. I have read various documentions and tried almost everything but it always fails for me.
Use AppleALC, as per FAQ:
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
 
Joined
Jun 13, 2015
Messages
13
CPU
i7-3630QM
Graphics
HD 4000 + GT 630m
Mac
MacBook Pro, Mac mini
Classic Mac
iBook, Power Mac
Mobile Phone
Android, iOS
Hi again! I did follow the instructions mentioned in the FAQ, unfortunately without any success. I have posted my Clover folder down below.
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Joined
Jun 13, 2015
Messages
13
CPU
i7-3630QM
Graphics
HD 4000 + GT 630m
Mac
MacBook Pro, Mac mini
Classic Mac
iBook, Power Mac
Mobile Phone
Android, iOS
Hi! Here is my files from the gen_debug tool.
 

Attachments

Joined
Jun 13, 2015
Messages
13
CPU
i7-3630QM
Graphics
HD 4000 + GT 630m
Mac
MacBook Pro, Mac mini
Classic Mac
iBook, Power Mac
Mobile Phone
Android, iOS
In the DSDT?
 
Joined
Jun 13, 2015
Messages
13
CPU
i7-3630QM
Graphics
HD 4000 + GT 630m
Mac
MacBook Pro, Mac mini
Classic Mac
iBook, Power Mac
Mobile Phone
Android, iOS
So I injected the layout-id under Properties by removing the # and added the layout-id 12, the id that got my audio working in previous versions of macos. However, the sound is still not working. I know that Mojave removed plenty of layout-id's including layout-id 12. Am I still supposed to use that id under Mojave?
 

RehabMan

Moderator
Joined
May 3, 2012
Messages
188,949
Motherboard
Intel DH67BL
CPU
i7-2600K
Graphics
HD 3000
Mac
MacBook Air
Mobile Phone
iOS
So I injected the layout-id under Properties by removing the # and added the layout-id 12, the id that got my audio working in previous versions of macos. However, the sound is still not working. I know that Mojave removed plenty of layout-id's including layout-id 12. Am I still supposed to use that id under Mojave?
No "Problem Reporting" files attached.
Read FAQ, "Problem Reporting" again. Carefully. Attach all requested files/output.
https://www.tonymacx86.com/threads/faq-read-first-laptop-frequent-questions.164990/
Use the gen_debug.sh tool mentioned in the FAQ, that way it is less likely you'll omit something.
 
Top