Contribute
Register

[solved] ASUS UX430UA external display HDMI not working

Joined
Apr 21, 2012
Messages
286
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
Hi, i'm trying to connect external monitor via HDMI micro.

spec:
CPU: Kaby Lake i7-7500U
GPU: Intel HD Graphics 620
macOS Sierra: 10.12.6

In BIOS i had to enable CMS support because without that it doesn't work at all(no detect external monitor).

Flow:
- when i connect monitor via HDMI and turn on laptop, display works only on external monitor. I'm not able to switch monitor to internal display. When i disconnect cable still internal display not working(switching). I have to reboot and then internal works fine
- when i boot only on internal display and then connect external it doesn't switch or mirror displays.
- when i go to SystemPreferences->Displays i don't see second display, even when i press with cmd "detect displays"

Can someone help my with this?

Thank you
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
Hi, i'm trying to connect external monitor via HDMI micro.

spec:
CPU: Kaby Lake i7-7500U
GPU: Intel HD Graphics 620
macOS Sierra: 10.12.6

In BIOS i had to enable CMS support because without that it doesn't work at all(no detect external monitor).

Flow:
- when i connect monitor via HDMI and turn on laptop, display works only on external monitor. I'm not able to switch monitor to internal display. When i disconnect cable still internal display not working(switching). I have to reboot and then internal works fine
- when i boot only on internal display and then connect external it doesn't switch or mirror displays.
- when i go to SystemPreferences->Displays i don't see second display, even when i press with cmd "detect displays"

Can someone help my with this?

Thank you
No ig-platform-id set.
Try various valid ig-platform-id values.
 
Joined
Apr 21, 2012
Messages
286
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
ok, i'll try
I've removed all fakeId etc because since 10.12.6 Kaby Lake is native supported as "Intel HD Graphics KBL CRB 1536 MB"

Thx
 
Joined
Apr 21, 2012
Messages
286
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
No ig-platform-id set.
Try various valid ig-platform-id values.
ok, i tried to set ig-platform-id: 0x19168086 but it doesn't change situation, still no external display ;(
 

Attachments

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
ok, i tried to set ig-platform-id: 0x19168086 but it doesn't change situation, still no external display ;(
ig-platform-id 0x19168086 is not a valid ig-platform-id.
You should expect graphics drivers to be disabled when using an invalid ig-platform-id.
 
Joined
Apr 21, 2012
Messages
286
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
ig-platform-id 0x19168086 is not a valid ig-platform-id.
You should expect graphics drivers to be disabled when using an invalid ig-platform-id.
ok, tried with:
IntelGFX: 0x59128086
and ig-platform-id's:
0x59120003
or
0x59120000
or
0x59160000

and still external display/mirroring not working;(

Thx
 
Last edited:
Joined
Apr 21, 2012
Messages
286
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS

RehabMan

Moderator
Joined
May 3, 2012
Messages
191,123
Motherboard
Intel DH67BL
CPU
Core i7-2600K
Graphics
Intel HD 3000
Mac
MacBook Air
Mobile Phone
iOS
ok, files attached

Thx
You're not injecting any ig-platform-id, therefore the kexts use a default... 0x59160000.

config.plist/Graphics/ig-platform-id has no effect without config.plist/Graphics/Inject/Intel=true.
 
Joined
Apr 21, 2012
Messages
286
Motherboard
Asus UX430UA (Clover)
CPU
i7-7500U
Graphics
HD 620
Mac
iMac, MacBook Air, MacBook Pro
Mobile Phone
iOS
You're not injecting any ig-platform-id, therefore the kexts use a default... 0x59160000.

config.plist/Graphics/ig-platform-id has no effect without config.plist/Graphics/Inject/Intel=true.
upps, sorry RehabMan i forgot to set "Intel=true" ;(

so, i set inject Intel and tried with different ids for IntelGFX and ig-platform-id and still nothing
With CMS Support i can boot only on external monitor, no mirroring or switching.
Without CMS Support only internal display works.

When i changed ig-platform-id and inject Intel "About this mac" shows "Intel HD Graphics 620 1536 MB" insead of "Intel HD Graphics KBL CRB 1536 MB" - 10.12.6 native support.

Should i only change ig-platform-id and leave IntelGFX ?
If yes, can you give me some list of values i can check?

Thank you
 
Top