Contribute
Register

[Solved] ASUS TUF Z390M PRO stuck in BIOS wont boot from UEFI

Joined
Feb 24, 2013
Messages
29
Motherboard
ASUS TUF Z390M-Pro Gaming
CPU
i5 9400F
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
I am trying to install Catalina on ASUS TUF Z390M PRO which was updated to the Bios v2606. I'm stuck with a strange issue where the USB drive is recognized by the BIOS, but it never boots into it- when I select the UEFI USB to boot, the screen just flickers and goes back to the bios screen. I tried resetting the CMOS etc. If I try to boot from a Linux install USB it works fine, I have tried multiple USB drives and ports. Any pointers on how to fix this ?
 
Joined
Apr 1, 2010
Messages
312
Motherboard
ASUS Prime Z390-P
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
your USB drive is not create properly, it must contain an hiding EFI partition, you get that buy formatting it with GUID in Mac OS. or you will need to follow the guid if creating it from windows. if you do have an EFI partition, it must contain and EFI folder with needed boot files, without those, it will not boot.
 
Joined
Apr 1, 2010
Messages
312
Motherboard
ASUS Prime Z390-P
CPU
i9-9900K
Graphics
RX 5700 XT
Mac
iMac, MacBook Pro, Mac mini
Mobile Phone
iOS
That doesn't should like it would make any difference... here are two examples of what your EFI Partition should look like. one is the EFI ROOT and the other is the EFI root with folders expanded. these are from my main system but I no longer use CLOVER, I have moved on to OC
 

Attachments

Joined
Feb 24, 2013
Messages
29
Motherboard
ASUS TUF Z390M-Pro Gaming
CPU
i5 9400F
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Doesn't seem like my day. FWIW here's the mounted EFI on the USB.

Tried to create 2 versions using the same USB that won't boot.

1) Unibeast - hangs at installing bootloader.
2) Vanilla following hackintosher - I can boot a real mac with it; but it won't work on the Hackintosh.

Was suspecting a bad usb drive. But that doesn't seem to be the case.

Is the new bios messed up ? But can't explain how UEFI boot with Ubuntu works -Clueless at this point.

Screen Shot 2020-04-24 at 12.01.17 PM.png
 
Joined
Mar 10, 2011
Messages
318
Motherboard
Gigabyte Z390 Auros Pro
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
try this opencore EFI
I set it for imac 19,1
I set it for cfg lock enabled if you can turn it off refer to coffee lake guide and cfg lock section in the guide

here is the guide for OpenCore

 

Attachments

Joined
Feb 24, 2013
Messages
29
Motherboard
ASUS TUF Z390M-Pro Gaming
CPU
i5 9400F
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
try this opencore EFI
I set it for imac 19,1
I set it for cfg lock enabled if you can turn it off refer to coffee lake guide and cfg lock section in the guide

here is the guide for OpenCore

Never tried opencore before, Can we do a vanilla install and just copy the OpenCore EFI to it ?
 
Joined
Mar 10, 2011
Messages
318
Motherboard
Gigabyte Z390 Auros Pro
CPU
i9-9900K
Graphics
RX 580
Mac
MacBook Pro
Mobile Phone
iOS
Yes you can

Try that EFI on a GUID partitioned USB drive or your install usb
I just copied it to my desktop to modify platform and the 2 quirks related to CFG Lock
your board should have a way to disable cfg lock in bios
us with gigabyte boards have to use a modified grub shell in UEFI to do so

I put on my USB and my Time Machine backup drive EFI partiton
I have it 2 other USB sticks as well

I pointed you to the guide in hopes it will make it easy
there is a Config.plist sanity checker its listed in the guide as well usually at end of each guide for a particular chip set, in our case Coffee Lake

you can even create usb install in windows as well now
 
Top