Contribute
Register

[Solved]ASUS H370-i I7-8700 Mojave 10.14.1 UHD630 driving need help!

osd

Joined
Nov 15, 2018
Messages
15
Motherboard
ASUS ROG STRIX H370-I GAMING
CPU
i7-8700
Graphics
UHD 630
Mobile Phone
Android, iOS
I have asus H370-i ITX board to install Mojave 10.14.1, only use its IGPU UHD630. But I can only access to desktop by using "inject Intel" with ig-platform-id:0x12345678 in Clover. The Graphic card showed in Apple system is "intel Graphics UHD630 7M".

I have tried to inject many other ig-platform id like 3E920000, 3E9B00007..... but all blank screen.

I also tried to use newest rev. Intel PB-Patcher to patch config.plist, using 3E920003,3E9B0007 and other ID. but all blank screen.

The Mainboard has one DP, one HDMI, and one USB type-C may also can output display. I guess the issue may caused by the video ouput connectors configuration.

Does anyone have the experience on driving UHD630 on this board? Can someone help me? Thanks very much!
 

osd

Joined
Nov 15, 2018
Messages
15
Motherboard
ASUS ROG STRIX H370-I GAMING
CPU
i7-8700
Graphics
UHD 630
Mobile Phone
Android, iOS
zero reply?
 
Joined
Dec 7, 2015
Messages
23
Motherboard
HP 83F0, BIOS: HP Q03 Ver.02.04.00
CPU
I7-8700
Graphics
UHD 630
Mobile Phone
iOS
my I7-8700 got same problem, either 7MB or black screen....
 
Joined
Sep 19, 2010
Messages
541
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7 4790K
Graphics
RX 480
Mac
iMac
Mobile Phone
iOS
Have you tried using WhateverGreen + Lilu kext? If not then, place both these files in the Other folder, uncheck “Inject Intel”, and remove all other graphics patches you have applied in your config file. Also, make sure that “Detect kexts=Yes” has been set in the config file. See if this works.
 
Joined
Dec 7, 2015
Messages
23
Motherboard
HP 83F0, BIOS: HP Q03 Ver.02.04.00
CPU
I7-8700
Graphics
UHD 630
Mobile Phone
iOS
Have you tried using WhateverGreen + Lilu kext? If not then, place both these files in the Other folder, uncheck “Inject Intel”, and remove all other graphics patches you have applied in your config file. Also, make sure that “Detect kexts=Yes” has been set in the config file. See if this works.
I've followed the instruction https://www.tonymacx86.com/threads/guide-intel-framebuffer-patching-using-whatevergreen.256490/, compiled Lilu and WhateverGreen, did all I can do.

But I have difficulty to do the "Framebuffer Dumps". I put -igfxdump in the clover boot flag and using debug version of Lilu+WhateverGreen, but I can't get the dump file.
 
Joined
Sep 19, 2010
Messages
541
Motherboard
Asus Z87 Maximus Gene VI
CPU
i7 4790K
Graphics
RX 480
Mac
iMac
Mobile Phone
iOS
What happens if you just use precompiled kexts found on their respective website? For the most part, Whatevergreen should be able to detect your iGPU and apply appropriate settings without you having to make any changes in the config file.
 

osd

Joined
Nov 15, 2018
Messages
15
Motherboard
ASUS ROG STRIX H370-I GAMING
CPU
i7-8700
Graphics
UHD 630
Mobile Phone
Android, iOS
Have you tried using WhateverGreen + Lilu kext? If not then, place both these files in the Other folder, uncheck “Inject Intel”, and remove all other graphics patches you have applied in your config file. Also, make sure that “Detect kexts=Yes” has been set in the config file. See if this works.
Yes, I have tried newest rev. WhateverGreen+Lilu Kext, but also get black screen.
 
Joined
Nov 8, 2018
Messages
4
Motherboard
Asus ROG Strix H370-I Gaming
CPU
i7 8700k
Graphics
HD 630
+1 here, @osd have you figured a way around this issue?
I have ASUS ROG Strix H370-I Also with only intel gfx + i7 8700k
 
Top