Contribute
Register

Solved! Anyone have USB 3.0 working on their Gigabyte GA-Z170-X UD5 TH under Sierra?

Status
Not open for further replies.
Joined
Aug 22, 2016
Messages
284
Motherboard
Gigabyte GA-Z170X-UD5 TH (F22g)
CPU
i7 6700K
Graphics
HD 530
If so, I'd appreciate knowing what you had to do? So far I'm not having any success here with Sierra. USB 3.0 worked fine with El Capitan here. Thanks.
 
Joined
Oct 7, 2012
Messages
122
Motherboard
ROG Maximus XII Hero Wi-Fi
CPU
i9-10900K
Graphics
RX 6900XT Sapphire Nitro+
Mac
  1. MacBook
Yep i do.What fixes have you ran?
 
Joined
Jan 6, 2014
Messages
14
Motherboard
Z170X-UD5 TH
CPU
i7-6700K
Graphics
GT 710
Mobile Phone
  1. iOS
Hi In-N-Out,
USB 3 is not working for me since I went to Sierra, same MB... I tried the new USBinjectAll.kext too, but it didn't changed anything.
I made a direct update from El Cap to Sierra, I'm planning to try with a full install.
 
Joined
Aug 22, 2016
Messages
284
Motherboard
Gigabyte GA-Z170X-UD5 TH (F22g)
CPU
i7 6700K
Graphics
HD 530
Hi Traj13, Well I'm using the full install of Sierra here and the problem remains. I'm still unable to get my 3.0 ports working. Interested to hear back from Totti with his procedure since he says he has it working with our motherboard.
 
Joined
Aug 22, 2016
Messages
284
Motherboard
Gigabyte GA-Z170X-UD5 TH (F22g)
CPU
i7 6700K
Graphics
HD 530
wtgserpant, Thank You! That worked, finally! Yippee! :) Thanks goes to RehabMan!

Traj13, make sure to use the 100 series edit. I created the 12.1 folder placed RehabMan's kext in it as well as the other folder (see below).

Screen Shot 2016-10-08 at 4.10.13 PM.png
 
Last edited:
Joined
Jan 6, 2014
Messages
14
Motherboard
Z170X-UD5 TH
CPU
i7-6700K
Graphics
GT 710
Mobile Phone
  1. iOS
Thanks guys! I will try this afternoon.

EDIT : I made something wrong, USB 3 not working.

I paste USBinjectAll in both 10.12 and Other folder, like in your screenshot.
Then I copy/paste the 100 series code in my config.plist :
Code:
            <dict>
                <key>Comment</key>
                <string>change 15 port limit to 26 in XHCI kext (100-series) 10.12</string>
                <key>Find</key>
                <data>g710////EA==</data>
                <key>Name</key>
                <string>AppleUSBXHCIPCI</string>
                <key>Replace</key>
                <data>g710////Gw==</data>
            </dict>

But no USB 3. In-N-Out, maybe you can help me?
 
Last edited:
Joined
Aug 22, 2016
Messages
284
Motherboard
Gigabyte GA-Z170X-UD5 TH (F22g)
CPU
i7 6700K
Graphics
HD 530
Traj13, that is exactly what I did here. Are you sure you are putting it under KernelAndKextPatches/KextsToPatch in config.plist, like this?

Screen Shot 2016-10-10 at 4.59.32 PM.png
 
Last edited:
Status
Not open for further replies.
Top