Contribute
Register

(Solved) ALC892 and audio_cloverHDMI-130_v0.8.command: Problems getting AppleHDA patched for GTX 970

Status
Not open for further replies.
Joined
Jun 19, 2015
Messages
55
Motherboard
GA-Z97-D3H
CPU
i7-4790K
Graphics
Vega64
Mac
  1. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
I'm trying to sort out my HDMI Audio and the last time I used Lilu.kext and AppleALC previously, I needed the ALC892 directory inside /Clover/Kexts/Other in order to run audio_cloverALC-130_v0.5.command and audio_cloverHDMI-130_v0.8.command. Anyway, I just installed ALC892 using Multibeast HighSierra and I don't see the ALC892 folder anywhere in clover.

I already generated my SSDT and DSDT and placed them into /CLOVER/ACPI

also AppleALC and Lilu are both inside of /CLOVER/KEXTS/Other

Am I missing something? I was also expecting to see the same ALC892 folder inside /Clover/Kexts/Other but I don't see it.
 

toleda

Moderator
Joined
May 20, 2010
Messages
24,086
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Jun 19, 2015
Messages
55
Motherboard
GA-Z97-D3H
CPU
i7-4790K
Graphics
Vega64
Mac
  1. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Thanks for the response, I removed everything from /CLOVER/KEXTS/Other and ran the script but I don't see the HDMI output. Here is what the command returns:

sed$ /Users/ted/Desktop/audio_cloverHDMI-130_v0.8.command



Agreement

The audio_cloverHDMI script is for personal use only. Do not distribute

the patch, any or all of the files for any reason without permission.

The audio_cloverHDMI script is provided as is and without any warranty.



File: audio_cloverHDMI-130_v0.8.command

Release Mode

EFI partition is mounted

Password:

No HDMI audio codec(s) detected, continue (y/n): y

HDMI audio codec(s)

Integrated Graphics is not installed/enabled

Install AMD/Nvidia HDMI audio (y/n): y

Nvidia discrete graphics card 10de13c2 found on PEG0@1/PEGP@0

Nvidia HDMI audio is not enabled

Install Nvidia HDMI audio ssdt (y/n): y

Download SSDT-HDMI-NVIDIA-PEG0 ...

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

100 44888 100 44888 0 0 185k 0 --:--:-- --:--:-- --:--:-- 186k

/Volumes/EFI/EFI/CLOVER/ACPI/patched/SSDT-HDMI-NVIDIA-PEG0.aml installed


Install finished, restart required.

To save a Copy of this Terminal session: Terminal/Shell/Export Text As ...
 
Last edited:
Joined
Jun 19, 2015
Messages
55
Motherboard
GA-Z97-D3H
CPU
i7-4790K
Graphics
Vega64
Mac
  1. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Search: property list editor

Thank you Toleda, I skipped the property list editor step and just followed: AppleHDA HDMI Audio_v2 [Guide] post #2 Like you said and workaround #1 got me sorted out. :)
 

Attachments

  • Screen Shot 2018-05-18 at 3.07.16 PM.png
    Screen Shot 2018-05-18 at 3.07.16 PM.png
    895.4 KB · Views: 388

toleda

Moderator
Joined
May 20, 2010
Messages
24,086
Motherboard
Asus Maximus VII Impact
CPU
Core i7-4770K
Graphics
RX 560 + HD4600
Mac
  1. iMac
  2. MacBook Pro
  3. Mac mini
Classic Mac
  1. 512K
  2. LC
  3. Power Mac
Mobile Phone
  1. iOS
Joined
Jun 19, 2015
Messages
55
Motherboard
GA-Z97-D3H
CPU
i7-4790K
Graphics
Vega64
Mac
  1. Mac mini
Classic Mac
  1. iMac
Mobile Phone
  1. Android
  2. iOS
Status
Not open for further replies.
Top